Bug 13936 - Fix patrons search on using the checkout tab
Summary: Fix patrons search on using the checkout tab
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Patrons (show other bugs)
Version: 3.20
Hardware: All All
: P5 - low critical (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on: 13894
Blocks:
  Show dependency treegraph
 
Reported: 2015-04-01 10:06 UTC by Jonathan Druart
Modified: 2016-06-21 21:37 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 13936: Last patch contained wrong change (1.11 KB, patch)
2015-04-01 10:07 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 13936: Last patch contained wrong change (1.20 KB, patch)
2015-04-07 07:30 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 13936: Last patch contained wrong change (1.20 KB, patch)
2015-04-08 08:30 UTC, Nicolas Legrand
Details | Diff | Splinter Review
Bug 13936: Last patch contained wrong change (1.26 KB, patch)
2015-04-08 08:32 UTC, Nicolas Legrand
Details | Diff | Splinter Review
[PASSED QA] Bug 13936: Last patch contained wrong change (1.51 KB, patch)
2015-04-09 22:12 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Druart 2015-04-01 10:06:16 UTC

    
Comment 1 Jonathan Druart 2015-04-01 10:07:28 UTC Comment hidden (obsolete)
Comment 2 M. Tompsett 2015-04-02 04:34:14 UTC
Test plan?
Comment 3 Jonathan Druart 2015-04-07 07:30:18 UTC Comment hidden (obsolete)
Comment 4 Nicolas Legrand 2015-04-08 08:30:04 UTC Comment hidden (obsolete)
Comment 5 Nicolas Legrand 2015-04-08 08:32:39 UTC Comment hidden (obsolete)
Comment 6 Katrin Fischer 2015-04-09 22:12:03 UTC
Created attachment 37632 [details] [review]
[PASSED QA] Bug 13936: Last patch contained wrong change

One of the 2 changes done in the last patch was not for this bug report.

The tt change was intended for bug 13926.

This patch reverts it.

BE CARE: This should NOT be pushed AFTER bug 13926!

Test plan:
Search for a patron using the 'check out' tab in the circulation module.

Signed-off-by: Nicolas Legrand <nicolas.legrand@bulac.fr>
Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
- use the checkout tab to search for a patron
  not using the autocomplete, but hitting enter
- without the patch, there won't be results
- with the patch there are

Passes all tests and QA script.
Comment 7 Tomás Cohen Arazi 2015-04-12 03:55:46 UTC
Patch pushed to master.

Thanks JOnathan!
Comment 8 Tomás Cohen Arazi 2015-06-25 17:44:23 UTC
Pinging Chris
Comment 9 Jonathan Druart 2015-07-02 08:22:32 UTC
(In reply to Tomás Cohen Arazi from comment #8)
> Pinging Chris

This has been pushed to master before the 3.20 release, so it can be marked as resolved.