Bug 14813 - Encoding issues when editing the help
Summary: Encoding issues when editing the help
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Documentation (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on: 11944
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-14 09:34 UTC by Jonathan Druart
Modified: 2016-06-21 21:38 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 14813: Fix encoding issues on editing help pages (1.98 KB, patch)
2015-09-14 09:39 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 14813: Fix encoding issues on editing help pages (2.04 KB, patch)
2015-09-14 11:42 UTC, Josef Moravec
Details | Diff | Splinter Review
[PASSED QA] Bug 14813: Fix encoding issues on editing help pages (2.11 KB, patch)
2015-09-14 20:26 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Druart 2015-09-14 09:34:55 UTC
To reproduce:
Install and set the fr-FR language (or ar-Arab).
Go on the help page and edit it.
The textarea will contain encoding issues.
Comment 1 Jonathan Druart 2015-09-14 09:35:15 UTC
Seems to be introduced by 11944.
Comment 2 Jonathan Druart 2015-09-14 09:39:24 UTC Comment hidden (obsolete)
Comment 3 Josef Moravec 2015-09-14 11:42:59 UTC Comment hidden (obsolete)
Comment 4 Katrin Fischer 2015-09-14 20:26:43 UTC
Created attachment 42543 [details] [review]
[PASSED QA] Bug 14813: Fix encoding issues on editing help pages

It has been introduced by bug 11944.

Test plan:
1/ Install and set the fr-FR language (or ar-Arab).
2/ Go on the help page and edit it.
3/ The textarea should not contain encoding issues with this patch.

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 5 Tomás Cohen Arazi 2015-09-16 13:54:32 UTC
Patch pushed to master.

Thanks Jonathan!
Comment 6 Chris Cormack 2015-09-22 17:37:07 UTC
Pushed to 3.20.x will be in 3.20.4
Comment 7 Liz Rea 2015-09-23 00:00:39 UTC
Pushed to 3.18.x will be in 3.18.11
Comment 8 Jonathan Druart 2015-09-23 07:48:27 UTC
(In reply to Liz Rea from comment #7)
> Pushed to 3.18.x will be in 3.18.11

Are you sure the issue existed in 3.18.x?