Bug 14902 - Add qualifier menu to staff side "Search the Catalog"
Summary: Add qualifier menu to staff side "Search the Catalog"
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Searching (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Target Milestone: ---
Assignee: Nick Clemens
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
: 15132 (view as bug list)
Depends on:
Blocks: 16799 19046
  Show dependency treegraph
 
Reported: 2015-09-25 16:27 UTC by HB-NEKLS
Modified: 2017-10-10 12:48 UTC (History)
9 users (show)

See Also:
Change sponsored?: Sponsored
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:
The main OPAC search has a qualifier menu available (the Search: Library Catalog/Title/Author/Subject/ISBN/Series/Call Number menu). Now the staff side had this option available, too. Show/Not show with syspref 'IntranetCatalogSearchPulldown'.
Version(s) released in:


Attachments
Bug 14902 - Add qualifier menu to staff side "Search the Catalog" (22.77 KB, patch)
2016-06-03 17:07 UTC, Nick Clemens
Details | Diff | Splinter Review
Shows combo bar without menu -- normal position. (27.77 KB, image/png)
2016-06-21 15:21 UTC, Barton Chittenden
Details
Shows search bar with menu, pushed below logo. (29.14 KB, image/png)
2016-06-21 15:21 UTC, Barton Chittenden
Details
Bug 14902 - Add qualifier menu to staff side "Search the Catalog" (22.83 KB, patch)
2016-06-23 16:44 UTC, Nicole C. Engard
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 14902 - Add qualifier menu to staff side "Search the Catalog" (22.91 KB, patch)
2016-06-23 19:51 UTC, Barton Chittenden
Details | Diff | Splinter Review
Bug 14902 (QA Followup) (4.11 KB, patch)
2016-06-24 20:36 UTC, Nick Clemens
Details | Diff | Splinter Review
Bug 14902 - Add qualifier menu to staff side "Search the Catalog" (22.96 KB, patch)
2016-06-25 12:56 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description HB-NEKLS 2015-09-25 16:27:48 UTC
The main OPAC search has a qualifier menu available (the Search: Library Catalog/Title/Author/Subject/ISBN/Series/Call Number menu). 

It would be nice if the staff side had this option available, too. 

(And yes, I know this is available through Advanced Search, but my librarians would like to see this available through the regular "Search the Catalog."
Comment 1 Kyle M Hall 2015-11-04 16:21:09 UTC
*** Bug 15132 has been marked as a duplicate of this bug. ***
Comment 2 Nick Clemens 2016-06-03 17:07:06 UTC Comment hidden (obsolete)
Comment 3 Barton Chittenden 2016-06-21 15:21:03 UTC
Created attachment 52654 [details]
Shows combo bar without menu -- normal position.
Comment 4 Barton Chittenden 2016-06-21 15:21:57 UTC
Created attachment 52655 [details]
Shows search bar with menu, pushed below logo.
Comment 5 Barton Chittenden 2016-06-21 15:23:01 UTC
(In reply to Nick Clemens from comment #2)
> Created attachment 52021 [details] [review] [review]
> Bug 14902 - Add qualifier menu to staff side "Search the Catalog"
> 
> To test:
> 1 - Apply patch and update dabase
> 2 - Check that Search the Catalog links throughout the staff interface
> have not changed
> 3 - Set "IntranetCatalogSearchPulldown" to 'Show'
> 4 - Verify that 'Search the catalog' links through staff client now have
> a dropdwon to  select search index
> 
> I think viewing one file each that includes updated header should be
> sufficient, but please check as many as you can:
> 
> cgi-bin/koha/admin/aqbudgetperiods.pl
> cgi-bin/koha/admin/admin-home.pl
> cgi-bin/koha/cataloguing/addbooks.pl
> cgi-bin/koha/circ/returns.pl
> cgi-bin/koha/circ/circulation-home.pl
> cgi-bin/koha/admin/cities.pl
> cgi-bin/koha/admin/aqcontract.pl
> cgi-bin/koha/admin/currency.pl
> cgi-bin/koha/mainpage.pl
> cgi-bin/koha/tools/letter.pl
> cgi-bin/koha/members/members-home.pl
> cgi-bin/koha/admin/categories.pl
> cgi-bin/koha/admin/preferences.pl
> cgi-bin/koha/admin/printers.pl
> cgi-bin/koha/serials/serials-home.pl
> cgi-bin/koha/acqui/newordersuggestion.pl
> cgi-bin/koha/admin/z3950servers.pl
> 
> Sponsored by:
>   Northeast Kansas Library System (http://nekls.org/)

I've verified that the dropdown is present on the catalog search on the pages above.

The one thing that I noticed was that below a certain screen width, the width of the searchbox + the dropdown forces the catalog search below the Koha logo.

Because this happens when you click 'Search the catalog', this resizing is a bit jarring.

See the attached 'checkout_bar.png' and 'search_bar.png'
Comment 6 Marc Véron 2016-06-21 15:56:00 UTC
(In reply to Barton Chittenden from comment #5)
(...)
> 
> The one thing that I noticed was that below a certain screen width, the
> width of the searchbox + the dropdown forces the catalog search below the
> Koha logo.
> 
> Because this happens when you click 'Search the catalog', this resizing is a
> bit jarring.
> 
> See the attached 'checkout_bar.png' and 'search_bar.png'

Hi Barton,

That happens with and without patch, maybe it could be fixed with CSS that takes in account the screen width. Can you file a new bug for that?
Comment 7 Nicole C. Engard 2016-06-23 16:44:52 UTC Comment hidden (obsolete)
Comment 8 Barton Chittenden 2016-06-23 19:51:31 UTC Comment hidden (obsolete)
Comment 9 Jonathan Druart 2016-06-24 16:21:43 UTC
Nick,
Why do you add [% USE Koha %] in some templates?
The Koha TT plugin is loaded in doc-head-open.inc and should then be everywhere else.
Comment 10 Nick Clemens 2016-06-24 20:36:46 UTC Comment hidden (obsolete)
Comment 11 Jonathan Druart 2016-06-25 12:56:07 UTC
Created attachment 52874 [details] [review]
Bug 14902 - Add qualifier menu to staff side "Search the Catalog"

To test:
1 - Apply patch and update dabase
2 - Check that Search the Catalog links throughout the staff interface
have not changed
3 - Set "IntranetCatalogSearchPulldown" to 'Show'
4 - Verify that 'Search the catalog' links through staff client now have
a dropdwon to  select search index

I think viewing one file each that includes updated header should be
sufficient, but please check as many as you can:

cgi-bin/koha/admin/aqbudgetperiods.pl
cgi-bin/koha/admin/admin-home.pl
cgi-bin/koha/cataloguing/addbooks.pl
cgi-bin/koha/circ/returns.pl
cgi-bin/koha/circ/circulation-home.pl
cgi-bin/koha/admin/cities.pl
cgi-bin/koha/admin/aqcontract.pl
cgi-bin/koha/admin/currency.pl
cgi-bin/koha/mainpage.pl
cgi-bin/koha/tools/letter.pl
cgi-bin/koha/members/members-home.pl
cgi-bin/koha/admin/categories.pl
cgi-bin/koha/admin/preferences.pl
cgi-bin/koha/admin/printers.pl
cgi-bin/koha/serials/serials-home.pl
cgi-bin/koha/acqui/newordersuggestion.pl
cgi-bin/koha/admin/z3950servers.pl

Sponsored by:
  Northeast Kansas Library System (http://nekls.org/)

Signed-off-by: Heather Braum <hbraum@nekls.org>

Signed-off-by: Barton Chittenden <barton@bywatersolutions.com>

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 12 Jonathan Druart 2016-06-25 12:57:03 UTC
(In reply to Nick Clemens from comment #10)
> Created attachment 52866 [details] [review] [review]
> Bug 14902 (QA Followup)
> 
> Remove unnecessary [% USE Koha %]
> 
> Any remaining were tested and needed

Indeed, that's weird.
So I prefer to keep the original patch, which has been widely tested. Sorry for the extra work.
Comment 13 Kyle M Hall 2016-07-08 14:05:11 UTC
Pushed to master for 16.11, thanks Nick!