Bug 15021 - Batch item modification does not work correctly on plack
Summary: Batch item modification does not work correctly on plack
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Tools (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
: 15041 (view as bug list)
Depends on:
Blocks: 7172 15019
  Show dependency treegraph
 
Reported: 2015-10-16 07:12 UTC by Josef Moravec
Modified: 2016-06-21 21:39 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Batch item modification display issue (48.69 KB, image/png)
2015-10-16 07:12 UTC, Josef Moravec
Details
Bug 15021: Fix scoping variable in tools/batchMod.pl (994 bytes, patch)
2015-10-16 08:53 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 15021: Fix scoping variable in tools/batchMod.pl (1.04 KB, patch)
2015-10-16 10:41 UTC, Josef Moravec
Details | Diff | Splinter Review
[PASSED QA] Bug 15021: Fix scoping variable in tools/batchMod.pl (1.12 KB, patch)
2015-10-23 10:43 UTC, Kyle M Hall
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Josef Moravec 2015-10-16 07:12:55 UTC
Created attachment 43450 [details]
Batch item modification display issue

In Batch item modification tool, after inserting some codes (in textarea or as file), in second step you should normally see the table with many columns and checkboxes to display/hide each of these columns. But under plack you see only the Title column (see attachment)
Comment 1 Jonathan Druart 2015-10-16 08:53:21 UTC Comment hidden (obsolete)
Comment 2 Josef Moravec 2015-10-16 10:41:11 UTC Comment hidden (obsolete)
Comment 3 Josef Moravec 2015-10-21 14:02:30 UTC
*** Bug 15041 has been marked as a duplicate of this bug. ***
Comment 4 Kyle M Hall 2015-10-23 10:43:02 UTC
Created attachment 43814 [details] [review]
[PASSED QA] Bug 15021: Fix scoping variable in tools/batchMod.pl

$tagslib is used in subroutines and should be declare as global.

Test plan:
On the Batch item modification page, all item fields should be listed, not only the title.

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>
Works as expected

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 5 Tomás Cohen Arazi 2015-10-23 13:16:37 UTC
Patch pushed to master.

Thanks Jonathan!