Bug 15864 - SMS cellular providers link missing from administration sidebar menu
Summary: SMS cellular providers link missing from administration sidebar menu
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: System Administration (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Owen Leonard
QA Contact: Testopia
URL:
Keywords:
: 15943 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-02-19 17:35 UTC by Owen Leonard
Modified: 2016-12-05 21:22 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 15864 - SMS cellular providers link missing from administration sidebar menu (1.77 KB, patch)
2016-02-29 16:11 UTC, Owen Leonard
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 15864 - SMS cellular providers link missing from administration sidebar menu (1.80 KB, patch)
2016-03-02 16:36 UTC, Nicole C. Engard
Details | Diff | Splinter Review
[PASSED QA] Bug 15864 - SMS cellular providers link missing from administration sidebar menu (1.86 KB, patch)
2016-03-03 06:51 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Leonard 2016-02-19 17:35:43 UTC
Even with SMS cellular provider management enabled, the link to SMS cellular providers doesn't appear in the administration sidebar menu.
Comment 1 Owen Leonard 2016-02-29 16:11:14 UTC Comment hidden (obsolete)
Comment 2 Owen Leonard 2016-02-29 23:12:38 UTC
*** Bug 15943 has been marked as a duplicate of this bug. ***
Comment 3 Nicole C. Engard 2016-03-02 16:36:37 UTC Comment hidden (obsolete)
Comment 4 Katrin Fischer 2016-03-03 06:51:33 UTC
Created attachment 48583 [details] [review]
[PASSED QA] Bug 15864 - SMS cellular providers link missing from administration sidebar menu

When the SMSSendDriver system preference is set to "Email" a link to the
SMS cellular providers management page should appear in the left-hand
sidebar menu on Administration pages. This patch adds the link to
admin-menu.inc.

To test, apply the patch set your SMSSendDriver system preference to
"Email." View various Administration pages which show the left-hand
sidebar menu and confirm that "SMS cellular providers" is in the list.

Empty the SMSSendDriver preference and confirm that the link no longer
appears.

Signed-off-by: Nicole C Engard <nengard@bywatersolutions.com>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 5 Brendan Gallagher 2016-03-03 22:23:34 UTC
Pushed to Master - Should be in May 2016 Release.  Thanks
Comment 6 Julian Maurice 2016-03-07 10:31:29 UTC
Does not concern stable versions, status changed to RESOLVED