Right now, Koha has four different functions for making payments: recordpayment, makepayment, recordpayment_sellectaccts and makepartialpayment. We should replace these four functions with a single all-singing all-dancing method in the Koha::Namespace. This would help to reduce regressions and make future additions much simpler ( such as my planned re-implementation of account offsets ) and add consistency for logging and whatnot.
I've pushed out a github branch with this entire patch set applied for ease of testing: https://github.com/bywatersolutions/bywater-koha-devel/tree/bug_15894_-_Unify_all_account_fine_payment_functions
*** Bug 14827 has been marked as a duplicate of this bug. ***
Confused by the status of this bug.. is it merged?
(In reply to Martin Renvoize from comment #3)
> Confused by the status of this bug.. is it merged?
It was an omnibus bug that had no patches of it's own. Once all the blocking patches were pushed I set the status to RESOLVED FIXED since none of the RMaints would be backporting the patches since they are all enhancements.
Brill, I understand now, thanks Kyle.