Bug 15894 - Unify all account fine payment functions
Summary: Unify all account fine payment functions
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Architecture, internals, and plumbing (show other bugs)
Version: unspecified
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Kyle M Hall
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
: 14827 (view as bug list)
Depends on: 15895 15896 15899 15905 15908 17894
Blocks: 14825 14826 15165 18033
  Show dependency treegraph
 
Reported: 2016-02-24 14:08 UTC by Kyle M Hall
Modified: 2017-05-01 22:30 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kyle M Hall 2016-02-24 14:08:41 UTC
Right now, Koha has four different functions for making payments: recordpayment, makepayment, recordpayment_sellectaccts and makepartialpayment. We should replace these four functions with a single all-singing all-dancing method in the Koha::Namespace. This would help to reduce regressions and make future additions much simpler ( such as my planned re-implementation of account offsets ) and add consistency for logging and whatnot.
Comment 1 Kyle M Hall 2016-03-07 19:04:06 UTC
I've pushed out a github branch with this entire patch set applied for ease of testing: https://github.com/bywatersolutions/bywater-koha-devel/tree/bug_15894_-_Unify_all_account_fine_payment_functions
Comment 2 Kyle M Hall 2016-07-12 13:26:57 UTC
*** Bug 14827 has been marked as a duplicate of this bug. ***
Comment 3 Martin Renvoize 2017-03-28 09:02:50 UTC
Confused by the status of this bug.. is it merged?
Comment 4 Kyle M Hall 2017-03-28 10:46:06 UTC
(In reply to Martin Renvoize from comment #3)
> Confused by the status of this bug.. is it merged?

It was an omnibus bug that had no patches of it's own. Once all the blocking patches were pushed I set the status to RESOLVED FIXED since none of the RMaints would be backporting the patches since they are all enhancements.
Comment 5 Martin Renvoize 2017-03-29 05:58:19 UTC
Brill, I understand now, thanks Kyle.