Bug 15964 - Cannot view detail bib record because missing perl module WWW::YouTube::Download
Summary: Cannot view detail bib record because missing perl module WWW::YouTube::Download
Status: RESOLVED DUPLICATE of bug 14168
Alias: None
Product: Koha
Classification: Unclassified
Component: Cataloging (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Josef Moravec
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-03-02 19:52 UTC by Héctor Eduardo Castro Avalos
Modified: 2016-05-25 17:43 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
[SIGNED-OFF]Bug 15964: Followup: make module WWW::YouTube::Download required (2.45 KB, patch)
2016-03-02 19:55 UTC, Héctor Eduardo Castro Avalos
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Héctor Eduardo Castro Avalos 2016-03-02 19:52:40 UTC
WWW::YouTube::Download needs to be marked as required
Comment 1 Héctor Eduardo Castro Avalos 2016-03-02 19:55:24 UTC
Created attachment 48562 [details] [review]
[SIGNED-OFF]Bug 15964: Followup: make module WWW::YouTube::Download required

Module C4::HTML5Media is used in detail.pl,
so if you don't have installled module for YouTube,
you get an internal server error.

This patch make module WWW::YouTube::Download required and adds it to package dependencies

Test plan:
1. Don't have installed module WWW::YouTube:Download, neither package libwww-youtube-download-perl
2. Try to access biblio detail in staff client (detail.pl) - you'll be presented withh internal server error
3. Check the About page -> Perl modules, the WWW::YouTube::Download should be reported as missing optional
4. Apply the patch
5. Check the About page -> Perl modules, the WWW::YouTube::Download should now be reported as missing required
6. Create and install debian package, the libwww-youtube-download-perl should be the dependency and so installed with koha-common package (use apt-get install -f, if neccessery)
7. Check the About page -> Perl modules, the WWW::YouTube::Download should now be reported as Module current
8. Try to access biblio detail in staff client (detail.pl) - it should be display, no error now

Signed-off-by: Hector Castro <hector.hecaxmmx@gmail.com>
Works as advertised
Comment 2 Héctor Eduardo Castro Avalos 2016-03-02 19:58:23 UTC
Hi Josef Moravec

I move your patch to this new bug

Regard
Comment 3 Josef Moravec 2016-03-02 20:43:25 UTC
Thanks Héctor, also for sign-off ;)
Comment 4 Mirko Tietgen 2016-03-02 20:59:12 UTC
Hi Héctor and Josef,

we talked about this on IRC today and the plan is to fix it in a different way.

The module is not available in Wheezy and it is not a core function, only a few people will actually need it. We will change the "use WWW::YouTube:Download" to a 'require' with the condition of the youtube-syspref being enabled, so people on Wheezy don't get bothered by this. I plan to add a patch tomorrow.
Comment 5 Josef Moravec 2016-03-02 21:23:41 UTC
I should be more often on IRC ;)

Thanks Mirko for clarification, I'm looking forward to your patch ;)
Comment 6 Mirko Tietgen 2016-05-25 17:43:39 UTC

*** This bug has been marked as a duplicate of bug 14168 ***