Bug 16530 - Add a circ sidebar navigation menu
Summary: Add a circ sidebar navigation menu
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Aleisha Amohia
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 18219
  Show dependency treegraph
 
Reported: 2016-05-17 04:35 UTC by Aleisha Amohia
Modified: 2017-03-13 13:59 UTC (History)
10 users (show)

See Also:
Change sponsored?: Sponsored
Patch complexity: Large patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 16530: Adding a circ sidebar navigation menu (21.55 KB, patch)
2016-05-17 04:40 UTC, Aleisha Amohia
Details | Diff | Splinter Review
Bug 16530: Adding a circ sidebar navigation menu (21.60 KB, patch)
2016-05-25 13:50 UTC, PTFS Europe Sandboxes
Details | Diff | Splinter Review
Bug 16530: Adding a circ sidebar navigation menu (24.74 KB, patch)
2016-07-01 02:41 UTC, Aleisha Amohia
Details | Diff | Splinter Review
Bug 16530: Adding a circ sidebar navigation menu and circSidebar syspref to activate/deactivate (34.37 KB, patch)
2016-07-04 05:31 UTC, Aleisha Amohia
Details | Diff | Splinter Review
Bug 16530: Adding a circ sidebar navigation menu and circSidebar syspref to activate/deactivate (33.94 KB, patch)
2016-12-01 23:08 UTC, Aleisha Amohia
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 16530: Adding a circ sidebar navigation menu and circSidebar syspref to activate/deactivate (34.00 KB, patch)
2016-12-02 09:03 UTC, Josef Moravec
Details | Diff | Splinter Review
Bug 16530: Adding a circ sidebar navigation menu and circSidebar syspref to activate/deactivate (32.92 KB, patch)
2017-02-02 11:47 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 16530: Add a new method to the Branches TT Plugin to avoid c/p (9.97 KB, patch)
2017-02-02 11:47 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Aleisha Amohia 2016-05-17 04:35:52 UTC
(Similar to the tools sidebar menu).

This is just an idea that I thought would make navigation around the circ module a bit easier ... I realise that it changes the display of many of the pages so I appreciate any thoughts on the upcoming patch. :)
Comment 1 Aleisha Amohia 2016-05-17 04:40:07 UTC Comment hidden (obsolete)
Comment 2 PTFS Europe Sandboxes 2016-05-25 13:50:14 UTC
Patch tested with a sandbox, by Jan Kissig <jkissig@th-wildau.de>
Comment 3 PTFS Europe Sandboxes 2016-05-25 13:50:36 UTC Comment hidden (obsolete)
Comment 4 Jan Kissig 2016-05-25 13:53:41 UTC
tested in sandbox. layout was okay and not messed up while showing error messages
Comment 5 Jonathan Druart 2016-06-12 11:12:22 UTC
I'd like to get different opinions before QAing it. Back to needs signoff.
Comment 6 Jonathan Druart 2016-06-12 11:14:11 UTC
My main concern is that the sidebar takes lot of spaces and may annoy librarians using it all day long.
For instance I don't think it's important for them to see the link to the offline circ tools.
Comment 7 Jonathan Druart 2016-06-12 11:15:33 UTC
Ccing Katrin and Owen.
It would be great to get opinions from librarians using it daily.
Comment 8 Owen Leonard 2016-06-13 17:32:36 UTC
(In reply to Jonathan Druart from comment #6)

> For instance I don't think it's important for them to see the link to the
> offline circ tools.

I agree. If we went forward with this patch I would probably say we ought to leave them out altogether.

I don't think this change looks bad, but I'm not sure it's necessary. The most important options (check out, check in, renew, set library) are always available in the header.

On the other hand, it is inconsistent that the circulation module doesn't have a sidebar menu. I think the original intention was to keep things like checkout and checkin distraction-free because they are such important tasks.
Comment 9 Séverine Queune 2016-06-29 13:06:56 UTC
The path seems to work well.
We notice three points that could be improved.
1. The "fast cataloging" link only appears on the circulation.pl page. It should be present in all circulation pages.
2. We agree with Jonathan that the link to offline circulation is not necessary.
3. It should be interesting to create an syspref to activate/desactivate the sidebar (if possible)
Comment 10 Aleisha Amohia 2016-07-01 02:41:10 UTC Comment hidden (obsolete)
Comment 11 Aleisha Amohia 2016-07-04 05:31:07 UTC
Created attachment 53072 [details] [review]
Bug 16530: Adding a circ sidebar navigation menu and circSidebar syspref to activate/deactivate

Edit: Fast cataloging link should now show on all pages, removed offline circulation links
Edit 2: Creates the syspref to activate or deactivate the sidebar

This adds a sidebar to
circ/branchoverdues.tt
circ/circulation.tt (I also fixed up some of the indentation in this file to make it easier to see where the divs started and ended)
circ/renew.tt
circ/returns.tt
circ/selectbranchprinter.tt
circ/transferstoreceive.tt
circ/view_holdsqueue.tt
circ/waitingreserves.tt
circ/branchtransfers.tt

To test:
1) Confirm syspref circSidebar is activated
2) Go to all of the above pages and confirm the sidebar menu shows up
3) Confirm fast cataloguing link and transfer link are there
4) Trigger any error messages you can possibly think of (i.e. on renew.pl: barcode does not exist). Confirm that this does not mess up the layout of the page
5) Go to a user account page, Check out tab. (Since this is a circ/circulation.pl page). Ensure the circ nav sidebar doesn't show up (confirm it looks as it usually does)
6) Deactivate circSidebar
7) Confirm pages all look normal

Sponsored-by: Catalyst IT

Signed-off-by: Jan Kissig <jkissig@th-wildau.de>
Comment 12 Aleisha Amohia 2016-07-04 05:33:07 UTC
Sorry forgot Step 1: Run updatedatabase.pl!

This is ready for testing
Comment 13 Jonathan Druart 2016-07-25 16:13:57 UTC
The sidebar does not appear on "Pending on-site checkouts", I guess it should.
I think the pref should be named CircSidebar instead of circSidebar.
Comment 14 Aleisha Amohia 2016-12-01 23:08:36 UTC
Created attachment 57869 [details] [review]
Bug 16530: Adding a circ sidebar navigation menu and circSidebar syspref to activate/deactivate

Edit: Fast cataloging link should now show on all pages, removed offline circulation links
Edit 2: Creates the syspref to activate or deactivate the sidebar
Edit 3: Fixing merge conflicts, using Koha::BiblioFrameworks to find FA
framework and adding sidebar to on-site checkouts

This adds a sidebar to
circ/branchoverdues.tt
circ/circulation.tt (I also fixed up some of the indentation in this file to make it easier to see where the divs started and ended)
circ/renew.tt
circ/returns.tt
circ/selectbranchprinter.tt
circ/transferstoreceive.tt
circ/view_holdsqueue.tt
circ/waitingreserves.tt
circ/branchtransfers.tt
circ/on-site_checkouts.tt

To test:
1) Confirm syspref CircSidebar is activated
2) Go to all of the above pages and confirm the sidebar menu shows up
3) Confirm fast cataloguing link and transfer link are there
4) Trigger any error messages you can possibly think of (i.e. on renew.pl: barcode does not exist). Confirm that this does not mess up the layout of the page
5) Go to a user account page, Check out tab. (Since this is a circ/circulation.pl page). Ensure the circ nav sidebar doesn't show up (confirm it looks as it usually does)
6) Deactivate circSidebar
7) Confirm pages all look normal

Sponsored-by: Catalyst IT

Signed-off-by: Jan Kissig <jkissig@th-wildau.de>
Comment 15 Josef Moravec 2016-12-02 09:03:46 UTC
Created attachment 57901 [details] [review]
[SIGNED-OFF] Bug 16530: Adding a circ sidebar navigation menu and circSidebar syspref to activate/deactivate

Edit: Fast cataloging link should now show on all pages, removed offline circulation links
Edit 2: Creates the syspref to activate or deactivate the sidebar
Edit 3: Fixing merge conflicts, using Koha::BiblioFrameworks to find FA
framework and adding sidebar to on-site checkouts

This adds a sidebar to
circ/branchoverdues.tt
circ/circulation.tt (I also fixed up some of the indentation in this file to make it easier to see where the divs started and ended)
circ/renew.tt
circ/returns.tt
circ/selectbranchprinter.tt
circ/transferstoreceive.tt
circ/view_holdsqueue.tt
circ/waitingreserves.tt
circ/branchtransfers.tt
circ/on-site_checkouts.tt

To test:
1) Confirm syspref CircSidebar is activated
2) Go to all of the above pages and confirm the sidebar menu shows up
3) Confirm fast cataloguing link and transfer link are there
4) Trigger any error messages you can possibly think of (i.e. on renew.pl: barcode does not exist). Confirm that this does not mess up the layout of the page
5) Go to a user account page, Check out tab. (Since this is a circ/circulation.pl page). Ensure the circ nav sidebar doesn't show up (confirm it looks as it usually does)
6) Deactivate circSidebar
7) Confirm pages all look normal

Sponsored-by: Catalyst IT

Signed-off-by: Jan Kissig <jkissig@th-wildau.de>

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>
Comment 16 Jonathan Druart 2017-02-02 11:47:31 UTC
Created attachment 59807 [details] [review]
Bug 16530: Adding a circ sidebar navigation menu and circSidebar syspref to activate/deactivate

Edit: Fast cataloging link should now show on all pages, removed offline circulation links
Edit 2: Creates the syspref to activate or deactivate the sidebar
Edit 3: Fixing merge conflicts, using Koha::BiblioFrameworks to find FA
framework and adding sidebar to on-site checkouts

This adds a sidebar to
circ/branchoverdues.tt
circ/circulation.tt (I also fixed up some of the indentation in this file to make it easier to see where the divs started and ended)
circ/renew.tt
circ/returns.tt
circ/selectbranchprinter.tt
circ/transferstoreceive.tt
circ/view_holdsqueue.tt
circ/waitingreserves.tt
circ/branchtransfers.tt
circ/on-site_checkouts.tt

To test:
1) Confirm syspref CircSidebar is activated
2) Go to all of the above pages and confirm the sidebar menu shows up
3) Confirm fast cataloguing link and transfer link are there
4) Trigger any error messages you can possibly think of (i.e. on renew.pl: barcode does not exist). Confirm that this does not mess up the layout of the page
5) Go to a user account page, Check out tab. (Since this is a circ/circulation.pl page). Ensure the circ nav sidebar doesn't show up (confirm it looks as it usually does)
6) Deactivate circSidebar
7) Confirm pages all look normal

Sponsored-by: Catalyst IT

Signed-off-by: Jan Kissig <jkissig@th-wildau.de>

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 17 Jonathan Druart 2017-02-02 11:47:37 UTC
Created attachment 59808 [details] [review]
Bug 16530: Add a new method to the Branches TT Plugin to avoid c/p

We should do the same for the other check (FA exists), but cannot find a
good and quick way to implement.

Doing it this way will avoid regression later, we will no have to check
if the variable is correctly passed to the template.

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 18 Kyle M Hall 2017-03-03 18:37:05 UTC
Pushed to master for 17.05, thanks Aleisha, Jonathan!
Comment 19 Katrin Fischer 2017-03-12 23:05:50 UTC
This won't get ported back to 16.11.x as it is an enhancement.