Bug 16546 - Make edit and delete links styled buttons in MARC bibliographic framework administration
Summary: Make edit and delete links styled buttons in MARC bibliographic framework adm...
Status: RESOLVED DUPLICATE of bug 17162
Alias: None
Product: Koha
Classification: Unclassified
Component: Templates (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Owen Leonard
QA Contact: Testopia
URL: /cgi-bin/koha/admin/marctagstructure....
Keywords:
Depends on:
Blocks:
 
Reported: 2016-05-18 16:39 UTC by Owen Leonard
Modified: 2017-01-05 12:21 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 16546 - Make edit and delete links styled buttons in MARC bibliographic framework administration (7.34 KB, patch)
2016-05-25 14:45 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 16546 - Make edit and delete links styled buttons in MARC bibliographic framework administration (7.44 KB, patch)
2016-05-27 12:22 UTC, Holger Meißner
Details | Diff | Splinter Review
Bug 16546 - Make edit and delete links styled buttons in MARC bibliographic framework administration (7.44 KB, patch)
2016-05-27 12:24 UTC, Holger Meißner
Details | Diff | Splinter Review
Bug 16546 - Make edit and delete links styled buttons in MARC bibliographic framework administration (7.44 KB, patch)
2016-05-27 12:29 UTC, Holger Meißner
Details | Diff | Splinter Review
Bug 16546 - Make edit and delete links styled buttons in MARC bibliographic framework administration (7.48 KB, patch)
2016-06-01 16:40 UTC, Marc Véron
Details | Diff | Splinter Review
Bug 16546 - Make edit and delete links styled buttons in MARC bibliographic framework administration (7.48 KB, patch)
2016-06-01 16:42 UTC, Marc Véron
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Leonard 2016-05-18 16:39:14 UTC
In Administration -> MARC bibliographic framework, the initial view has a styled action menu, but if you choose "MARC structure," there are unstyled action links. Further, if you choose "subfields" from that page there are edit and delete links which could be made into Bootstrap-styled buttons with Font Awesome icons.
Comment 1 Owen Leonard 2016-05-25 14:45:12 UTC Comment hidden (obsolete)
Comment 2 Holger Meißner 2016-05-27 12:22:00 UTC Comment hidden (obsolete)
Comment 3 Holger Meißner 2016-05-27 12:24:32 UTC Comment hidden (obsolete)
Comment 4 Holger Meißner 2016-05-27 12:29:55 UTC Comment hidden (obsolete)
Comment 5 Marc Véron 2016-05-28 19:32:19 UTC
Tested as well, works as expected.
Holger, did you forget to switch the status to "Signed-off"?
Comment 6 Marc Véron 2016-06-01 16:40:41 UTC Comment hidden (obsolete)
Comment 7 Marc Véron 2016-06-01 16:42:14 UTC
Created attachment 51949 [details] [review]
Bug 16546 - Make edit and delete links styled buttons in MARC bibliographic framework administration

This patch modifies two MARC framwork templates, styling some
edit and delete links as Bootstrap buttons with Font Awesome icons.

To test, apply the patch and go to Administration -> MARC frameworks ->
MARC structure.

- In the list of tags for your selected MARC framework, the "Subfields,"
  "Edit" and "Delete" items in the 'Actions' menu should look correct
  and work correctly.
- Choose "Subfields" for any tag. In the list of subfields,
  the "Edit" and "Delete" buttons should look correct and work
  correctly.

Signed-off-by: Holger Meißner <h.meissner.82@web.de>
Signed-off-by: Marc Véron <veron@veron.ch>
Comment 8 Marc Véron 2016-06-01 16:48:07 UTC
Signing off. Sorry for the duplicate upload, after uploading I got a 500 internal error from Bugzilla (Failed to attach patch to bug 16546, status 500), but patches were attached anyway.
Comment 9 Jonathan Druart 2016-06-12 12:00:17 UTC
As I already said, it seems that 3 buttons could be displayed in the same column to avoid 1 click.
Why did not join put Edit and Delete into the same column (/marc_subfields_structure.pl?tagfield=200&frameworkcode=)?
Comment 10 Owen Leonard 2017-01-05 12:21:13 UTC
Made obsolete by Bug 17162 and Bug 17163

*** This bug has been marked as a duplicate of bug 17162 ***