Bug 17162 - Moving MARC tags structure actions into a drop down menu
Summary: Moving MARC tags structure actions into a drop down menu
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: System Administration (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Aleisha Amohia
QA Contact: Testopia
URL:
Keywords:
: 16546 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-08-23 01:20 UTC by Aleisha Amohia
Modified: 2017-12-07 22:16 UTC (History)
4 users (show)

See Also:
Change sponsored?: Sponsored
Patch complexity: Trivial patch
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 17162: Moving MARC tags structure actions into a drop down menu (4.04 KB, patch)
2016-08-23 01:24 UTC, Aleisha Amohia
Details | Diff | Splinter Review
Bug 17162: Moving MARC tags structure actions into a drop down menu (4.20 KB, patch)
2016-08-23 06:42 UTC, Marc Véron
Details | Diff | Splinter Review
Bug 17162: Moving MARC tags structure actions into a drop down menu (4.27 KB, patch)
2016-08-23 12:43 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Aleisha Amohia 2016-08-23 01:20:58 UTC

    
Comment 1 Aleisha Amohia 2016-08-23 01:24:54 UTC Comment hidden (obsolete)
Comment 2 Marc Véron 2016-08-23 06:42:17 UTC Comment hidden (obsolete)
Comment 3 Jonathan Druart 2016-08-23 12:43:44 UTC
Created attachment 54768 [details] [review]
Bug 17162: Moving MARC tags structure actions into a drop down menu

To test:
1) Go to Admin -> MARC bibliographic framework
2) Go to Actions -> MARC structure for any framework
3) Confirm that three links, Subfields, Edit and Delete, now show in
drop-down menu with appropriate font awesome icons
4) Confirm that Subfields takes you to the right page and Edit and
Delete work as expected

Sponsored-by: Catalyst IT

Patch behaves as expected.
Signed-off-by: Marc Véron <veron@veron.ch>

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 4 Kyle M Hall 2016-09-09 14:58:58 UTC
Pushed to master for 16.11, thanks Aleisha!
Comment 5 Owen Leonard 2017-01-05 12:21:13 UTC
*** Bug 16546 has been marked as a duplicate of this bug. ***