Bug 16736 - Keep library filter when changing suggestion
Summary: Keep library filter when changing suggestion
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Acquisitions (show other bugs)
Version: master
Hardware: All All
: P5 - low minor (vote)
Assignee: Fridolin Somers
QA Contact: Testopia
URL:
Keywords:
: 8147 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-06-14 15:05 UTC by Fridolin Somers
Modified: 2017-06-14 22:13 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 16736 - Keep branch filter when changing suggestion (1.43 KB, patch)
2016-06-14 15:09 UTC, Fridolin Somers
Details | Diff | Splinter Review
Bug 16736 - Keep branch filter when changing suggestion (1.58 KB, patch)
2016-06-14 16:01 UTC, Marc Véron
Details | Diff | Splinter Review
[PASSED QA] Bug 16736 - Keep branch filter when changing suggestion (1.65 KB, patch)
2016-06-19 11:40 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Fridolin Somers 2016-06-14 15:05:29 UTC
When changing suggestion, the selected tab is kept.
The same should be done with the selected branch.
Comment 1 Fridolin Somers 2016-06-14 15:09:30 UTC Comment hidden (obsolete)
Comment 2 Marc Véron 2016-06-14 16:01:19 UTC Comment hidden (obsolete)
Comment 3 Katrin Fischer 2016-06-19 11:35:50 UTC
Note: if you use the 'edit' link to edit the suggestion, the filters are still reset.
Comment 4 Katrin Fischer 2016-06-19 11:40:07 UTC
Created attachment 52536 [details] [review]
[PASSED QA] Bug 16736 - Keep branch filter when changing suggestion

When changing suggestion, the selected tab is kept.
The same should be done with the selected branch.

Test plan:
- Go to suggestions table : /cgi-bin/koha/suggestion/suggestion.pl
- Select a branch in Acquisition information > For
- Select a pending suggestion
- Change status as accepted
- Click on Submit
=> without patch, the table is no longer filtered by branch
=> with patch, the table is filtered by branch

Works as expected.
Signed-off-by: Marc Véron <veron@veron.ch>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Note: changing the suggestion using the 'edit' link
will still reset the filters. Out of scope here.
Comment 5 Kyle M Hall 2016-06-24 13:07:30 UTC
Pushed to master for 16.11, thanks Frido!
Comment 6 Frédéric Demians 2016-08-01 11:52:49 UTC
Pushed in 16.05. Will be in 16.05.02.
Comment 7 Julian Maurice 2016-08-16 13:08:30 UTC
Patch pushed to 3.22.x, will be in 3.22.10
Comment 8 Katrin Fischer 2016-08-28 12:19:18 UTC
*** Bug 8147 has been marked as a duplicate of this bug. ***