Bug 16762 - Record matching rules: Remove match check link removes too much
Summary: Record matching rules: Remove match check link removes too much
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: System Administration (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Owen Leonard
QA Contact: Testopia
URL: /cgi-bin/koha/admin/matching-rules.pl...
Keywords:
Depends on:
Blocks: 16763
  Show dependency treegraph
 
Reported: 2016-06-17 15:32 UTC by Owen Leonard
Modified: 2017-12-07 22:17 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 16762 - Record matching rules: Remove match check link removes too much (2.37 KB, patch)
2016-06-17 16:46 UTC, Owen Leonard
Details | Diff | Splinter Review
[SIGNED-OFF]Bug 16762: Record matching rules: Remove match check link removes too much (2.42 KB, patch)
2016-06-22 17:52 UTC, Héctor Eduardo Castro Avalos
Details | Diff | Splinter Review
[SIGNED-OFF]Bug 16762: Record matching rules: Remove match check link removes too much (2.42 KB, patch)
2016-06-22 17:53 UTC, Héctor Eduardo Castro Avalos
Details | Diff | Splinter Review
Bug 16762: Record matching rules: Remove match check link removes too much (2.46 KB, patch)
2016-06-24 15:38 UTC, Kyle M Hall
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Leonard 2016-06-17 15:32:17 UTC
Caused by my patch for Bug 5006: In record matching rules, if you remove the last match check, the entire match check container is deleted, including the controls for adding a new match check.
Comment 1 Owen Leonard 2016-06-17 16:46:19 UTC Comment hidden (obsolete)
Comment 2 Héctor Eduardo Castro Avalos 2016-06-22 17:52:37 UTC Comment hidden (obsolete)
Comment 3 Héctor Eduardo Castro Avalos 2016-06-22 17:53:05 UTC Comment hidden (obsolete)
Comment 4 Kyle M Hall 2016-06-24 15:38:49 UTC
Created attachment 52815 [details] [review]
Bug 16762: Record matching rules: Remove match check link removes too much

My patch for Bug 5006 introduced a lot of markup changes to the record
matching rules template. I missed a change in one are though, which
caused a bug with the way the 'Remove match check' link works.

To reproduce:

- Go to Administration -> Record matching rules.
- Edit a matching rule which includes at least one match check.
- Click a 'Remove match check' link. The entire "Required match checks"
  block is removed.

To test, apply the patch and repeat the steps above. Clicking any
'Remove match check' link should remove only the corresponding rule.

Signed-off-by: Hector Castro <hector.hecaxmmx@gmail.com>
Works as advertised

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 5 Kyle M Hall 2016-07-08 12:50:33 UTC
Pushed to master for 16.11, thanks Owen!
Comment 6 Frédéric Demians 2016-08-01 13:23:12 UTC
Pushed in 16.05. Will be in 16.05.02.
Comment 7 Julian Maurice 2016-08-16 14:21:50 UTC
Patch pushed to 3.22.x, will be in 3.22.10