Bug 17734 - Make possible to pay and writeoff from boraccount page and make action buttons split button
Summary: Make possible to pay and writeoff from boraccount page and make action button...
Status: RESOLVED DUPLICATE of bug 24079
Alias: None
Product: Koha
Classification: Unclassified
Component: Fines and fees (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Josef Moravec
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-12-07 10:07 UTC by Josef Moravec
Modified: 2020-07-10 16:27 UTC (History)
8 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 17734: Make possible to pay and writeoff from boraccount page and make action buttons split button (7.05 KB, patch)
2016-12-07 11:10 UTC, Josef Moravec
Details | Diff | Splinter Review
Bug 17734: Get rid of reverse_col parameter (3.49 KB, patch)
2016-12-07 11:11 UTC, Josef Moravec
Details | Diff | Splinter Review
Bug 17734: Make possible to pay and writeoff from boraccount page and make action buttons split button (4.10 KB, patch)
2016-12-12 12:22 UTC, Radek Šiman (R-Bit Technology, s.r.o.)
Details | Diff | Splinter Review
Bug 17734: Make possible to pay and writeoff from boraccount page and make action buttons split button (7.18 KB, patch)
2016-12-14 12:36 UTC, Radek Šiman (R-Bit Technology, s.r.o.)
Details | Diff | Splinter Review
Bug 17734: Make possible to pay and writeoff from boraccount page and make action buttons split button (7.18 KB, patch)
2016-12-14 12:38 UTC, Radek Šiman (R-Bit Technology, s.r.o.)
Details | Diff | Splinter Review
Bug 17734: Make possible to pay and writeoff from boraccount page and make action buttons split button (7.18 KB, patch)
2016-12-14 12:45 UTC, Radek Šiman (R-Bit Technology, s.r.o.)
Details | Diff | Splinter Review
Bug 17734: Get rid of reverse_col parameter (3.62 KB, patch)
2016-12-14 12:51 UTC, Radek Šiman (R-Bit Technology, s.r.o.)
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Josef Moravec 2016-12-07 10:07:47 UTC

    
Comment 1 Josef Moravec 2016-12-07 11:10:59 UTC
Created attachment 58009 [details] [review]
Bug 17734: Make possible to pay and writeoff from boraccount page and make action buttons split button

Test plan
0) Have a patron with some fines - some payd and some unpaid
1) Apply the patch
2) Go to boraccount.pl page
3) In most right column you should see apropriate combination of buttons for
each row:
    Print - fee which was writted-off and write-off line
    Pay + Print in dropdown - unpaid fee, for user without permissin to writeoff
    Pay + Print and Write off in dropdown - unpaid fee, user with permission to writeoff
    Print + Reverse in dropdown - for payment row
4) Try all combination and use buttons and confirm they work as expected
Comment 2 Josef Moravec 2016-12-07 11:11:04 UTC
Created attachment 58010 [details] [review]
Bug 17734: Get rid of reverse_col parameter

As it's not needed anymore, we have at least "Print" action button for each row

Test plan:
1) Go to boraccount page, the last column header should have "Actions" title
2) git grep reverse_col should not return any appearence
Comment 3 Chris Kirby 2016-12-10 16:29:12 UTC
Paid a fine using the pay button in right column.
Reversed the payment using the reverse button dropdown
Now, action displays "Pay" and dropdown arrow appears but know options visible.
Should the dropdown arrow be removed since there are no longer are options?
Or should the "write off" and "print" be displayed in the dropdown menu again?
Comment 4 Josef Moravec 2016-12-10 22:08:32 UTC
(In reply to Chris Kirby from comment #3)
> Paid a fine using the pay button in right column.
> Reversed the payment using the reverse button dropdown
> Now, action displays "Pay" and dropdown arrow appears but know options
> visible.
> Should the dropdown arrow be removed since there are no longer are options?
> Or should the "write off" and "print" be displayed in the dropdown menu
> again?

You are right, there should always be the print action. I'll attach a followup soon.
Comment 5 Radek Šiman (R-Bit Technology, s.r.o.) 2016-12-12 12:22:51 UTC
Created attachment 58115 [details] [review]
Bug 17734: Make possible to pay and writeoff from boraccount page and make action buttons split button

Test plan
0) Have a patron with some fines - some paid and some unpaid
1) Apply the patch
2) git grep reverse_col should not return any appearence
3) Go to boraccount page, the last column header should have "Actions"
title
4) In the rightmost column you should see apropriate combination of buttons
for each row:
    Print - fee which was written-off and write-off line
    Pay + Print in dropdown - unpaid fee, for user without permission to
writeoff
    Pay + Print and Write off in dropdown - unpaid fee, user with
permission to writeoff
    Print + Reverse in dropdown - for payment row
5) Try all combination and use buttons and confirm they work as expected

Signed-off-by: Radek Šiman <rbit@rbit.cz>
Comment 6 Jonathan Druart 2016-12-13 15:35:05 UTC
fatal: sha1 information is lacking or useless (koha-tmpl/intranet-tmpl/prog/en/modules/members/boraccount.tt).
Comment 7 Josef Moravec 2016-12-14 08:14:21 UTC
Radek, what did you do with the patches? Looks like you join the second patch with commit message of first patch, so there is now code for second patch twice and no code from first patch... If don't know what happens, I can resubmit the original patches...
Comment 8 Josef Moravec 2016-12-14 08:33:29 UTC
I was contacted by Radek off Bugzilla and he now knows where the problem is and will try to re-sign off it, so I obsolete his attachment and unobsolete the original one.
Comment 9 Radek Šiman (R-Bit Technology, s.r.o.) 2016-12-14 12:36:15 UTC
Created attachment 58169 [details] [review]
Bug 17734: Make possible to pay and writeoff from boraccount page and make action buttons split button

Test plan
0) Have a patron with some fines - some paid and some unpaid
1) Apply the patch
2) git grep reverse_col should not return any appearence
3) Go to boraccount page, the last column header should have "Actions"
title
4) In the rightmost column you should see apropriate combination of buttons
for each row:
    Print - fee which was written-off and write-off line
    Pay + Print in dropdown - unpaid fee, for user without permission to
writeoff
    Pay + Print and Write off in dropdown - unpaid fee, user with
permission to writeoff
    Print + Reverse in dropdown - for payment row
5) Try all combination and use buttons and confirm they work as expected

Signed-off-by: Radek Šiman <rbit@rbit.cz>
Comment 10 Radek Šiman (R-Bit Technology, s.r.o.) 2016-12-14 12:38:41 UTC
Created attachment 58171 [details] [review]
Bug 17734: Make possible to pay and writeoff from boraccount page and make action buttons split button

Test plan
0) Have a patron with some fines - some payd and some unpaid
1) Apply the patch
2) Go to boraccount.pl page
3) In most right column you should see apropriate combination of buttons for
each row:
    Print - fee which was writted-off and write-off line
    Pay + Print in dropdown - unpaid fee, for user without permissin to writeoff
    Pay + Print and Write off in dropdown - unpaid fee, user with permission to writeoff
    Print + Reverse in dropdown - for payment row
4) Try all combination and use buttons and confirm they work as expected

Signed-off-by: Radek Šiman <rbit@rbit.cz>
Comment 11 Radek Šiman (R-Bit Technology, s.r.o.) 2016-12-14 12:41:51 UTC
Please forgive me, I'm really trying to do my best :-( I'm about to sign-off again.
Comment 12 Radek Šiman (R-Bit Technology, s.r.o.) 2016-12-14 12:45:41 UTC
Created attachment 58174 [details] [review]
Bug 17734: Make possible to pay and writeoff from boraccount page and make action buttons split button

Test plan
0) Have a patron with some fines - some payd and some unpaid
1) Apply the patch
2) Go to boraccount.pl page
3) In most right column you should see apropriate combination of buttons for
each row:
    Print - fee which was writted-off and write-off line
    Pay + Print in dropdown - unpaid fee, for user without permissin to writeoff
    Pay + Print and Write off in dropdown - unpaid fee, user with permission to writeoff
    Print + Reverse in dropdown - for payment row
4) Try all combination and use buttons and confirm they work as expected

Signed-off-by: Radek Šiman <rbit@rbit.cz>
Comment 13 Radek Šiman (R-Bit Technology, s.r.o.) 2016-12-14 12:51:22 UTC
Created attachment 58175 [details] [review]
Bug 17734: Get rid of reverse_col parameter

As it's not needed anymore, we have at least "Print" action button for each row

Test plan:
1) Go to boraccount page, the last column header should have "Actions" title
2) git grep reverse_col should not return any appearence

Signed-off-by: Radek Šiman <rbit@rbit.cz>
Comment 14 Jonathan Druart 2017-01-02 12:23:21 UTC
I get a menu with "Pay", an arrow to open the dropdown, but it is empty.
To recreate:
- Create a manual invoice
- Account tab, click pay
- Reverse the payment
Comment 15 Martin Renvoize 2020-04-03 13:46:29 UTC

*** This bug has been marked as a duplicate of bug 24604 ***
Comment 16 Martin Renvoize 2020-07-10 16:27:16 UTC

*** This bug has been marked as a duplicate of bug 24079 ***