Bug 17796 - Koha::Issues should be moved to Koha::Checkouts
Summary: Koha::Issues should be moved to Koha::Checkouts
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Architecture, internals, and plumbing (show other bugs)
Version: unspecified
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Keywords:
: 16870 (view as bug list)
Depends on: 16086
Blocks: 17584 17678 17689
  Show dependency treegraph
 
Reported: 2016-12-20 13:00 UTC by Jonathan Druart
Modified: 2018-06-04 20:10 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 17796: Replace Koha::Issue[s] with Koha::Checkout[s] (11.80 KB, patch)
2016-12-20 13:10 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 17796: Move Koha::OldIssue[s] to Koha::Checkout[s] (3.25 KB, patch)
2016-12-20 13:28 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 17796: Move Koha::OldIssue[s] to Koha::Checkout[s] (3.30 KB, patch)
2016-12-20 13:32 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 17796: Replace Koha::Issue[s] with Koha::Checkout[s] (11.85 KB, patch)
2016-12-20 14:22 UTC, Nick Clemens
Details | Diff | Splinter Review
Bug 17796: Move Koha::OldIssue[s] to Koha::Checkout[s] (3.35 KB, patch)
2016-12-20 14:22 UTC, Nick Clemens
Details | Diff | Splinter Review
Bug 17796: Replace Koha::Issue[s] with Koha::Checkout[s] (11.91 KB, patch)
2016-12-20 15:13 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 17796: Move Koha::OldIssue[s] to Koha::Checkout[s] (3.41 KB, patch)
2016-12-20 15:14 UTC, Kyle M Hall
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Druart 2016-12-20 13:00:59 UTC
Koha::Issues and Koha::Checkouts have been added to the codebase to represent the same thing.

In ODLIS the word Issue is never used in the sense we use it. Another problem with Issue is it has so many meaning in English (such as problem/bug)
The word Checkout *is* in ODLIS, closer to what we use: http://www.abc-clio.com/ODLIS/odlis_c.aspx#checkoutslip
Comment 1 Jonathan Druart 2016-12-20 13:10:25 UTC
Created attachment 58290 [details] [review]
Bug 17796: Replace Koha::Issue[s] with Koha::Checkout[s]

Koha::Issues and Koha::Checkouts have been added to the codebase to
represent the same thing.

In ODLIS the word Issue is never used in the sense we use it. Another
problem with Issue is it has so many meaning in English (such as
problem/bug)
The word Checkout *is* in ODLIS, closer to what we use:
http://www.abc-clio.com/ODLIS/odlis_c.aspx#checkoutslip

Test plan:
  git grep Koha::Issue
should not return any occurrences and the tests must still pass
Comment 2 Jonathan Druart 2016-12-20 13:28:39 UTC
Created attachment 58291 [details] [review]
Bug 17796: Move Koha::OldIssue[s] to Koha::Checkout[s]
Comment 3 Jonathan Druart 2016-12-20 13:32:57 UTC
Created attachment 58292 [details] [review]
Bug 17796: Move Koha::OldIssue[s] to Koha::Checkout[s]
Comment 4 Nick Clemens 2016-12-20 14:22:53 UTC
Created attachment 58296 [details] [review]
Bug 17796: Replace Koha::Issue[s] with Koha::Checkout[s]

Koha::Issues and Koha::Checkouts have been added to the codebase to
represent the same thing.

In ODLIS the word Issue is never used in the sense we use it. Another
problem with Issue is it has so many meaning in English (such as
problem/bug)
The word Checkout *is* in ODLIS, closer to what we use:
http://www.abc-clio.com/ODLIS/odlis_c.aspx#checkoutslip

Test plan:
  git grep Koha::Issue
should not return any occurrences and the tests must still pass

Signed-off-by: Nick Clemens <nick@bywatersolutions.com>
Comment 5 Nick Clemens 2016-12-20 14:22:59 UTC
Created attachment 58297 [details] [review]
Bug 17796: Move Koha::OldIssue[s] to Koha::Checkout[s]

Signed-off-by: Nick Clemens <nick@bywatersolutions.com>
Comment 6 Kyle M Hall 2016-12-20 15:13:53 UTC
Created attachment 58301 [details] [review]
Bug 17796: Replace Koha::Issue[s] with Koha::Checkout[s]

Koha::Issues and Koha::Checkouts have been added to the codebase to
represent the same thing.

In ODLIS the word Issue is never used in the sense we use it. Another
problem with Issue is it has so many meaning in English (such as
problem/bug)
The word Checkout *is* in ODLIS, closer to what we use:
http://www.abc-clio.com/ODLIS/odlis_c.aspx#checkoutslip

Test plan:
  git grep Koha::Issue
should not return any occurrences and the tests must still pass

Signed-off-by: Nick Clemens <nick@bywatersolutions.com>

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 7 Kyle M Hall 2016-12-20 15:14:03 UTC
Created attachment 58302 [details] [review]
Bug 17796: Move Koha::OldIssue[s] to Koha::Checkout[s]

Signed-off-by: Nick Clemens <nick@bywatersolutions.com>

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 8 Kyle M Hall 2016-12-20 15:14:18 UTC
Pushed to master for 17.05, thanks Jonathan!
Comment 9 Katrin Fischer 2016-12-22 19:19:24 UTC
This won't get ported back to 16.11.x as it is an enhancement.
Comment 10 M. Tompsett 2017-01-17 04:17:01 UTC
How might this be related to 16870?
Comment 11 Jonathan Druart 2017-01-17 07:47:49 UTC
*** Bug 16870 has been marked as a duplicate of this bug. ***