Bug 18296 - C4::Items - Remove GetItemInfosOf
Summary: C4::Items - Remove GetItemInfosOf
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Architecture, internals, and plumbing (show other bugs)
Version: unspecified
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Jonathan Druart
QA Contact: Marcel de Rooy
URL:
Whiteboard:
Keywords:
: 18753 (view as bug list)
Depends on: 18295
Blocks: 18252
  Show dependency treegraph
 
Reported: 2017-03-17 16:20 UTC by Jonathan Druart
Modified: 2017-06-13 07:31 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 18295: C4::Items - get_itemnumbers_of (9.51 KB, patch)
2017-03-17 17:25 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 18296: C4::Items - Remove GetItemInfosOf (4.13 KB, patch)
2017-03-17 17:28 UTC, Jonathan Druart
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 18296: C4::Items - Remove GetItemInfosOf (4.01 KB, patch)
2017-05-31 19:07 UTC, Josef Moravec
Details | Diff | Splinter Review
Bug 18296: C4::Items - Remove GetItemInfosOf (4.02 KB, patch)
2017-06-02 16:14 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 18296: C4::Items - Remove GetItemInfosOf (4.00 KB, patch)
2017-06-06 13:19 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 18296: C4::Items - Remove GetItemInfosOf (4.08 KB, patch)
2017-06-07 06:40 UTC, Marcel de Rooy
Details | Diff | Splinter Review
Bug 18296: Remove perlcritic error (request.pl) (1.04 KB, patch)
2017-06-08 15:00 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Druart 2017-03-17 16:20:10 UTC

    
Comment 1 Jonathan Druart 2017-03-17 17:25:42 UTC Comment hidden (obsolete)
Comment 2 Jonathan Druart 2017-03-17 17:28:23 UTC
Created attachment 61226 [details] [review]
Bug 18296: C4::Items - Remove GetItemInfosOf

At this point this subroutine is only used once, from reserve/request.pl.
Since we already have the items, it's easy to populate the different
hashes as the rest of the code is expecting it.

Test plan:
You need to create analytical record relationships (
EasyAnalyticalRecords needs to be set). Link an item to a biblio using
the 'Edit > Link to host item' menu from the biblio detail page.
From the staff interface place a hold on the biblio. You should see the
items from the biblio and the one you just linked
Comment 3 Josef Moravec 2017-05-31 19:07:31 UTC
Created attachment 63888 [details] [review]
[SIGNED-OFF] Bug 18296: C4::Items - Remove GetItemInfosOf

At this point this subroutine is only used once, from reserve/request.pl.
Since we already have the items, it's easy to populate the different
hashes as the rest of the code is expecting it.

Test plan:
You need to create analytical record relationships (
EasyAnalyticalRecords needs to be set). Link an item to a biblio using
the 'Edit > Link to host item' menu from the biblio detail page.
From the staff interface place a hold on the biblio. You should see the
items from the biblio and the one you just linked

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>
Comment 4 Marcel de Rooy 2017-06-02 08:39:37 UTC
Cannot apply this on top of 18295.
Regardless of applying 18279 in between or not.
Comment 5 Jonathan Druart 2017-06-02 16:14:04 UTC
Created attachment 63944 [details] [review]
Bug 18296: C4::Items - Remove GetItemInfosOf

At this point this subroutine is only used once, from reserve/request.pl.
Since we already have the items, it's easy to populate the different
hashes as the rest of the code is expecting it.

Test plan:
You need to create analytical record relationships (
EasyAnalyticalRecords needs to be set). Link an item to a biblio using
the 'Edit > Link to host item' menu from the biblio detail page.
From the staff interface place a hold on the biblio. You should see the
items from the biblio and the one you just linked

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>
Comment 6 Jonathan Druart 2017-06-02 16:15:29 UTC
(In reply to Marcel de Rooy from comment #4)
> Cannot apply this on top of 18295.
> Regardless of applying 18279 in between or not.

It applied ok for me, reattached anyway

1c01bbb112 Bug 18296: C4::Items - Remove GetItemInfosOf
81caf630f1 Bug 18295: C4::Items - get_itemnumbers_of
5d94ff7513 DBRev 17.05.00.000
Comment 7 Marcel de Rooy 2017-06-06 10:59:12 UTC
(In reply to Jonathan Druart from comment #6)
> (In reply to Marcel de Rooy from comment #4)
> > Cannot apply this on top of 18295.
> > Regardless of applying 18279 in between or not.
> 
> It applied ok for me, reattached anyway
> 
> 1c01bbb112 Bug 18296: C4::Items - Remove GetItemInfosOf
> 81caf630f1 Bug 18295: C4::Items - get_itemnumbers_of
> 5d94ff7513 DBRev 17.05.00.000

Current master now:

Applying: Bug 18296: C4::Items - Remove GetItemInfosOf
fatal: sha1 information is lacking or useless (C4/Items.pm).
Repository lacks necessary blobs to fall back on 3-way merge.
Comment 8 Jonathan Druart 2017-06-06 13:19:21 UTC
Created attachment 64050 [details] [review]
Bug 18296: C4::Items - Remove GetItemInfosOf

At this point this subroutine is only used once, from reserve/request.pl.
Since we already have the items, it's easy to populate the different
hashes as the rest of the code is expecting it.

Test plan:
You need to create analytical record relationships (
EasyAnalyticalRecords needs to be set). Link an item to a biblio using
the 'Edit > Link to host item' menu from the biblio detail page.
From the staff interface place a hold on the biblio. You should see the
items from the biblio and the one you just linked

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>
Comment 9 Marcel de Rooy 2017-06-07 06:17:38 UTC
It applies now! Thanks.
Comment 10 Marcel de Rooy 2017-06-07 06:40:48 UTC
Created attachment 64073 [details] [review]
Bug 18296: C4::Items - Remove GetItemInfosOf

At this point this subroutine is only used once, from reserve/request.pl.
Since we already have the items, it's easy to populate the different
hashes as the rest of the code is expecting it.

Test plan:
You need to create analytical record relationships (
EasyAnalyticalRecords needs to be set). Link an item to a biblio using
the 'Edit > Link to host item' menu from the biblio detail page.
From the staff interface place a hold on the biblio. You should see the
items from the biblio and the one you just linked

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>

Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl>
Comment 11 Jonathan Druart 2017-06-07 14:32:05 UTC
Pushed to master for 17.11, thanks to everybody involved!
Comment 12 Jonathan Druart 2017-06-08 15:00:23 UTC
Created attachment 64106 [details] [review]
Bug 18296: Remove perlcritic error (request.pl)

"$itemnumbers_of_biblioitem" is declared but not used at line 314,
column 5.  Unused variables clutter code and make it harder to read.
(Severity: 3)
Comment 13 Jonathan Druart 2017-06-08 15:02:10 UTC
Last patch pushed to master!
Comment 14 Jonathan Druart 2017-06-08 15:12:20 UTC
*** Bug 18753 has been marked as a duplicate of this bug. ***
Comment 15 Fridolin SOMERS 2017-06-13 07:31:41 UTC
Enhancement not pushed to 17.05.x