Bug 18490 - Transfer message confusing, cancel button missing
Summary: Transfer message confusing, cancel button missing
Status: RESOLVED DUPLICATE of bug 21346
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Christopher Brannon
QA Contact: Testopia
URL:
Keywords:
Depends on: 21346
Blocks: 18503
  Show dependency treegraph
 
Reported: 2017-04-24 23:50 UTC by Christopher Brannon
Modified: 2018-11-08 18:55 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
[Bug 18490] Change transfer message/show cancel (16.62 KB, patch)
2017-04-25 00:13 UTC, Christopher Brannon
Details | Diff | Splinter Review
Applied the patch but no changes (121.34 KB, image/jpeg)
2017-06-23 02:40 UTC, Ryn
Details
No Cancel button displayed (8.15 KB, image/png)
2017-09-08 00:17 UTC, Alex Buckley
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher Brannon 2017-04-24 23:50:35 UTC
When checking in an item that is being transferred to another branch (not for a reserve), the dialog is a bit confusing.  It says:

Please return item to: Library XYZ

And then shows a Print slip button.

I see two problems.  First, checking in the item initiates the transfer, and this is not clear in the message.  Second, you can't cancel the hold unless you check it in again, and then you get the Cancel transfer button.

I don't think there is any reason not to show the cancel button the first time around.  I also think it would be much clearer as to what is going on if the message read:

Transferring item to: Library XYZ

I am open to suggestions on the phrasing.
Comment 1 Christopher Brannon 2017-04-25 00:13:41 UTC
Created attachment 62649 [details] [review]
[Bug 18490] Change transfer message/show cancel

This patch changes the transfer message and shows the cancel button on
the first checkin.  I've also cleaned up some formatting in the code.

To test:

Test A:
1) Check in an item at a library other than its homebranch.

Test B:
2) Place an item on hold to be picked up at another library.
3) Check in the item at a library other than the home branch or pickup
loccation.

Test C:
4) Add item to a rotating collection.
5) Transfer collection to another library.
6) Check in the item to trigger the transfer.

7) On each test, notice the phrase "Please transfer item to:" and notice
that the Cancel transfer button does not appear on the first checkin.

8) Apply patch.
9) Repeat steps 1-6.
10) On each test notice the phrase is now "Transferring item to:" and
notice that the Cancel transfer button now shows after the first
checkin.
Comment 2 Ryn 2017-06-23 02:40:34 UTC
Created attachment 64561 [details]
Applied the patch but no changes

We have tested the patch, doing all the Test Plan and repeat the Test Plan after applying the patch.
We find out that there are no changes after patch is applied. We tested in Sandbox01, BibLibre UNIMARC on 23rd June 2017, 1000am Philippine Time. Attachment shows the dialog box after the patch is applied, there are no 'Cancel' button. So does on the other Test Plan.
Comment 3 Koha Team University Lyon 3 2017-07-13 12:52:39 UTC
regarding comment 2
Comment 4 Christopher Brannon 2017-08-25 18:08:46 UTC
Patch works.  Maybe sandbox testing issue.  Test environment may need a restart?
Comment 5 Alex Buckley 2017-09-08 00:17:47 UTC
Created attachment 66967 [details]
No Cancel button displayed

Hi Christopher

When I tested this patch I found that the 'Transferring item to:' text was displayed in Test A, B, and C however the 'Cancel' button is only being displayed in test C
Comment 6 Alex Buckley 2017-09-08 00:40:17 UTC
OK so I have now got it displaying the 'cancel transfer' button, so the patch works as described in the test plan. 

However running the QA test it fails on valid_template, could you please fix this up Christopher and then I'll be happy to re-test and sign off on your patch

 FAIL	koha-tmpl/intranet-tmpl/prog/en/modules/circ/returns.tt
   OK	  forbidden patterns
   OK	  git manipulation
   OK	  spelling
   OK	  tt_valid
   FAIL	  valid_template
Comment 7 Christopher Brannon 2018-09-16 16:15:50 UTC
I'm going to hold off on this until 21346 is pushed.  Doesn't completely depend on it, but there are enough changes there that I would like to work from that point forward.
Comment 8 Christopher Brannon 2018-11-08 18:55:18 UTC
Bug 21346 addresses and corrects this issue.

*** This bug has been marked as a duplicate of bug 21346 ***