Bug 18503 - Confusing hold and transfer dialog
Summary: Confusing hold and transfer dialog
Status: CLOSED WONTFIX
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Christopher Brannon
QA Contact: Testopia
URL:
Keywords:
Depends on: 18490
Blocks:
  Show dependency treegraph
 
Reported: 2017-04-27 17:16 UTC by Christopher Brannon
Modified: 2019-10-14 19:58 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 18503: Fixes confusing dialog and other minor (16.45 KB, patch)
2017-05-02 20:54 UTC, Christopher Brannon
Details | Diff | Splinter Review
Bug 18503: Fixes confusing dialog and other minor (16.44 KB, patch)
2017-08-25 22:58 UTC, Christopher Brannon
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher Brannon 2017-04-27 17:16:26 UTC
To produce the confusing dialog:

1) Place an item belonging to Library A on hold for Patron 1 for pickup at Library B.
2) Trigger hold.  Item is now in transit to Library B.
3) Check in item at Library C (item ended up in their hands by mistake).
4) Note 4 buttons.  Not clear what to do.

Realistically, the hold should be the focus, and sent along with either of the two bottom buttons.  The top buttons do not need to be there.  Why transfer the item home when it will just continue to trigger the hold?
Comment 1 Christopher Brannon 2017-05-02 20:54:21 UTC
Created attachment 62990 [details] [review]
Bug 18503: Fixes confusing dialog and other minor

This corrects the returns2 dialog logic, and cleans up a few pieces of
code.  Patch also updates some buttons and fixes check in layout.

To Test:
1) Check out an item.
2) Check item in.  Note old buttons (Submit next to barcode, Clear).
Note message next to calendar is wrapping to next line.  Note Clear
button is next to the check box rather than next to the calendar.
3) Check in item at a different branch both with AllowReturnToBranch in
all four settings and with AutomaticItemReturn set to Do and Don't.
Note old style buttons on all dialogs.
4) Place a hold on an item for pickup at another library.
5) Trigger the hold and confirm.
6) Check in item at another library (not the pickup location).
7) Note the confusing transfer/hold buttons and message.
8) Apply patch
9) Repeat steps 1-8.  Note changes to the items pointed out in those
steps.
Comment 2 Alex Buckley 2017-05-02 21:33:27 UTC
Hi Christopher 

When I apply this patch on a up to date clean branch I get the following error:

Applying: Bug 18503: Fixes confusing dialog and other minor
fatal: sha1 information is lacking or useless (koha-tmpl/intranet-tmpl/prog/en/modules/circ/returns.tt).
Repository lacks necessary blobs to fall back on 3-way merge.
Cannot fall back to three-way merge.
Patch failed at 0001 Bug 18503: Fixes confusing dialog and other minor
The copy of the patch that failed is found in:
   /home/vagrant/kohaclone/.git/rebase-apply/patch
When you have resolved this problem run "git bz apply --continue".
If you would prefer to skip this patch, instead run "git bz apply --skip".
To restore the original branch and stop patching run "git bz apply --abort".
Patch left in /tmp/Bug-18503-Fixes-confusing-dialog-and-other-minor-JMU2nv.patch
Comment 3 Christopher Brannon 2017-05-02 21:36:52 UTC
Did you apply the(In reply to Alex Buckley from comment #2)
> Hi Christopher 
> 
> When I apply this patch on a up to date clean branch I get the following
> error:
> 
> Applying: Bug 18503: Fixes confusing dialog and other minor
> fatal: sha1 information is lacking or useless
> (koha-tmpl/intranet-tmpl/prog/en/modules/circ/returns.tt).
> Repository lacks necessary blobs to fall back on 3-way merge.
> Cannot fall back to three-way merge.
> Patch failed at 0001 Bug 18503: Fixes confusing dialog and other minor
> The copy of the patch that failed is found in:
>    /home/vagrant/kohaclone/.git/rebase-apply/patch
> When you have resolved this problem run "git bz apply --continue".
> If you would prefer to skip this patch, instead run "git bz apply --skip".
> To restore the original branch and stop patching run "git bz apply --abort".
> Patch left in
> /tmp/Bug-18503-Fixes-confusing-dialog-and-other-minor-JMU2nv.patch

Did you apply patch 18490?  This patch depends on it.
Comment 4 Alex Buckley 2017-05-02 21:59:43 UTC
Yup I applied bug 18490 first
Comment 5 Christopher Brannon 2017-08-25 22:58:05 UTC
Created attachment 66494 [details] [review]
Bug 18503: Fixes confusing dialog and other minor

This corrects the returns2 dialog logic, and cleans up a few pieces of
code.  Patch also updates some buttons and fixes check in layout.

To Test:
1) Check out an item.
2) Check item in.  Note old buttons (Submit next to barcode, Clear).
Note message next to calendar is wrapping to next line.  Note Clear
button is next to the check box rather than next to the calendar.
3) Check in item at a different branch both with AllowReturnToBranch in
all four settings and with AutomaticItemReturn set to Do and Don't.
Note old style buttons on all dialogs.
4) Place a hold on an item for pickup at another library.
5) Trigger the hold and confirm.
6) Check in item at another library (not the pickup location).
7) Note the confusing transfer/hold buttons and message.
8) Apply patch
9) Repeat steps 1-8.  Note changes to the items pointed out in those
steps.
Comment 6 Christopher Brannon 2017-08-25 23:01:08 UTC
Rebased.  Sorry for delay!  Please try again.
Comment 7 Christopher Brannon 2017-08-25 23:10:18 UTC
Confirm button doesn't trigger hold at remote library.  Regression of a bug.  Need to fix.
Comment 8 Katrin Fischer 2017-08-27 11:39:37 UTC
Hi Christopher, you might have run into bug 19116
Comment 9 Christopher Brannon 2017-08-29 22:12:55 UTC
(In reply to Katrin Fischer from comment #8)
> Hi Christopher, you might have run into bug 19116

I believe you are correct.  I was thinking I might have broke something, but I do recall this bug coming up on one of our last upgrades, and someone fixed it (probably applied the patch).

I have tested, and it is a pre-existing condition that this patch doesn't address, so we are good to go.  Thanks!
Comment 10 Caroline Cyr La Rose 2017-09-08 18:41:25 UTC
I tried to apply the patch, and the system gave me an error

fatal: sha1 information is lacking or useless (koha-tmpl/intranet-tmpl/prog/en/modules/circ/returns.tt).
Comment 11 Christopher Brannon 2018-09-14 16:52:36 UTC
I see some things have changed since I have been able to work on this.  I am going to rework the patch and some of the elements being addressed.
Comment 12 Christopher Brannon 2018-09-14 19:18:43 UTC
Looks like some things are already fixed, and some things are being addressed elsewhere.  So I am closing this bug, and I am going to start a new bug to address some of the leftovers.