Bug 18597 - Quick add form does not transfer patron attributes values when switching forms/saving
Summary: Quick add form does not transfer patron attributes values when switching form...
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Patrons (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Nick Clemens
QA Contact: Testopia
URL:
Keywords:
: 18612 (view as bug list)
Depends on: 3534
Blocks:
  Show dependency treegraph
 
Reported: 2017-05-12 14:02 UTC by Nick Clemens
Modified: 2017-12-07 22:20 UTC (History)
7 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 18597 - Quick add form does not transfer patron attributes values when switching forms/saving (2.71 KB, patch)
2017-05-12 14:08 UTC, Nick Clemens
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 18597 - Quick add form does not transfer patron attributes values when switching forms/saving (2.78 KB, patch)
2017-05-12 14:46 UTC, Nick Clemens
Details | Diff | Splinter Review
Bug 18597 - Quick add form does not transfer patron attributes values when switching forms/saving (2.85 KB, patch)
2017-05-18 19:34 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Nick Clemens 2017-05-12 14:02:59 UTC
To recreate
1 - Have some patron attributes (with/without auth values set)
2 - Add them to QuickAddFields (patron_attr2 for example)
3 - view quick add form and set some values
4 - Switch to full form, values not transferred
5 - Swithc to quick add, view values, save
6 - Values are not saved :-(
Comment 1 Nick Clemens 2017-05-12 14:08:22 UTC
Created attachment 63443 [details] [review]
Bug 18597 - Quick add form does not transfer patron attributes values when switching forms/saving

The function that switches between quick add/fulll form assumes labels
are followed by values - patron_attr don't follow this pattern. This
patch just moves the hidden input field

To test:
1 - Have some patron attributes (with/without auth values set)
2 - Add them to QuickAddFields (patron_attr2 for example)
3 - view quick add form and set some values
4 - Switch to full form, values not transferred
5 - Switch to quick add, view values, save
6 - Values are not saved :-(
7 - Apply patch
8 - Repeat 3 - 5
9 - Values are transferred and saved :-)
Comment 2 Nick Clemens 2017-05-12 14:46:05 UTC
Created attachment 63448 [details] [review]
[SIGNED-OFF] Bug 18597 - Quick add form does not transfer patron attributes values when switching forms/saving

The function that switches between quick add/fulll form assumes labels
are followed by values - patron_attr don't follow this pattern. This
patch just moves the hidden input field

To test:
1 - Have some patron attributes (with/without auth values set)
2 - Add them to QuickAddFields (patron_attr2 for example)
3 - view quick add form and set some values
4 - Switch to full form, values not transferred
5 - Switch to quick add, view values, save
6 - Values are not saved :-(
7 - Apply patch
8 - Repeat 3 - 5
9 - Values are transferred and saved :-)

Signed-off-by: Peggy Thrasher <p.thrasher@dover.nh.gov>
Comment 3 Nick Clemens 2017-05-16 02:42:56 UTC
*** Bug 18612 has been marked as a duplicate of this bug. ***
Comment 4 Jonathan Druart 2017-05-18 19:29:47 UTC
I do not manage to see the patron attributes on the quick add form.
Comment 5 Jonathan Druart 2017-05-18 19:33:03 UTC
(In reply to Jonathan Druart from comment #4)
> I do not manage to see the patron attributes on the quick add form.

Ha, we have to guess the id of the attribute in DB. That's very badly implemented.
Comment 6 Jonathan Druart 2017-05-18 19:34:03 UTC
Created attachment 63543 [details] [review]
Bug 18597 - Quick add form does not transfer patron attributes values when switching forms/saving

The function that switches between quick add/fulll form assumes labels
are followed by values - patron_attr don't follow this pattern. This
patch just moves the hidden input field

To test:
1 - Have some patron attributes (with/without auth values set)
2 - Add them to QuickAddFields (patron_attr2 for example)
3 - view quick add form and set some values
4 - Switch to full form, values not transferred
5 - Switch to quick add, view values, save
6 - Values are not saved :-(
7 - Apply patch
8 - Repeat 3 - 5
9 - Values are transferred and saved :-)

Signed-off-by: Peggy Thrasher <p.thrasher@dover.nh.gov>

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 7 Kyle M Hall 2017-05-19 14:39:27 UTC
Pushed to master for 17.05, thanks Nick!
Comment 8 Katrin Fischer 2017-05-21 21:24:50 UTC
This patch has been pushed to 16.11.x and will be in 16.11.08.
Comment 9 Mason James 2017-05-24 03:14:15 UTC
Blocked by new feature, skipping for 16.05.x