Bug 18612 - Quick add new patron do not save additional attributes
Summary: Quick add new patron do not save additional attributes
Status: RESOLVED DUPLICATE of bug 18597
Alias: None
Product: Koha
Classification: Unclassified
Component: Patrons (show other bugs)
Version: 16.11
Hardware: Other Linux
: P5 - low normal (vote)
Assignee: Bugs List
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-05-15 23:56 UTC by Sven H.
Modified: 2017-05-16 02:42 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sven H. 2017-05-15 23:56:31 UTC
I had created some Patron attribute types (example "Klasse" = "patron_attr_1") and added them to BorrowerMandatoryField and PatronQuickAddFields.

If i create a new patron via "Quick add patron", the value is not saved. If i do the same action in full view the value is saved.

Test
----
1. add new category list in authorized values
2. add new Patron attribute type with Authorized value category from 1.
3. Add attributes to system preferences/patrons/BorrowerMandatoryField and PatronQuickAddFields
4. Quick add patron

System: Ubuntu 16.04 LTS, koha 16.11, fresh installed system

Screenshots
-----------
Patron attribute type: http://prntscr.com/f89v3x
Authorized Values: http://prntscr.com/f89vgz
System preferences: http://prntscr.com/f89w91
Quick add patron: http://prntscr.com/f89wyk
New patron after saving quick add: http://prntscr.com/f89xp8
New patron after edit additional attributes or saving via full formular: http://prntscr.com/f89y9p
Comment 1 Nick Clemens 2017-05-16 02:42:56 UTC

*** This bug has been marked as a duplicate of bug 18597 ***