Bug 18662 - Can not delete currencies
Summary: Can not delete currencies
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: System Administration (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on: 13726
Blocks: 18684
  Show dependency treegraph
 
Reported: 2017-05-23 15:45 UTC by Marc Véron
Modified: 2017-06-05 12:23 UTC (History)
7 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 18662: Fix currency deletion (1.28 KB, patch)
2017-05-23 16:05 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 18662: Fix currency deletion (1.41 KB, patch)
2017-05-23 16:57 UTC, Marc Véron
Details | Diff | Splinter Review
Bug 18662: Fix currency deletion (1.47 KB, patch)
2017-05-24 14:45 UTC, Julian Maurice
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Véron 2017-05-23 15:45:51 UTC
Trying to delete any currency leads to a message:
"Cannot delete currency 'XYZ' This currency is used by Koha::Acquisition::Booksellers=HASH(0xec48a4c) vendors. Deletion not possible"

To reproduce:
- Go to Home > Administration > Currencies & Exchange rates
- Add a new currency (to make sure that it is not used by any bookseller)
- Try to delete currency (or any other)

Result: Message above.
Comment 1 Jonathan Druart 2017-05-23 16:05:08 UTC
Created attachment 63662 [details] [review]
Bug 18662: Fix currency deletion

Sounds like it is caused by bug 13726.
It is not possible to delete a currency, even if not used by any vendors

Test plan:
Try and delete currencies used or not by vendors.
Comment 2 Marc Véron 2017-05-23 16:57:25 UTC
Created attachment 63664 [details] [review]
Bug 18662: Fix currency deletion

Sounds like it is caused by bug 13726.
It is not possible to delete a currency, even if not used by any vendors

Test plan:
Try and delete currencies used or not by vendors.

Signed-off-by: Marc Véron <veron@veron.ch>
Comment 3 Julian Maurice 2017-05-24 14:45:18 UTC
Created attachment 63699 [details] [review]
Bug 18662: Fix currency deletion

Sounds like it is caused by bug 13726.
It is not possible to delete a currency, even if not used by any vendors

Test plan:
Try and delete currencies used or not by vendors.

Signed-off-by: Marc Véron <veron@veron.ch>
Signed-off-by: Julian Maurice <julian.maurice@biblibre.com>
Comment 4 Kyle M Hall 2017-05-29 02:07:24 UTC
Pushed to master for 17.05, thanks Jonathan!
Comment 5 Katrin Fischer 2017-06-05 12:23:09 UTC
Depends on bug 13726 which is not in 16.11.x.