Bug 19458 - Self-check module highlighting
Summary: Self-check module highlighting
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Self checkout (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Agustín Moyano
QA Contact: Alex Arnaud
URL:
Keywords:
: 15488 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-10-13 13:27 UTC by Kyle M Hall
Modified: 2019-05-30 12:18 UTC (History)
8 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Who signed the patch off:
Text to go in the release notes:
This enhancement highlights new checkouts/renewals in the self-check display to make it easier to see which actions have been performed in the user's session
Version(s) released in:


Attachments
First patch of 2 (4.16 KB, patch)
2018-12-14 03:08 UTC, Agustín Moyano
Details | Diff | Splinter Review
Second patch of 2 (7.90 KB, patch)
2018-12-14 03:09 UTC, Agustín Moyano
Details | Diff | Splinter Review
Bug 19458: Self-check module highlighting (4.21 KB, patch)
2018-12-19 08:48 UTC, Josef Moravec
Details | Diff | Splinter Review
Bug 19458: (follow-up) Self-check module highlighting (7.95 KB, patch)
2018-12-19 08:48 UTC, Josef Moravec
Details | Diff | Splinter Review
Bug 19458: Self-check module highlighting (4.25 KB, patch)
2018-12-26 15:02 UTC, Alex Arnaud
Details | Diff | Splinter Review
Bug 19458: (follow-up) Self-check module highlighting (7.99 KB, patch)
2018-12-26 15:02 UTC, Alex Arnaud
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Kyle M Hall 2017-10-13 13:27:20 UTC
Work to be done

1. Identify new checkouts and renewals
2. Pass this data to the template
3. Have template apply a special class to those checkouts
4. Apply CSS to style these checkouts
Comment 1 Agustín Moyano 2018-12-14 03:08:49 UTC
Created attachment 83193 [details] [review]
First patch of 2
Comment 2 Agustín Moyano 2018-12-14 03:09:16 UTC
Created attachment 83194 [details] [review]
Second patch of 2
Comment 3 Josef Moravec 2018-12-19 08:48:12 UTC
Created attachment 83382 [details] [review]
Bug 19458: Self-check module highlighting

In SCO Module there is no difference on how new checkouts and renewals are shown from previous ones. This commit is done to address that issue.

How to test:
1. Go to /cgi-bin/koha/sco/sco-main.pl and login.
2. Checkout a new item.
3. In checkout's table new checkouts should be easily identifiable.

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>
Comment 4 Josef Moravec 2018-12-19 08:48:18 UTC
Created attachment 83383 [details] [review]
Bug 19458: (follow-up) Self-check module highlighting

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>
Comment 5 Alex Arnaud 2018-12-26 15:02:43 UTC
Created attachment 83488 [details] [review]
Bug 19458: Self-check module highlighting

In SCO Module there is no difference on how new checkouts and renewals are shown from previous ones. This commit is done to address that issue.

How to test:
1. Go to /cgi-bin/koha/sco/sco-main.pl and login.
2. Checkout a new item.
3. In checkout's table new checkouts should be easily identifiable.

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>
Signed-off-by: Alex Arnaud <alex.arnaud@biblibre.com>
Comment 6 Alex Arnaud 2018-12-26 15:02:50 UTC
Created attachment 83489 [details] [review]
Bug 19458: (follow-up) Self-check module highlighting

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>
Signed-off-by: Alex Arnaud <alex.arnaud@biblibre.com>
Comment 7 Nick Clemens 2019-01-11 13:31:31 UTC
Awesome work all!

Pushed to master for 19.05
Comment 8 Martin Renvoize 2019-01-14 14:06:06 UTC
Enhancement, will not be backported to 18.11.x series
Comment 9 Joy Nelson 2019-02-14 13:34:03 UTC
*** Bug 15488 has been marked as a duplicate of this bug. ***