Bug 19959 - Update popup window templates to use Bootstrap grid: Label creator
Summary: Update popup window templates to use Bootstrap grid: Label creator
Status: RESOLVED DUPLICATE of bug 19709
Alias: None
Product: Koha
Classification: Unclassified
Component: Templates (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Owen Leonard
QA Contact: Testopia
URL:
Keywords: Academy
Depends on:
Blocks: 19931
  Show dependency treegraph
 
Reported: 2018-01-11 18:32 UTC by Owen Leonard
Modified: 2018-05-11 12:17 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 19959: Update popup window templates to use Bootstrap grid: Label creator (3.02 KB, patch)
2018-01-11 18:41 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 19959: Update popup window templates to use Bootstrap grid: Label creator (3.09 KB, patch)
2018-01-18 20:58 UTC, Charlotte Cordwell
Details | Diff | Splinter Review
Bug 19959: Update popup window templates to use Bootstrap grid: Label creator (7.13 KB, patch)
2018-02-12 15:53 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 19959: Update popup window templates to use Bootstrap grid: Label creator (2.79 KB, patch)
2018-03-05 17:42 UTC, Owen Leonard
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Leonard 2018-01-11 18:32:50 UTC
This bug falls under the omnibus Bug 19931, "Update popup window templates to use Bootstrap grid." Updated in this patch will be two label creator templates: result.tt, search.tt.
Comment 1 Owen Leonard 2018-01-11 18:41:24 UTC Comment hidden (obsolete)
Comment 2 Charlotte Cordwell 2018-01-18 20:58:50 UTC Comment hidden (obsolete)
Comment 3 Katrin Fischer 2018-02-04 15:28:28 UTC
Depends on 19709 which is not signed off yet.
Comment 4 Owen Leonard 2018-02-12 15:53:19 UTC
Created attachment 71482 [details] [review]
Bug 19959: Update popup window templates to use Bootstrap grid: Label creator

This patch updates two label creator templates to use the Bootstrap grid
instead of the YUI grid.

To test, apply the patch and go to Label creator -> Manage -> Label
batches.

- Create a new or open an existing label batch.
- Click "Add items."
  - The resulting pop-up window should look correct.
  - Perform a search
    - The search results screen should look correct.

Signed-off-by: Charlotte Cordwell <charlotte.cordwell123@gmail.com>
Comment 5 Owen Leonard 2018-02-12 15:53:42 UTC
Rebased.
Comment 6 Owen Leonard 2018-03-05 17:42:10 UTC
Created attachment 72440 [details] [review]
Bug 19959: Update popup window templates to use Bootstrap grid: Label creator

This patch updates two label creator templates to use the Bootstrap grid
instead of the YUI grid.

To test, apply the patch and go to Label creator -> Manage -> Label
batches.

- Create a new or open an existing label batch.
- Click "Add items."
  - The resulting pop-up window should look correct.
  - Perform a search
    - The search results screen should look correct.

Signed-off-by: Charlotte Cordwell <charlotte.cordwell123@gmail.com>
Comment 7 Owen Leonard 2018-05-11 12:17:04 UTC
When I refactored Bug 19709 I incorporated these changes.

*** This bug has been marked as a duplicate of bug 19709 ***