Bug 19981 - Switch single-column templates to Bootstrap grid: Course reserves
Summary: Switch single-column templates to Bootstrap grid: Course reserves
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Templates (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Owen Leonard
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
: 19848 (view as bug list)
Depends on:
Blocks: 14546 19980 20268
  Show dependency treegraph
 
Reported: 2018-01-16 15:02 UTC by Owen Leonard
Modified: 2018-03-23 14:22 UTC (History)
7 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 19981: Switch single-column templates to Bootstrap grid: Course reserves (4.92 KB, patch)
2018-01-16 15:29 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 19981: Switch single-column templates to Bootstrap grid: Course reserves (8.57 KB, patch)
2018-01-16 16:04 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 19981: Switch single-column templates to Bootstrap grid: Course reserves (8.63 KB, patch)
2018-02-16 10:23 UTC, Claire Gravely
Details | Diff | Splinter Review
Bug 19981: Switch single-column templates to Bootstrap grid: Course reserves (8.72 KB, patch)
2018-02-18 13:47 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Leonard 2018-01-16 15:02:31 UTC
There are three single-column templates in the Course Reserves module which can be updated to use Bootstrap:

course-details.tt
course-reserves.tt
invalid-course.tt
Comment 1 Owen Leonard 2018-01-16 15:29:56 UTC Comment hidden (obsolete)
Comment 2 Owen Leonard 2018-01-16 16:03:46 UTC
Missed:

course.tt
add_items-step1.tt
add_items-step2.tt
Comment 3 Owen Leonard 2018-01-16 16:04:37 UTC
Created attachment 70559 [details] [review]
Bug 19981: Switch single-column templates to Bootstrap grid: Course reserves

This patch updates three single-column course reserves templates to use
the Bootstrap grid:

- course-reserves.tt - The main Course Reserves page
- course-details.tt - The detail view of an individual course
- course.tt - Editing a course
- add_items-step1.tt - Adding items to a course, step 1 (scan barcode)
- add_items-step2.tt - Adding items to a course, step 2
- invalid-course.tt - The error page shown if you try to view
  course_reserves/course-details.pl directly without passing a course id
  in the URL
  - Also changed in this template: Error message has been wrapped in the
    standard "dialog alert" <div>.

Each of these pages should look correct, with a single centered column
with wide margins on either side. At lower browser widths the margins
should disappear.
Comment 4 Owen Leonard 2018-02-07 17:59:58 UTC
*** Bug 19848 has been marked as a duplicate of this bug. ***
Comment 5 Claire Gravely 2018-02-16 10:23:44 UTC
Created attachment 71711 [details] [review]
Bug 19981: Switch single-column templates to Bootstrap grid: Course reserves

This patch updates three single-column course reserves templates to use
the Bootstrap grid:

- course-reserves.tt - The main Course Reserves page
- course-details.tt - The detail view of an individual course
- course.tt - Editing a course
- add_items-step1.tt - Adding items to a course, step 1 (scan barcode)
- add_items-step2.tt - Adding items to a course, step 2
- invalid-course.tt - The error page shown if you try to view
  course_reserves/course-details.pl directly without passing a course id
  in the URL
  - Also changed in this template: Error message has been wrapped in the
    standard "dialog alert" <div>.

Each of these pages should look correct, with a single centered column
with wide margins on either side. At lower browser widths the margins
should disappear.

Signed-off-by: Claire Gravely <claire.gravely@bsz-bw.de>
Comment 6 Katrin Fischer 2018-02-18 13:47:31 UTC
Created attachment 71907 [details] [review]
Bug 19981: Switch single-column templates to Bootstrap grid: Course reserves

This patch updates three single-column course reserves templates to use
the Bootstrap grid:

- course-reserves.tt - The main Course Reserves page
- course-details.tt - The detail view of an individual course
- course.tt - Editing a course
- add_items-step1.tt - Adding items to a course, step 1 (scan barcode)
- add_items-step2.tt - Adding items to a course, step 2
- invalid-course.tt - The error page shown if you try to view
  course_reserves/course-details.pl directly without passing a course id
  in the URL
  - Also changed in this template: Error message has been wrapped in the
    standard "dialog alert" <div>.

Each of these pages should look correct, with a single centered column
with wide margins on either side. At lower browser widths the margins
should disappear.

Signed-off-by: Claire Gravely <claire.gravely@bsz-bw.de>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 7 Jonathan Druart 2018-02-18 19:50:25 UTC
Pushed to master for 18.05, thanks to everybody involved!
Comment 8 Nick Clemens 2018-03-23 00:58:57 UTC
Enhancement, not backported for 17.11