Bug 20268 - CSS regression: white gap on the top of the staff pages
Summary: CSS regression: white gap on the top of the staff pages
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Staff Client (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Owen Leonard
QA Contact: Marcel de Rooy
URL:
Whiteboard:
Keywords:
: 20328 (view as bug list)
Depends on: 7760 19981
Blocks:
  Show dependency treegraph
 
Reported: 2018-02-22 10:11 UTC by Victor Grousset/tuxayo
Modified: 2018-06-04 20:15 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Screenshot of the new white gap on the top of the page. (40.76 KB, image/png)
2018-02-22 10:11 UTC, Victor Grousset/tuxayo
Details
Bug 20268: CSS regression: white gap on the top of the staff pages (2.55 KB, patch)
2018-03-01 15:05 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 20268: CSS regression: white gap on the top of the staff pages (2.61 KB, patch)
2018-03-01 16:02 UTC, Claire Gravely
Details | Diff | Splinter Review
Bug 20268: CSS regression: white gap on the top of the staff pages (2.71 KB, patch)
2018-03-02 07:38 UTC, Marcel de Rooy
Details | Diff | Splinter Review
Bug 20268 (follow-up) Correct template error (1.16 KB, patch)
2018-03-23 13:51 UTC, Owen Leonard
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Victor Grousset/tuxayo 2018-02-22 10:11:56 UTC
Created attachment 72068 [details]
Screenshot of the new white gap on the top of the page.

There is a new white gap on the top of the page, see screenshot.

git bisect allowed to find that this was caused by commit 3eb50270b1a02fe98cde767ad0240b2943e23321

Bug 19981: Switch single-column templates to Bootstrap grid: Course reserves
Comment 1 Fridolin SOMERS 2018-02-26 13:00:27 UTC
Comes from staff-global.css :
.main {	margin-top: 1em; }

main class is on body in intranet-main.tt.
It is usually in :
<div class="main container-fluid">
Comment 2 Victor Grousset/tuxayo 2018-02-27 16:20:50 UTC
@Fridolin: Why does it depends on bug 7760 ?
Comment 3 Owen Leonard 2018-03-01 15:05:22 UTC
Created attachment 72310 [details] [review]
Bug 20268: CSS regression: white gap on the top of the staff pages

This patch makes template and CSS changes so that the staff client main
page doesn't get an unwanted top margin from the Bootstrap-grid
conversion.

- The unused "main" class is removed from the login page
- The "main" class on the staff client home page is changed to
  "intranet-main."
- The CSS for the staff client home page has been modified accordingly.

To test, apply the patch and clear your browser cache if necessary.

- Open the staff client login page. It should look as it always does.
- Log in and check the style of the main page. There should be no white
  margin at the top of the page.
Comment 4 Claire Gravely 2018-03-01 16:02:17 UTC
Created attachment 72339 [details] [review]
Bug 20268: CSS regression: white gap on the top of the staff pages

This patch makes template and CSS changes so that the staff client main
page doesn't get an unwanted top margin from the Bootstrap-grid
conversion.

- The unused "main" class is removed from the login page
- The "main" class on the staff client home page is changed to
  "intranet-main."
- The CSS for the staff client home page has been modified accordingly.

To test, apply the patch and clear your browser cache if necessary.

- Open the staff client login page. It should look as it always does.
- Log in and check the style of the main page. There should be no white
  margin at the top of the page.

Signed-off-by: Claire Gravely <claire.gravely@bsz-bw.de>
Comment 5 Marcel de Rooy 2018-03-02 07:38:27 UTC
Created attachment 72344 [details] [review]
Bug 20268: CSS regression: white gap on the top of the staff pages

This patch makes template and CSS changes so that the staff client main
page doesn't get an unwanted top margin from the Bootstrap-grid
conversion.

- The unused "main" class is removed from the login page
- The "main" class on the staff client home page is changed to
  "intranet-main."
- The CSS for the staff client home page has been modified accordingly.

To test, apply the patch and clear your browser cache if necessary.

- Open the staff client login page. It should look as it always does.
- Log in and check the style of the main page. There should be no white
  margin at the top of the page.

Signed-off-by: Claire Gravely <claire.gravely@bsz-bw.de>

Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl>
Comment 6 Claire Gravely 2018-03-05 07:28:25 UTC
*** Bug 20328 has been marked as a duplicate of this bug. ***
Comment 7 Jonathan Druart 2018-03-19 18:31:22 UTC
Pushed to master for 18.05, thanks to everybody involved!
Comment 8 Jonathan Druart 2018-03-19 18:33:43 UTC
A test is failing, please fix ASAP:
xt/tt_valid.t .. 1/3 
#   Failed test '<body> tag with id and class attributes'
#   at xt/tt_valid.t line 91.
# Files list: 
# intranet-tmpl/prog/en/modules/auth.tt: 15

https://jenkins.koha-community.org/job/Koha_Master_D8/398/
Comment 9 Owen Leonard 2018-03-23 13:51:15 UTC
Created attachment 73180 [details] [review]
Bug 20268 (follow-up) Correct template error

The login template must have a class attribute on the body tag in order
for the template to pass tests.

To test, apply the patch and confirm that the staff client login form
still looks the same. For further confirmation you could update the
IntranetUserCSS system preference with something like this:

.main_main-auth {
    background-color: #CCF;
}

The login form should now have a different background color.
Comment 10 Jonathan Druart 2018-03-23 14:31:08 UTC
(In reply to Owen Leonard from comment #9)
> Created attachment 73180 [details] [review] [review]
> Bug 20268 (follow-up) Correct template error

Pushed to master.