Bug 20003 - Result summary of remaining checkouts items not displaying.
Summary: Result summary of remaining checkouts items not displaying.
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: master
Hardware: All Linux
: P5 - low normal (vote)
Assignee: Josef Moravec
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on: 17466 17829
Blocks:
  Show dependency treegraph
 
Reported: 2018-01-17 09:30 UTC by Anuj Singh
Modified: 2018-06-04 20:15 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Result Summary that need to be show while returning of books. (22.57 KB, image/png)
2018-01-17 09:30 UTC, Anuj Singh
Details
Bug 20003: Fix showing number of remaining checkouts during checking in (1.21 KB, patch)
2018-01-18 08:05 UTC, Josef Moravec
Details | Diff | Splinter Review
Bug 20003: Fix showing number of remaining checkouts during checking in (1.26 KB, patch)
2018-01-19 20:04 UTC, Roch D'Amour
Details | Diff | Splinter Review
Bug 20003: Fix showing number of remaining checkouts during checking in (1.32 KB, patch)
2018-01-26 21:03 UTC, Nick Clemens
Details | Diff | Splinter Review
Bug 20003: QA Followup - use patron checkouts method instead of Koha::Checkouts (1.13 KB, patch)
2018-01-26 21:06 UTC, Nick Clemens
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Anuj Singh 2018-01-17 09:30:46 UTC
Created attachment 70602 [details]
Result Summary that need to be show while returning of books.

On the previous build Koha v17.05, after checking an item, the Check-in items table (patron cell), numbers of remaining items is visible below the patron's name, but now in v17.11 it is not visible even if patron has remaining checkout books.

I am attaching the older screenshot of the result summary marking with red block in the screenshot that is not visible/displaying in the newer build.

Please also help me, if there is an system preferences that need to be changed / modify to view results summary.
Comment 1 Katrin Fischer 2018-01-18 05:50:15 UTC
Adding the bug number of the original patch for adding this feature. I also confirmed it's no longer working.
Comment 2 Josef Moravec 2018-01-18 08:05:45 UTC
Created attachment 70681 [details] [review]
Bug 20003: Fix showing number of remaining checkouts during checking in

Test plan:
0) Do not apply the patch
1) Have a patron with more then one checkout
2) Return one of patron's checkout and confirm the remaining number of
checkout is not shown
3) Apply the patch
4) Try it again and confirm the number is now shown
Comment 3 Jonathan Druart 2018-01-19 13:18:48 UTC
Caused by 
  commit 2b90ea2cb0e5e976de7ddef0151ae83d8ac578e6
    Bug 17829: Move GetMember to Koha::Patron

Due to a bad merge conflict during a rebase (that is exactly why we should not wait for moths to focus on these patches...)

So I guess it impacts master as well.
Comment 4 Roch D'Amour 2018-01-19 20:04:10 UTC
Created attachment 70778 [details] [review]
Bug 20003: Fix showing number of remaining checkouts during checking in

Test plan:
0) Do not apply the patch
1) Have a patron with more then one checkout
2) Return one of patron's checkout and confirm the remaining number of
checkout is not shown
3) Apply the patch
4) Try it again and confirm the number is now shown

Signed-off-by: Roch D'Amour <roch.damour@inlibro.com>
Comment 5 Nick Clemens 2018-01-26 21:03:35 UTC
Created attachment 70981 [details] [review]
Bug 20003: Fix showing number of remaining checkouts during checking in

Test plan:
0) Do not apply the patch
1) Have a patron with more then one checkout
2) Return one of patron's checkout and confirm the remaining number of
checkout is not shown
3) Apply the patch
4) Try it again and confirm the number is now shown

Signed-off-by: Roch D'Amour <roch.damour@inlibro.com>

Signed-off-by: Nick Clemens <nick@bywatersolutions.com>
Comment 6 Nick Clemens 2018-01-26 21:06:39 UTC
Created attachment 70982 [details] [review]
Bug 20003: QA Followup - use patron checkouts method instead of Koha::Checkouts
Comment 7 Nick Clemens 2018-01-26 21:07:25 UTC
Added a possible followup to use the method provided in Patron.pm instead of calling from Koha::Checkouts - feel free to obsolete if other method is preferred
Comment 8 Jonathan Druart 2018-01-30 17:18:11 UTC
Please make sure the " (QA follow-up) " flag is correct
https://wiki.koha-community.org/wiki/Commit_messages#Examples
Comment 9 Jonathan Druart 2018-01-30 17:26:20 UTC
Pushed to master for 18.05, thanks to everybody involved!
Comment 10 Nick Clemens 2018-02-12 20:57:57 UTC
Awesome work all!

This patch has been pushed to 17.11.x and will be in 17.11.03