Bug 20249 - "Patron has no outstanding fines" now appears alongside fines
Summary: "Patron has no outstanding fines" now appears alongside fines
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Templates (show other bugs)
Version: master
Hardware: All All
: P5 - low trivial (vote)
Assignee: Charles Farmer
QA Contact:
URL:
Whiteboard:
Keywords:
: 20233 (view as bug list)
Depends on: 18789
Blocks:
  Show dependency treegraph
 
Reported: 2018-02-19 19:59 UTC by Charles Farmer
Modified: 2018-03-23 01:06 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 20249: "Patron has no outstanding fines" now appears alongside fines (1.41 KB, patch)
2018-02-19 20:08 UTC, Charles Farmer
Details | Diff | Splinter Review
Bug 20249: (bug 18789 follow-up) "Patron has no outstanding fines" now appears alongside fines (1.51 KB, patch)
2018-02-19 20:24 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Charles Farmer 2018-02-19 19:59:21 UTC
I was working on BZ11373 when I fell on this behavior.

It seems like commit 0ab22e1c (BZ18789) introduced a small regression: the [% ELSE %] tag at line 125 of pay.tt disappeared when work was done to replace the 'borrower' object with 'patron'.

I'll provide a patch in a jiffy.
Comment 1 Charles Farmer 2018-02-19 20:08:13 UTC
Created attachment 71972 [details] [review]
Bug 20249: "Patron has no outstanding fines" now appears alongside fines

Test plan:
    1) Choose two patrons from your database, one who has fines, and the other who does not
    2) Visit their 'Fines' page, and click on the 'Pay fines' tab
        2.1) If they don't have any fines, you'll only see a blank row
        2.2) If they do have fines, the payment form will appear, but the text "... no outstanding fines" will also appear
    3) Apply patch
    4) Visit once again the 'Pay fines' tab of your patrons
        4.1) Now, "... no outstanding fines" will appear for the right situation
Comment 2 Jonathan Druart 2018-02-19 20:24:09 UTC
Created attachment 71973 [details] [review]
Bug 20249: (bug 18789 follow-up) "Patron has no outstanding fines" now appears alongside fines

Test plan:
    1) Choose two patrons from your database, one who has fines, and the other who does not
    2) Visit their 'Fines' page, and click on the 'Pay fines' tab
        2.1) If they don't have any fines, you'll only see a blank row
        2.2) If they do have fines, the payment form will appear, but the text "... no outstanding fines" will also appear
    3) Apply patch
    4) Visit once again the 'Pay fines' tab of your patrons
        4.1) Now, "... no outstanding fines" will appear for the right situation

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 3 Jonathan Druart 2018-02-19 20:25:30 UTC
Patch pushed to master for 18.05

Thanks for catching that Charles!
Comment 4 Katrin Fischer 2018-02-23 08:44:57 UTC
*** Bug 20233 has been marked as a duplicate of this bug. ***
Comment 5 Nick Clemens 2018-03-23 01:06:13 UTC
Depends on 18789 which is not in stable