Bug 20284 - ILL: Adding a 'new request' from OPAC fails with template error if text exists in ILLModuleCopyrightClearance
Summary: ILL: Adding a 'new request' from OPAC fails with template error if text exist...
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: ILL (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Andrew Isherwood
QA Contact: Tomás Cohen Arazi
URL:
Whiteboard:
Keywords: rel_17_11_candidate
Depends on: 7317
Blocks: 20548
  Show dependency treegraph
 
Reported: 2018-02-23 12:13 UTC by Jonathan Field
Modified: 2018-10-24 09:13 UTC (History)
8 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug [20284] - [ILL: Adding a 'new request' from ..] (6.24 KB, patch)
2018-04-09 14:01 UTC, Andrew Isherwood
Details | Diff | Splinter Review
Bug 20284: ILLModuleCopyrightClearance text breaks (6.25 KB, patch)
2018-04-13 11:15 UTC, Andrew Isherwood
Details | Diff | Splinter Review
Bug 11674: DBRev 17.12.00.031 (2.93 KB, patch)
2018-04-18 11:33 UTC, Barry Cannon
Details | Diff | Splinter Review
Bug 20284: ILLModuleCopyrightClearance text breaks (6.32 KB, patch)
2018-04-20 08:10 UTC, Marcel de Rooy
Details | Diff | Splinter Review
Bug 20284: (follow-up) Added missing 'exit's (1.26 KB, patch)
2018-04-20 14:18 UTC, Andrew Isherwood
Details | Diff | Splinter Review
Bug 20284: ILLModuleCopyrightClearance text breaks (6.33 KB, patch)
2018-05-04 15:34 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review
Bug 20284: (follow-up) Added missing 'exit's (1.31 KB, patch)
2018-05-04 15:34 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review
Bug 20284: (QA follow-up) superlibrarian has ill permissions (900 bytes, patch)
2018-05-04 15:34 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review
Bug 20284: Fix minor compilation errors (1.40 KB, patch)
2018-05-04 15:34 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Field 2018-02-23 12:13:37 UTC
If text is added to the system preference ILLModuleCopyrightClearance then you are unable to place an ILL request in the OPAC. You get a list of the backends but, upon selecting any of them, you get an internal server error. Error log shows:

Template process failed: file error - : not found at /usr/share/koha/lib/C4/Templates.pm line 122.
Comment 1 Jonathan Druart 2018-02-23 13:44:43 UTC
Upping severity as the feature is broken at the OPAC.
Comment 2 Andrew Isherwood 2018-04-09 14:01:15 UTC
Created attachment 73870 [details] [review]
Bug [20284] - [ILL: Adding a 'new request' from ..]

This patch fixes the display of the copyright notice text that is defined in ILLModuleCopyrightClearance preference when placing ILL requests from the OPAC. Handling of the copyrightclearance stage was missing, this has been added.

Test plan:

- Ensure you have at least one ILL backend available:
  https://wiki.koha-community.org/wiki/ILL_backends
- Ensure you have the "ILLModule" preference enabled
- Add some text to the "ILLModuleCopyrightClearance" preference
- Navigate to a search results page in the catalog
- Click the "Make an Interlibrary Loan request" link at the bottom
- Choose "Create a new request", then select a backend
- TEST: Check the text you added earlier is displayed with buttons for agreeing or disagreeing (prior to this patch, this screen displayed an error)
- TEST: Check that clicking "Yes" takes you to the form for adding request details
- TEST: Check that clicking "No" takes you back to the "Interlibrary loan requests" page
Comment 3 Andrew Isherwood 2018-04-13 11:15:06 UTC
Created attachment 74156 [details] [review]
Bug 20284: ILLModuleCopyrightClearance text breaks

This patch fixes the display of the copyright notice text that is defined
in ILLModuleCopyrightClearance preference when placing ILL requests from
the OPAC. Handling of the copyrightclearance stage was missing,
this has been added.

To test:
1) Ensure you have at least one ILL backend available:
   https://wiki.koha-community.org/wiki/ILL_backends
2) Ensure you have the "ILLModule" preference enabled
3) Add some text to the "ILLModuleCopyrightClearance" preference
4) Navigate to a search results page in the catalog
5) Click the "Make an Interlibrary Loan request" link at the bottom
6) Choose "Create a new request", then select a backend
7) Observe the text you added earlier is displayed with buttons for
   agreeing or disagreeing (prior to this patch, this screen displayed
   an error)
8) Observe that clicking "Yes" takes you to the form for adding request
   details
9) Observe that clicking "No" takes you back to the "Interlibrary loan
   requests" page
Comment 4 Barry Cannon 2018-04-18 11:33:58 UTC
Created attachment 74426 [details] [review]
Bug 11674: DBRev 17.12.00.031

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 5 Barry Cannon 2018-04-18 11:36:34 UTC
ummm, really not sure what happened here. I have signed this patch off but I seem to have contaminated it with a completely different bug. 
Suggestions welcome!
Comment 6 Barry Cannon 2018-04-18 11:37:22 UTC
Signed off as previous comment
Comment 7 Josef Moravec 2018-04-18 12:34:42 UTC
(In reply to Barry Cannon from comment #5)
> ummm, really not sure what happened here. I have signed this patch off but I
> seem to have contaminated it with a completely different bug. 
> Suggestions welcome!

Hi Barry, you just attached the last commit from top of master, not from branch with this patch applied.
Comment 8 Marcel de Rooy 2018-04-20 08:04:08 UTC
(In reply to Barry Cannon from comment #5)
> ummm, really not sure what happened here. I have signed this patch off but I
> seem to have contaminated it with a completely different bug. 
> Suggestions welcome!

Will add your signoff line (for this time ;)
Comment 9 Marcel de Rooy 2018-04-20 08:10:31 UTC
Created attachment 74599 [details] [review]
Bug 20284: ILLModuleCopyrightClearance text breaks

This patch fixes the display of the copyright notice text that is defined
in ILLModuleCopyrightClearance preference when placing ILL requests from
the OPAC. Handling of the copyrightclearance stage was missing,
this has been added.

To test:
1) Ensure you have at least one ILL backend available:
   https://wiki.koha-community.org/wiki/ILL_backends
2) Ensure you have the "ILLModule" preference enabled
3) Add some text to the "ILLModuleCopyrightClearance" preference
4) Navigate to a search results page in the catalog
5) Click the "Make an Interlibrary Loan request" link at the bottom
6) Choose "Create a new request", then select a backend
7) Observe the text you added earlier is displayed with buttons for
   agreeing or disagreeing (prior to this patch, this screen displayed
   an error)
8) Observe that clicking "Yes" takes you to the form for adding request
   details
9) Observe that clicking "No" takes you back to the "Interlibrary loan
   requests" page

Signed-off-by: Barry Cannon <bc@interleaf.ie>
Comment 10 Marcel de Rooy 2018-04-20 08:11:11 UTC
Redirect without exit. See other bug?
Comment 11 Andrew Isherwood 2018-04-20 14:18:36 UTC
Created attachment 74652 [details] [review]
Bug 20284: (follow-up) Added missing 'exit's

This patch adds the exits that were missing after the redirects
Comment 12 Jonathan Druart 2018-04-20 14:25:33 UTC
Skipping SO for the follow-up.
Comment 13 Tomás Cohen Arazi 2018-05-04 15:34:06 UTC
Created attachment 75079 [details] [review]
Bug 20284: ILLModuleCopyrightClearance text breaks

This patch fixes the display of the copyright notice text that is defined
in ILLModuleCopyrightClearance preference when placing ILL requests from
the OPAC. Handling of the copyrightclearance stage was missing,
this has been added.

To test:
1) Ensure you have at least one ILL backend available:
   https://wiki.koha-community.org/wiki/ILL_backends
2) Ensure you have the "ILLModule" preference enabled
3) Add some text to the "ILLModuleCopyrightClearance" preference
4) Navigate to a search results page in the catalog
5) Click the "Make an Interlibrary Loan request" link at the bottom
6) Choose "Create a new request", then select a backend
7) Observe the text you added earlier is displayed with buttons for
   agreeing or disagreeing (prior to this patch, this screen displayed
   an error)
8) Observe that clicking "Yes" takes you to the form for adding request
   details
9) Observe that clicking "No" takes you back to the "Interlibrary loan
   requests" page

Signed-off-by: Barry Cannon <bc@interleaf.ie>
Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>
Comment 14 Tomás Cohen Arazi 2018-05-04 15:34:13 UTC
Created attachment 75080 [details] [review]
Bug 20284: (follow-up) Added missing 'exit's

This patch adds the exits that were missing after the redirects

Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>
Comment 15 Tomás Cohen Arazi 2018-05-04 15:34:20 UTC
Created attachment 75081 [details] [review]
Bug 20284: (QA follow-up) superlibrarian has ill permissions

Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>
Comment 16 Tomás Cohen Arazi 2018-05-04 15:34:29 UTC
Created attachment 75082 [details] [review]
Bug 20284: Fix minor compilation errors

Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>
Comment 17 Jonathan Druart 2018-05-07 15:25:59 UTC
Pushed to master for 18.05, thanks to everybody involved!
Comment 18 M. Tompsett 2018-05-08 13:29:10 UTC
*** Bug 20646 has been marked as a duplicate of this bug. ***