Bug 20437 - Force requirement for HTTP::OAI 3.27
Summary: Force requirement for HTTP::OAI 3.27
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Packaging (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Tomás Cohen Arazi
QA Contact: Marcel de Rooy
URL:
Whiteboard:
Keywords: dependency
Depends on:
Blocks: 20800
  Show dependency treegraph
 
Reported: 2018-03-16 17:56 UTC by Tomás Cohen Arazi
Modified: 2018-09-11 14:42 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 20437: Force the dependency on HTTP::OAI < 4.0 (1.35 KB, patch)
2018-03-16 18:23 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review
[ALTERNATIVE] Bug 20437: Add HTTP::OAI@3.27 to the source tree (115.81 KB, patch)
2018-03-20 14:22 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review
Bug 20437: Force the dependency on HTTP::OAI < 4.0 (1.44 KB, patch)
2018-03-23 06:56 UTC, Marcel de Rooy
Details | Diff | Splinter Review
Bug 20437: Force the dependency on HTTP::OAI < 4.0 (1.46 KB, patch)
2018-05-15 17:26 UTC, Mirko Tietgen
Details | Diff | Splinter Review
Bug 20437: Update debian/control (1.02 KB, patch)
2018-05-15 17:26 UTC, Mirko Tietgen
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Tomás Cohen Arazi 2018-03-16 17:56:28 UTC
Until HTTP::OAI is patched so it actually works, and bug 17704 fixes the API change Koha-side, we need to explicitly pull the right version. Otherwise people using Debian 9+ derived distros (Ubuntu 16.04+) are seeing production issues.

This implies packaging our custom libhttp-oai-perl distribution in the meantime.
Comment 1 Tomás Cohen Arazi 2018-03-16 18:23:42 UTC
Created attachment 73059 [details] [review]
Bug 20437: Force the dependency on HTTP::OAI < 4.0

Until HTTP::OAI is patched so it actually works, and bug 17704 fixes the API change Koha-side, we need to explicitly pull the right version. Otherwise people using Debian 9+ derived distros (Ubuntu 16.04+) are seeing production issues.

This implies packaging our custom libhttp-oai-perl distribution in the meantime.

This patch makes Koha require a version lower than 4.0.

Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>
Comment 2 Tomás Cohen Arazi 2018-03-20 14:22:33 UTC
Created attachment 73105 [details] [review]
[ALTERNATIVE] Bug 20437: Add HTTP::OAI@3.27 to the source tree
Comment 3 Marcel de Rooy 2018-03-23 06:53:38 UTC
(In reply to Tomás Cohen Arazi from comment #2)
> Created attachment 73105 [details] [review] [review]
> [ALTERNATIVE] Bug 20437: Add HTTP::OAI@3.27 to the source tree

We never did it like that ? Not my preference..
Comment 4 Marcel de Rooy 2018-03-23 06:56:05 UTC
Created attachment 73160 [details] [review]
Bug 20437: Force the dependency on HTTP::OAI < 4.0

Until HTTP::OAI is patched so it actually works, and bug 17704 fixes the API change Koha-side, we need to explicitly pull the right version. Otherwise people using Debian 9+ derived distros (Ubuntu 16.04+) are seeing production issues.

This implies packaging our custom libhttp-oai-perl distribution in the meantime.

This patch makes Koha require a version lower than 4.0.

Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>

Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl>
Comment 5 Jonathan Druart 2018-03-27 16:51:17 UTC
I cannot push this patch as it, we need to prove libhttp-oai-perl v3.27
To do that it needs to be tested on debian 9 to make sure dependencies are not broken if another is installed.

Marked as Blocked until someone tests.
Comment 6 Mirko Tietgen 2018-03-29 08:16:04 UTC
Tomás: I think you said you are in contact with the maintainer and the patch that fixes the problem is already in the repo. Do you know when 4.07 is planned? It would be the easiest/best way to solve this problem.
Comment 7 Jonathan Druart 2018-05-15 12:48:12 UTC
http://lists.koha-community.org/pipermail/koha-devel/2018-May/044551.html

Mirko, will you be ready for this one before 18.05 is released?
Comment 8 Mirko Tietgen 2018-05-15 14:56:20 UTC
Working on this.
Comment 9 Mirko Tietgen 2018-05-15 17:19:00 UTC
I have added libhttp-oai-perl 3.27~koha1-1 to the unstable repository.

I rolled a package with Tomás' patch, did a subsequent regeneration of debian/control and installed in a stretch VM. I had to manually tweak things to get 3.27 installed because the RC1 in the unstable repo interfered.

Patch works as intended (needs update of control file). I did not encounter any dependency issues with the back- and forthport of libhttp-oai-perl 3.27 in Stretch.

If a system already has libhttp-oai-perl 4.x installed, it will break things but give a clear message about the problem.

If there is software installed on a system that needs 4.x, it is incompatible to Koha until 4.07 is released and packaged. This is expected and we can't do anything about it.

3.27~koha1 is in the unstable repository and can be copied to stable and oldstable any time.
Comment 10 Mirko Tietgen 2018-05-15 17:26:16 UTC
Created attachment 75340 [details] [review]
Bug 20437: Force the dependency on HTTP::OAI < 4.0

Until HTTP::OAI is patched so it actually works, and bug 17704 fixes the API change Koha-side, we need to explicitly pull the right version. Otherwise people using Debian 9+ derived distros (Ubuntu 16.04+) are seeing production issues.

This implies packaging our custom libhttp-oai-perl distribution in the meantime.

This patch makes Koha require a version lower than 4.0.

Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>

Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl>
Signed-off-by: Mirko Tietgen <mirko@abunchofthings.net>
Comment 11 Mirko Tietgen 2018-05-15 17:26:29 UTC
Created attachment 75341 [details] [review]
Bug 20437: Update debian/control

Signed-off-by: Mirko Tietgen <mirko@abunchofthings.net>
Comment 12 Jonathan Druart 2018-05-15 18:04:17 UTC
Pushed to master for 18.05, thanks to everybody involved!
Comment 13 Fridolin SOMERS 2018-09-11 14:42:24 UTC
Pushed to 17.11.x for 17.11.10