Bug 20800 - Keep Koha on Stretch from using broken libhttp-oai-perl
Summary: Keep Koha on Stretch from using broken libhttp-oai-perl
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Packaging (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Mirko Tietgen
QA Contact: Tomás Cohen Arazi
URL:
Whiteboard:
Keywords:
Depends on: 20437
Blocks:
  Show dependency treegraph
 
Reported: 2018-05-22 11:23 UTC by Mirko Tietgen
Modified: 2018-09-11 14:46 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 20800: Keep Koha on Stretch from using broken libhttp-oai-perl (2.22 KB, patch)
2018-05-22 11:26 UTC, Mirko Tietgen
Details | Diff | Splinter Review
Bug 20800: Keep Koha on Stretch from using broken libhttp-oai-perl (2.28 KB, patch)
2018-05-22 13:19 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review
Bug 20800: Keep Koha on Stretch from using broken libhttp-oai-perl (2.33 KB, patch)
2018-05-22 14:11 UTC, M. Tompsett
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Mirko Tietgen 2018-05-22 11:23:25 UTC
libhttp-oai-perl in Stretch is 4.03 and broken. Koha depends on libhttp-oai-perl << 4 for that reason. To make the installation of Koha on Stretch as easy as possible, this patch adds the alternative libhttp-oai-3.27-perl which we provide in the Koha repository.
Comment 1 Mirko Tietgen 2018-05-22 11:26:32 UTC
Created attachment 75463 [details] [review]
Bug 20800: Keep Koha on Stretch from using broken libhttp-oai-perl

libhttp-oai-perl in Stretch is 4.03 and broken. Koha depends on
libhttp-oai-perl << 4 for that reason. To make the installation of Koha
on Stretch as easy as possible, this patch adds the alternative
libhttp-oai-3.27-perl which we provide in the Koha repository.
Comment 2 Tomás Cohen Arazi 2018-05-22 13:19:49 UTC
Created attachment 75466 [details] [review]
Bug 20800: Keep Koha on Stretch from using broken libhttp-oai-perl

libhttp-oai-perl in Stretch is 4.03 and broken. Koha depends on
libhttp-oai-perl << 4 for that reason. To make the installation of Koha
on Stretch as easy as possible, this patch adds the alternative
libhttp-oai-3.27-perl which we provide in the Koha repository.

Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>
Comment 3 M. Tompsett 2018-05-22 14:11:37 UTC
Created attachment 75469 [details] [review]
Bug 20800: Keep Koha on Stretch from using broken libhttp-oai-perl

libhttp-oai-perl in Stretch is 4.03 and broken. Koha depends on
libhttp-oai-perl << 4 for that reason. To make the installation of Koha
on Stretch as easy as possible, this patch adds the alternative
libhttp-oai-3.27-perl which we provide in the Koha repository.

Signed-off-by: Mark Tompsett <mtompset@hotmail.com>

Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>
Comment 4 Jonathan Druart 2018-05-22 14:24:03 UTC
Pushed to master for 18.05
Comment 5 Narcis Garcia 2018-07-27 07:08:42 UTC
If depending ONLY on libhttp-oai-3.27-perl for Debian 9 is not possible, then take into account that the order of specified dependencies in package matters:

Instead of*:
libhttp-oai-perl (>= 3.2) | libhttp-oai-3.27-perl, libhttp-oai-perl (<
4.0) | libhttp-oai-3.27-perl

These dependencies should be written as:
libhttp-oai3-koha (< 4.0) | libhttp-oai-3.27-perl

And a "libhttp-oai3-koha" metapackage with dependencies:
libhttp-oai-perl (>= 3.2), libhttp-oai-perl (< 4.0)

+ In the meanwhile, a bug to Debian Perl Group for libhttp-oai-perl
package could be filed.

(*) The problem is that first case matches with libhttp-oai-perl=4.03 and dependency is satisfied with this proken package.
Comment 6 Fridolin SOMERS 2018-09-11 14:46:38 UTC
Pushed to 17.11.x for 17.11.10

@Narcis Garcia please open a new bug report for your comment 5