Bug 20720 - Add libraries (sponsors) to the about page
Summary: Add libraries (sponsors) to the about page
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: About (show other bugs)
Version: unspecified
Hardware: All All
: P5 - low minor (vote)
Target Milestone: ---
Assignee: Martin Renvoize
QA Contact: Testopia
URL:
Whiteboard:
Keywords: Academy
: 20610 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-05-07 15:45 UTC by Jonathan Druart
Modified: 2018-11-28 12:55 UTC (History)
9 users (show)

See Also:
Change sponsored?: ---
Patch complexity: String patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 20720: Using git Sponsored-by lines to update 'about' (4.77 KB, patch)
2018-10-19 16:19 UTC, Martin Renvoize
Details | Diff | Splinter Review
Bug 20720: Using git Sponsored-by lines to update 'about' (4.92 KB, patch)
2018-10-19 16:21 UTC, Martin Renvoize
Details | Diff | Splinter Review
Bug 20720: Using git Sponsored-by lines to update 'about' (4.92 KB, patch)
2018-10-19 18:30 UTC, Martin Renvoize
Details | Diff | Splinter Review
Bug 20720: Using git Sponsored-by lines to update 'about' (4.99 KB, patch)
2018-10-19 18:58 UTC, Caroline Cyr La Rose
Details | Diff | Splinter Review
Bug 20720: Using git Sponsored-by lines to update 'about' (4.97 KB, patch)
2018-10-19 18:59 UTC, Michal Denar
Details | Diff | Splinter Review
Bug 20720: Found some more sponsors to add to 'about' (3.59 KB, patch)
2018-10-20 12:51 UTC, Martin Renvoize
Details | Diff | Splinter Review
Bug 20720: Using git Sponsored-by lines to update 'about' (5.02 KB, patch)
2018-10-20 19:42 UTC, Michal Denar
Details | Diff | Splinter Review
Bug 20720: Found some more sponsors to add to 'about' (3.68 KB, patch)
2018-10-20 19:43 UTC, Michal Denar
Details | Diff | Splinter Review
Bug 20720: Using git Sponsored-by lines to update 'about' (5.03 KB, patch)
2018-10-28 11:35 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 20720: Found some more sponsors to add to 'about' (3.69 KB, patch)
2018-10-28 11:35 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 20720: (QA follow-up) Some minor corrections (2.65 KB, patch)
2018-10-28 11:35 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Druart 2018-05-07 15:45:29 UTC
It would make sense to list the libraries sponsoring Koha developments on the about page.
Comment 1 Jonathan Druart 2018-05-07 15:46:54 UTC
Should we add a new tab or list them at the bottom of "Koha team"?
Comment 2 Jonathan Druart 2018-05-07 15:49:29 UTC
Using the git log (`git log|grep "Sponsored-by"|sort -n | uniq`), I have this list:

Alingsås Public Library, Sweden
American Numismatic Society
Arcadia Public Library
Athens County Public Libraries
BdP de la Meuse
Briar Cliff University
Brooklyn Law School Library
BULAC - http://www.bulac.fr/
California College of the Arts
Camden County
Carnegie Stout Library
CCSR ( http://www.ccsr.qc.ca )
Central Kansas Library System (CKLS), Plum Creek Library System and Washoe County Library System
Cheshire Libraries
Corpus Christi Public Libraries
Dover
FIT
Goethe-Institut
Halland county library
Hochschule für Gesundheit (hsg), Germany
Hotchkiss School
KEEP SOLUTIONS
Kultur i Halland - Regionbibliotek
Library of the Józef Piłsudski Institute of America
Los Gatos Public Library and Harrison Carmel Public Library
North Central Regional Library (NCRL)
Northeast Kansas Library System (NEKLS)
Oslo Public Library
Regionbibliotek Halland / County library of Halland
Region Halland
Rolling Hills Consolidated Libraries
South-East Kansas Library System
Sunday TV is boring
SWITCH Library Consortium
Talking Tech
Universidad de El Salvador
Universidad Empresarial Siglo 21
Universidad Nacional de Córdoba
Université d'Aix-Marseille
Université de Lyon 3
Université de Rennes 2
Université de St Etienne
University of the Arts London
Vaara-kirjastot
Vanier college
Ville de Victoriaville, QC
VOKAL
Washoe County Library System

Duplicate and support companies have been removed manually.

We could also split the list by release (and so a library could appear several times)?
Comment 3 Owen Leonard 2018-05-07 16:11:58 UTC
I think adding a new tab would make sense. I think doing the list by release would get cumbersome, so my vote is for a simple alphabetical list.
Comment 4 Liz Rea 2018-05-07 21:10:18 UTC
Simple list, all time library sponsors/contributors.
Comment 5 Katrin Fischer 2018-05-07 21:57:10 UTC
(In reply to Owen Leonard from comment #3)
> I think adding a new tab would make sense. I think doing the list by release
> would get cumbersome, so my vote is for a simple alphabetical list.

+1
Comment 6 Nick Clemens 2018-05-09 14:12:44 UTC
+1
Comment 7 Tomás Cohen Arazi 2018-05-14 13:32:43 UTC
I would love to get rid of the single big list, and have per-release pages. I imagine a slider to jump from current, to previous release teams and contributors. I wanted that for 3.22 but didn't manage to do it in time.
Comment 8 Martin Renvoize 2018-10-19 15:31:37 UTC
I wonder how this relates to bug 21317. In that bug we cleared up the formatting a little.. perhaps this bug is more about updating the list to get it current?
Comment 9 Martin Renvoize 2018-10-19 16:19:15 UTC
Created attachment 80945 [details] [review]
Bug 20720: Using git Sponsored-by lines to update 'about'
Comment 10 Martin Renvoize 2018-10-19 16:21:18 UTC
Created attachment 80946 [details] [review]
Bug 20720: Using git Sponsored-by lines to update 'about'
Comment 11 Caroline Cyr La Rose 2018-10-19 17:41:16 UTC
Very minor: after Los Gatos Public Library (love the name btw), there is a bullet with nothing.
Comment 12 Martin Renvoize 2018-10-19 18:30:32 UTC
Created attachment 80950 [details] [review]
Bug 20720: Using git Sponsored-by lines to update 'about'
Comment 13 Martin Renvoize 2018-10-19 18:31:51 UTC
Ooops, corrected now, thanks.
Comment 14 Caroline Cyr La Rose 2018-10-19 18:58:27 UTC
Created attachment 80951 [details] [review]
Bug 20720: Using git Sponsored-by lines to update 'about'

Signed-off-by: Caroline Cyr La Rose <caroline.cyr-la-rose@inlibro.com>
Comment 15 Michal Denar 2018-10-19 18:59:44 UTC
Created attachment 80952 [details] [review]
Bug 20720: Using git Sponsored-by lines to update 'about'

Signed-off-by: Michal Denar <black23@gmail.com>
Comment 16 Martin Renvoize 2018-10-20 12:51:52 UTC
Created attachment 80961 [details] [review]
Bug 20720: Found some more sponsors to add to 'about'

git log|grep -i "sponsored-by"|sort -n | uniq
git log|grep -i "sponsored by"|sort -n | uniq
Comment 17 Martin Renvoize 2018-10-20 12:59:54 UTC
Found a few more so added a followup.
Comment 18 Michal Denar 2018-10-20 19:42:58 UTC
Created attachment 80962 [details] [review]
Bug 20720: Using git Sponsored-by lines to update 'about'

Signed-off-by: Michal Denar <black23@gmail.com>
Comment 19 Michal Denar 2018-10-20 19:43:03 UTC
Created attachment 80963 [details] [review]
Bug 20720: Found some more sponsors to add to 'about'

git log|grep -i "sponsored-by"|sort -n | uniq
git log|grep -i "sponsored by"|sort -n | uniq

Signed-off-by: Michal Denar <black23@gmail.com>

Signed-off-by: Michal Denar <black23@gmail.com>
Comment 20 Jonathan Druart 2018-10-22 17:55:39 UTC
Should not we split by Koha version? And add the number of enhancements they sponsored?
Comment 21 Jonathan Druart 2018-10-22 17:56:29 UTC
(In reply to Jonathan Druart from comment #20)
> Should not we split by Koha version?

Oops sorry, this has been discussed already!
Comment 22 Martin Renvoize 2018-10-24 09:35:01 UTC
As it happens, I'm keen to automate this as part of the release process and then add enhancements on top of that automation.

My initial plan is to convert the process from 'add lines to the template directly' to 'build a developers.yaml and sponsors.yaml' as release time and use in the template instead.

This was just intended as a quick 'get us up to date' patch whilst I work on a more joined up procedure.
Comment 23 Katrin Fischer 2018-10-28 11:35:31 UTC
Created attachment 81391 [details] [review]
Bug 20720: Using git Sponsored-by lines to update 'about'

Signed-off-by: Michal Denar <black23@gmail.com>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 24 Katrin Fischer 2018-10-28 11:35:36 UTC
Created attachment 81392 [details] [review]
Bug 20720: Found some more sponsors to add to 'about'

git log|grep -i "sponsored-by"|sort -n | uniq
git log|grep -i "sponsored by"|sort -n | uniq

Signed-off-by: Michal Denar <black23@gmail.com>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 25 Katrin Fischer 2018-10-28 11:35:41 UTC
Created attachment 81393 [details] [review]
Bug 20720: (QA follow-up) Some minor corrections

Made some corrections to countries, spelling and
changed OPUS entry.
Comment 26 Katrin Fischer 2018-10-28 11:38:23 UTC
About OPUS: I changed it back to be only the abbreviation as the full name was not the correct one. The one that was listed refers to a digital repository software that is developed and widely used in Germany. It shows up a lot in combination with Koha in searches, as a lot of presentations, thesis and other publications on Koha are published in OPUS based systems.
Comment 27 Katrin Fischer 2018-10-28 11:39:23 UTC
I think this might be a good candidate - Chris C. might be able to confirm:
http://katipo.co.nz/portfolio/libraries/54-opus.html
Comment 28 Katrin Fischer 2018-10-28 11:40:05 UTC
*** Bug 20610 has been marked as a duplicate of this bug. ***
Comment 29 Martin Renvoize 2018-10-28 12:24:32 UTC
Thanks for the fixes Katrin 😁
Comment 30 Nick Clemens 2018-10-29 01:20:31 UTC
Awesome work all!

Pushed to master for 18.11
Comment 31 Martin Renvoize 2018-11-08 15:59:35 UTC
I chose to backport this to give contributing institution their dues.  Pushed to 18.05.x for 18.05.06
Comment 32 Fridolin SOMERS 2018-11-28 12:55:21 UTC
Pushed to 17.11.x for 17.11.13

Viva our sponsors :D