Bug 20883 - Display patron user id
Summary: Display patron user id
Status: RESOLVED DUPLICATE of bug 21063
Alias: None
Product: Koha
Classification: Unclassified
Component: ILL (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Andrew Isherwood
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on: 7317
Blocks:
  Show dependency treegraph
 
Reported: 2018-06-05 13:49 UTC by Andrew Isherwood
Modified: 2018-10-19 09:48 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 20883: Add patron userid to display (4.80 KB, patch)
2018-06-05 14:04 UTC, Andrew Isherwood
Details | Diff | Splinter Review
Bug 20883: (follow-up) Fix column indexes (1.15 KB, patch)
2018-06-05 14:23 UTC, Andrew Isherwood
Details | Diff | Splinter Review
Bug 20883: Add patron userid to display (5.21 KB, patch)
2018-10-15 15:32 UTC, M. Tompsett
Details | Diff | Splinter Review
Bug 20883: Add patron userid to display (5.22 KB, patch)
2018-10-15 15:34 UTC, M. Tompsett
Details | Diff | Splinter Review
Bug 20883: Add patron userid to display (5.33 KB, patch)
2018-10-15 15:37 UTC, M. Tompsett
Details | Diff | Splinter Review
Bug 20883: Add patron userid to display (5.39 KB, patch)
2018-10-15 16:13 UTC, M. Tompsett
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Isherwood 2018-06-05 13:49:02 UTC
Currently, when displaying a list of ILL requests, or viewing a single request, the requester's userid is not displayed. This should be visible.
Comment 1 Andrew Isherwood 2018-06-05 14:04:23 UTC
Created attachment 75817 [details] [review]
Bug 20883: Add patron userid to display

This patch adds the display of patron userid to both the "illlist" and
"illview" pages.

Test plan (see bug 7317 for ILL deployment details):
1) Ensure you have at least one ILL request
2) Go to the main "List requests" page by clicking "ILL requests" from
the main staff interface
   TEST => Observe that you see a "Patron username" column the the
   table, containing the patron's correct userid
3) Click "Manage request" on a request
   TEST => Observe that, in the "Patron" row, you see the patron's
   correct userid in brackets (along with their name and barcode)
Comment 2 Andrew Isherwood 2018-06-05 14:23:58 UTC
Created attachment 75821 [details] [review]
Bug 20883: (follow-up) Fix column indexes
Comment 3 M. Tompsett 2018-10-15 15:32:50 UTC
Created attachment 80609 [details] [review]
Bug 20883: Add patron userid to display

This patch adds the display of patron userid to both the "illlist" and
"illview" pages.

Test plan (see bug 7317 for ILL deployment details):
1) Ensure you have at least one ILL request
2) Go to the main "List requests" page by clicking "ILL requests" from
the main staff interface
   TEST => Observe that you see a "Patron username" column the the
   table, containing the patron's correct userid
3) Click "Manage request" on a request
   TEST => Observe that, in the "Patron" row, you see the patron's
   correct userid in brackets (along with their name and barcode)
Comment 4 M. Tompsett 2018-10-15 15:34:53 UTC
Created attachment 80610 [details] [review]
Bug 20883: Add patron userid to display

This patch adds the display of patron userid to both the "illlist" and
"illview" pages.

Test plan (see bug 7317 for ILL deployment details):
1) Ensure you have at least one ILL request
2) Go to the main "List requests" page by clicking "ILL requests" from
the main staff interface
   TEST => Observe that you see a "Patron username" column the the
   table, containing the patron's correct userid
3) Click "Manage request" on a request
   TEST => Observe that, in the "Patron" row, you see the patron's
   correct userid in brackets (along with their name and barcode)
Comment 5 M. Tompsett 2018-10-15 15:37:31 UTC
Created attachment 80611 [details] [review]
Bug 20883: Add patron userid to display

This patch adds the display of patron userid to both the "illlist" and
"illview" pages.

Test plan (see bug 7317 for ILL deployment details):
1) Ensure you have at least one ILL request
2) Go to the main "List requests" page by clicking "ILL requests" from
the main staff interface
   TEST => Observe that you see a "Patron username" column the the
   table, containing the patron's correct userid
3) Click "Manage request" on a request
   TEST => Observe that, in the "Patron" row, you see the patron's
   correct userid in brackets (along with their name and barcode)
Comment 6 M. Tompsett 2018-10-15 15:40:44 UTC
Hopefully this is recovered from a non-existent "Patch Does Not Apply" state, because I didn't want to leave it there. :)
Comment 7 M. Tompsett 2018-10-15 16:13:05 UTC
Created attachment 80614 [details] [review]
Bug 20883: Add patron userid to display

This patch adds the display of patron userid to both the "illlist" and
"illview" pages.

Test plan (see bug 7317 for ILL deployment details):
1) Ensure you have at least one ILL request
2) Go to the main "List requests" page by clicking "ILL requests" from
the main staff interface
   TEST => Observe that you see a "Patron username" column the the
   table, containing the patron's correct userid
3) Click "Manage request" on a request
   TEST => Observe that, in the "Patron" row, you see the patron's
   correct userid in brackets (along with their name and barcode)

Signed-off-by: Mark Tompsett <mtompset@hotmail.com>
Comment 8 Jonathan Druart 2018-10-16 18:08:52 UTC
(In reply to Andrew Isherwood from comment #0)
> Currently, when displaying a list of ILL requests, or viewing a single
> request, the requester's userid is not displayed. This should be visible.

Why? :)
We usually do not display the username anywhere AFAIK.
Here you are adding a new column, maybe it could fit into the same column as the firstname and surname?

On the detail view we have:
  Patron: firstname surname [42] [username]

Not sure the [] are good for visibility and tell what we are displaying.

I am just asking :)
Comment 9 Andrew Isherwood 2018-10-17 09:38:12 UTC
It's a good question and I'm not 100% sure of the answer. We definitely had a request from a customer at some point to add the username as it would enable them then to filter by it. We do have another bug 21063 which enables the user to select the columns that are displayed, though username is not currently one of the columns that can be selected.

So, maybe, rather than this bug which hardcodes this into the UI, we need an another enhancement bug, which is dependent on 20163, which adds username into the list of columns available for selection.
Comment 10 Martin Renvoize 2018-10-17 13:08:54 UTC
That gets a +1 from me.. perhaps mark this one as a duplicate and add the configurable column to that other bug :)
Comment 11 Jonathan Druart 2018-10-17 14:39:58 UTC
I was not aware of bug 21063. This should definitely be built on top of it.

Re-assigning to you Andrew as more work is needed.
Comment 12 Andrew Isherwood 2018-10-18 13:38:33 UTC

*** This bug has been marked as a duplicate of bug 21063 ***