Bug 21209 - When trying to edit housebound roles, the edit button goes to patron attributes
Summary: When trying to edit housebound roles, the edit button goes to patron attributes
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Patrons (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Keywords:
Depends on: 20779 20828
Blocks:
  Show dependency treegraph
 
Reported: 2018-08-10 21:11 UTC by Caroline Cyr La Rose
Modified: 2019-10-14 19:56 UTC (History)
7 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 21209: (bug 20828 follow-up) Step 4 of moremember is used for Housebound and additional attributes (1.88 KB, patch)
2018-08-13 18:07 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 21209: (bug 20828 follow-up) Step 4 of moremember is used for Housebound and additional attributes (1.89 KB, patch)
2018-08-22 01:09 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 21209: (bug 20828 follow-up) Step 4 of moremember is used for Housebound and additional attributes (1.94 KB, patch)
2018-08-22 05:51 UTC, Claire Gravely
Details | Diff | Splinter Review
Bug 21209: (bug 20828 follow-up) Step 4 of moremember is used for Housebound and additional attributes (2.00 KB, patch)
2018-08-24 06:05 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Caroline Cyr La Rose 2018-08-10 21:11:53 UTC
Once the patron has defined housebound roles, the edit button goes to the patron attributes page.

To reproduce :

1) Make sure the HouseboundModule is enabled in system preferences
2) Go to a patron file
3) Next to Housebound roles, click on "Add"
4) Check "Yes" next to one of the two roles (or both)
5) Click "Save"
6) The "Add" button is now "Edit", click on it

The page is the one to edit patron attributes and not housebound roles.
Comment 1 Jonathan Druart 2018-08-13 18:07:59 UTC
Created attachment 77763 [details] [review]
Bug 21209: (bug 20828 follow-up) Step 4 of moremember is used for Housebound and additional attributes

Test plan:

1) Make sure the HouseboundModule is enabled in system preferences
2) Go to a patron file
3) Next to Housebound roles, click on "Add"
4) Check "Yes" next to one of the two roles (or both)
5) Click "Save"
6) The "Add" button is now "Edit", click on it

The page is the one to edit housebound roles.
Comment 2 Claire Gravely 2018-08-21 09:00:23 UTC
patch does not apply 
Auto-merging koha-tmpl/intranet-tmpl/prog/en/modules/members/moremember.tt
CONFLICT (content): Merge conflict in koha-tmpl/intranet-tmpl/prog/en/modules/members/moremember.tt
Failed to merge in the changes.
Patch failed at 0001 Bug 21209: (bug 20828 follow-up) Step 4 of moremember is used for Housebound and additional attributes
Comment 3 Jonathan Druart 2018-08-22 01:09:49 UTC
Created attachment 78083 [details] [review]
Bug 21209: (bug 20828 follow-up) Step 4 of moremember is used for Housebound and additional attributes

Test plan:

1) Make sure the HouseboundModule is enabled in system preferences
2) Go to a patron file
3) Next to Housebound roles, click on "Add"
4) Check "Yes" next to one of the two roles (or both)
5) Click "Save"
6) The "Add" button is now "Edit", click on it

The page is the one to edit housebound roles.
Comment 4 Claire Gravely 2018-08-22 05:51:04 UTC
Created attachment 78084 [details] [review]
Bug 21209: (bug 20828 follow-up) Step 4 of moremember is used for Housebound and additional attributes

Test plan:

1) Make sure the HouseboundModule is enabled in system preferences
2) Go to a patron file
3) Next to Housebound roles, click on "Add"
4) Check "Yes" next to one of the two roles (or both)
5) Click "Save"
6) The "Add" button is now "Edit", click on it

The page is the one to edit housebound roles.

Signed-off-by: Claire Gravely <claire.gravely@bsz-bw.de>
Comment 5 Katrin Fischer 2018-08-24 06:05:44 UTC
Created attachment 78105 [details] [review]
Bug 21209: (bug 20828 follow-up) Step 4 of moremember is used for Housebound and additional attributes

Test plan:

1) Make sure the HouseboundModule is enabled in system preferences
2) Go to a patron file
3) Next to Housebound roles, click on "Add"
4) Check "Yes" next to one of the two roles (or both)
5) Click "Save"
6) The "Add" button is now "Edit", click on it

The page is the one to edit housebound roles.

Signed-off-by: Claire Gravely <claire.gravely@bsz-bw.de>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 6 Nick Clemens 2018-08-24 16:32:16 UTC
Awesome work all!

Pushed to master for 18.11
Comment 7 Martin Renvoize 2018-09-04 15:15:54 UTC
Caused by bug 20779 not in 18.05.x series, marking resolved fixed.