Bug 21481 - Translation tool still references to help templates
Summary: Translation tool still references to help templates
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Architecture, internals, and plumbing (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Josef Moravec
QA Contact: Julian Maurice
URL: https://gitlab.com/josef.moravec/Koha...
Keywords:
: 21483 (view as bug list)
Depends on: 19817
Blocks:
  Show dependency treegraph
 
Reported: 2018-10-03 10:16 UTC by Josef Moravec
Modified: 2019-10-14 19:57 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 21481: Remove references to help from LangInstaller (5.19 KB, patch)
2018-10-03 10:53 UTC, Josef Moravec
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Josef Moravec 2018-10-03 10:16:16 UTC
As of bug 19817 is pushed, our translation toolkit should not reference to help templates - they dosn't exist anymore.
Comment 1 Josef Moravec 2018-10-03 10:16:35 UTC
Patches are coming
Comment 2 Josef Moravec 2018-10-03 10:53:50 UTC
Created attachment 79863 [details] [review]
Bug 21481: Remove references to help from LangInstaller

Test plan:
1) Aply the patches
2) cd misc/translator
3) Run these command one by one:
    ./translate install <lang-code>
    ./translate update <lang-code>
    ./translate create <lang-code>
4) All should not end with error and must do what is documented (see
    ./translate --help)
Comment 3 Josef Moravec 2018-10-03 11:04:12 UTC
Patches are on this branch:
https://gitlab.com/josef.moravec/Koha/tree/bug21481

Test plan is:
1) cd misc/translator
2) Run these command one by one:
    ./translate install <lang-code>
    ./translate update <lang-code>
    ./translate create <lang-code>
3) All should not end with error and must do what is documented (see
    ./translate --help)
Comment 4 Owen Leonard 2018-10-04 17:10:11 UTC
I followed the test plan and each step was successful. I hereby grant this bug the title "Signed off."
Comment 5 Josef Moravec 2018-10-05 05:27:39 UTC
(In reply to Owen Leonard from comment #4)
> I followed the test plan and each step was successful. I hereby grant this
> bug the title "Signed off."

Thanks Owen
Comment 6 Josef Moravec 2018-10-05 07:21:38 UTC
(In reply to Josef Moravec from comment #5)
> (In reply to Owen Leonard from comment #4)
> > I followed the test plan and each step was successful. I hereby grant this
> > bug the title "Signed off."
> 
> Thanks Owen

I added your signed-off line to remote branch
Comment 7 Julian Maurice 2018-10-05 12:31:32 UTC
Passed QA

Patches are here: https://gitlab.com/jajm/Koha/commits/bug21481 

with an additional follow-up: https://gitlab.com/jajm/Koha/commit/34cf20df7e1ac99f4efd46469b1b0852a8735ca1
Comment 8 Julian Maurice 2018-10-05 12:33:34 UTC
*** Bug 21483 has been marked as a duplicate of this bug. ***
Comment 9 Nick Clemens 2018-10-05 16:25:39 UTC
Awesome work all!

Pushed to master for 18.11
Comment 10 Martin Renvoize 2018-10-08 09:01:32 UTC
Caused by 19817 not in 18.05.x series.