Bug 21483 - Translate script displays an error about missing "help" directory
Summary: Translate script displays an error about missing "help" directory
Status: RESOLVED DUPLICATE of bug 21481
Alias: None
Product: Koha
Classification: Unclassified
Component: Architecture, internals, and plumbing (show other bugs)
Version: unspecified
Hardware: All All
: P5 - low normal (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Keywords:
Depends on: 19817
Blocks:
  Show dependency treegraph
 
Reported: 2018-10-03 15:46 UTC by Jonathan Druart
Modified: 2018-10-05 12:33 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 21483: Remove translation for "help" (4.31 KB, patch)
2018-10-03 15:49 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Druart 2018-10-03 15:46:06 UTC
% perl translate update es-ES
/home/vagrant/kohaclone/koha-tmpl/intranet-tmpl/prog/en/modules/help: Input must be a directory.

The "help" directory has been removed by bug 19817.
Comment 1 Jonathan Druart 2018-10-03 15:49:11 UTC
Created attachment 79902 [details] [review]
Bug 21483: Remove translation for "help"

% perl translate update es-ES
/home/vagrant/kohaclone/koha-tmpl/intranet-tmpl/prog/en/modules/help:
Input must be a directory.

The "help" directory has been removed by bug 19817.

I kept the "excludes" option even if not used, it could be useful later.

Test plan:
Create, install and update templates for a given language. Make sure the
files are generated correctly.
Comment 2 Julian Maurice 2018-10-04 06:59:14 UTC
*-staff-help.po files are still there. Shouldn't they be removed too ?
Comment 3 Katrin Fischer 2018-10-04 19:59:07 UTC
(In reply to Julian Maurice from comment #2)
> *-staff-help.po files are still there. Shouldn't they be removed 

Good point, Julian. Maybe on another bug?
Comment 4 Julian Maurice 2018-10-05 07:07:12 UTC
Duplicate detected. See bug 21481
Comment 5 Julian Maurice 2018-10-05 12:33:34 UTC
(In reply to Julian Maurice from comment #4)
> Duplicate detected. See bug 21481

Marking this one as duplicate because bug 21481 is now Passed QA

*** This bug has been marked as a duplicate of bug 21481 ***