Bug 21649 - Add child button in the staff client is no longer automatically populating the parent address
Summary: Add child button in the staff client is no longer automatically populating th...
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Patrons (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Target Milestone: ---
Assignee: Nick Clemens
QA Contact: Marcel de Rooy
URL:
Whiteboard:
Keywords: regression
: 21843 (view as bug list)
Depends on: 18789
Blocks:
  Show dependency treegraph
 
Reported: 2018-10-24 17:21 UTC by Margaret
Modified: 2018-12-19 10:17 UTC (History)
9 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 21649: Pass guarantee info to template when adding child (1.07 KB, patch)
2018-11-19 14:48 UTC, Nick Clemens
Details | Diff | Splinter Review
Bug 21649: Pass guarantee info to template when adding child (1.12 KB, patch)
2018-11-21 17:31 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 21649: Pass guarantee info to template when adding child (1.17 KB, patch)
2018-11-21 18:08 UTC, ByWater Sandboxes
Details | Diff | Splinter Review
Bug 21649: Pass guarantee info to template when adding child (1.21 KB, patch)
2018-11-21 18:09 UTC, ByWater Sandboxes
Details | Diff | Splinter Review
Bug 21649: Pass guarantee info to template when adding child (1.31 KB, patch)
2018-11-23 08:07 UTC, Marcel de Rooy
Details | Diff | Splinter Review
Bug 21649: [18.05.X] Pass guarantee info to template when adding child (1.12 KB, patch)
2018-12-10 15:55 UTC, Nick Clemens
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Margaret 2018-10-24 17:21:55 UTC
In 18.05 when a staff member clicks the Add Child button on a Parent's/Guardian's account the main address is not populated on the new patron page. Other details carry over but the main address is empty. 

I tested on a 17.11 instance and the feature works correctly there. 

To Replicate:
1) Install/be running 18.05.04
2) Create or find an adult patron account you want to test with; make sure they have an address - street, city, etc.
3) On the Details tab of the patron's record click on the "+Add child" button.
4) See that the main address text boxes are empty on the /cgi-bin/koha/members/memberentry.pl?op=add&guarantorid=... page. The Guarantor information and Contact information seems to come over, but Address does not.
Comment 1 Nick Clemens 2018-11-19 14:48:50 UTC
Created attachment 82510 [details] [review]
Bug 21649: Pass guarantee info to template when adding child

To test:
1 - Find an adult patron
2 - Click 'Add child'
3 - Note address/phone info does not carry over
4 - Apply patch
5 - Repeat
6 - Note information populates
Comment 2 Nick Clemens 2018-11-19 14:50:38 UTC
*** Bug 21843 has been marked as a duplicate of this bug. ***
Comment 3 Owen Leonard 2018-11-21 17:31:17 UTC
Created attachment 82570 [details] [review]
Bug 21649: Pass guarantee info to template when adding child

To test:
1 - Find an adult patron
2 - Click 'Add child'
3 - Note address/phone info does not carry over
4 - Apply patch
5 - Repeat
6 - Note information populates

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Comment 4 ByWater Sandboxes 2018-11-21 18:08:46 UTC
Created attachment 82571 [details] [review]
Bug 21649: Pass guarantee info to template when adding child

To test:
1 - Find an adult patron
2 - Click 'Add child'
3 - Note address/phone info does not carry over
4 - Apply patch
5 - Repeat
6 - Note information populates

Signed-off-by: Owen Leonard <oleonard@myacpl.org>

Signed-off-by: Todd <tgoatley@gmail.com>
Comment 5 ByWater Sandboxes 2018-11-21 18:09:10 UTC
Created attachment 82572 [details] [review]
Bug 21649: Pass guarantee info to template when adding child

To test:
1 - Find an adult patron
2 - Click 'Add child'
3 - Note address/phone info does not carry over
4 - Apply patch
5 - Repeat
6 - Note information populates

Signed-off-by: Owen Leonard <oleonard@myacpl.org>

Signed-off-by: Todd <tgoatley@gmail.com>

Signed-off-by: Todd <tgoatley@gmail.com>
Comment 6 Marcel de Rooy 2018-11-23 08:07:09 UTC
Created attachment 82597 [details] [review]
Bug 21649: Pass guarantee info to template when adding child

To test:
1 - Find an adult patron
2 - Click 'Add child'
3 - Note address/phone info does not carry over
4 - Apply patch
5 - Repeat
6 - Note information populates

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Signed-off-by: Todd <tgoatley@gmail.com>

Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl>
It works, but the code is ugly and hard to maintain.
Comment 7 Marcel de Rooy 2018-11-23 08:07:49 UTC
Trivial is not the right qualification if you look for $patron, $newdata etc. in memberentry
Comment 8 Nick Clemens 2018-11-26 12:54:37 UTC
Awesome work all!

Pushed to master for 18.11
Comment 9 Christopher Brannon 2018-11-27 23:31:41 UTC
Will this be applied to 18.05?
Comment 10 Lucas Gass 2018-12-10 15:18:20 UTC
This patch does not work for 18.05, not backporting
Comment 11 Nick Clemens 2018-12-10 15:55:44 UTC
Created attachment 83020 [details] [review]
Bug 21649: [18.05.X] Pass guarantee info to template when adding child

To test:
1 - Find an adult patron
2 - Click 'Add child'
3 - Note address/phone info does not carry over
4 - Apply patch
5 - Repeat
6 - Note information populates
Comment 12 Nick Clemens 2018-12-10 15:57:31 UTC
(In reply to Nick Clemens from comment #11)
> Created attachment 83020 [details] [review] [review]
> Bug 21649: [18.05.X] Pass guarantee info to template when adding child
> 
> To test:
> 1 - Find an adult patron
> 2 - Click 'Add child'
> 3 - Note address/phone info does not carry over
> 4 - Apply patch
> 5 - Repeat
> 6 - Note information populates

This should be tested - in 18.05 we are creating a new patron object when creating a new one - testing for borrowernumber seems to confirm it is an 'empty' patron and allow for the pass of the guarantor info
Comment 13 Lucas Gass 2018-12-10 20:17:22 UTC
backported to 18.05 for 18.05.07
Comment 14 Fridolin SOMERS 2018-12-19 10:17:46 UTC
Depends on Bug 18789 not in 17.11.x