Bug 22274 - Self-checkout pages not covered by OPAC CSS changes
Summary: Self-checkout pages not covered by OPAC CSS changes
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Self checkout (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Claire Gravely
QA Contact: Josef Moravec
URL:
Keywords:
: 14000 (view as bug list)
Depends on: 22638
Blocks: 22772
  Show dependency treegraph
 
Reported: 2019-02-05 14:05 UTC by Oliver Behnke
Modified: 2019-04-26 11:58 UTC (History)
7 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:
19.05.00


Attachments
Crude patch for the SCO module (13.19 KB, patch)
2019-02-06 11:17 UTC, Oliver Behnke
Details | Diff | Splinter Review
Bug 22274: Self-checkout/checkin pages not covered by OPAC CSS changes (6.69 KB, patch)
2019-04-10 13:21 UTC, Claire Gravely
Details | Diff | Splinter Review
Bug 22274: Self-checkout/checkin pages not covered by OPAC CSS changes (6.63 KB, patch)
2019-04-11 16:16 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 22274: (follow-up) Use one CSS file for SCO and SCI (17.31 KB, patch)
2019-04-11 16:16 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 22274: Self-checkout/checkin pages not covered by OPAC CSS changes (6.69 KB, patch)
2019-04-16 16:28 UTC, Liz Rea
Details | Diff | Splinter Review
Bug 22274: Self-checkout/checkin pages not covered by OPAC CSS changes (6.69 KB, patch)
2019-04-16 16:29 UTC, Liz Rea
Details | Diff | Splinter Review
Bug 22274: (follow-up) Use one CSS file for SCO and SCI (17.38 KB, patch)
2019-04-16 16:29 UTC, Liz Rea
Details | Diff | Splinter Review
Bug 22274: Self-checkout/checkin pages not covered by OPAC CSS changes (6.73 KB, patch)
2019-04-16 19:43 UTC, Josef Moravec
Details | Diff | Splinter Review
Bug 22274: (follow-up) Use one CSS file for SCO and SCI (17.41 KB, patch)
2019-04-16 19:43 UTC, Josef Moravec
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver Behnke 2019-02-05 14:05:52 UTC
Hi everyone, unfortunately the self-checkout module has been neglected/missed once again and the nice new 18.11 OPAC theme isn't yet applied to it, leading to an inconsistent UI.

Cheers
Comment 1 Oliver Behnke 2019-02-05 14:37:01 UTC
FYI, the same should also apply to the self-checkin module (/koha-tmpl/opac-tmpl/bootstrap/css/sci.css), I presume.
Comment 2 Oliver Behnke 2019-02-06 11:17:13 UTC
Created attachment 84809 [details] [review]
Crude patch for the SCO module

This is a very crude patch for the SCO module. I took the relevant OPAC changes, converted the SCSS to CSS and applied them. Note: it's certainly not meant to be applied as is, as it might still be incomplete or even wrong in places. Yet it should hopefully kickstart and speed up things.

Cheers
Comment 3 Victor Grousset/tuxayo 2019-03-07 16:00:26 UTC
Hi,

Thanks for the finding this and working on it.
Do you seek tester on this patch? Or do you still need to work on it?
Comment 4 Oliver Behnke 2019-03-07 16:16:54 UTC
Hi Victor,

I just uploaded a *crude* patch that was simply meant as a workaround for others having the same problem. It's just a hack that I did to quickly fix our production site. I was hoping that those people responsible for the CSS changes in #20554 or those who developed the SCO/SCI layout would take of this problem and fix it "the right way".

That said, I took that patch as far as I could but I wouldn't move that into testing before someone knowledgeable in the area signed off on it, or ideally, fixed/streamlined it first. For instance, I'm not using SCSS which bloats the code and shouldn't be committed that way.

Thanks
Comment 5 Claire Gravely 2019-03-08 06:31:38 UTC
Hi,

sorry, it is on my to do list. I was on leave and have a busy couple of weeks coming up but will try and get it done ASAP! Thanks for pointing it out!
Comment 6 Oliver Behnke 2019-03-08 08:59:32 UTC
Hi Claire, I didn't mean to be pushy if I came across like that. Just wanted to clarify any potential misunderstandings :-) Glad to have you back!

Cheers
Comment 7 Victor Grousset/tuxayo 2019-03-08 10:50:00 UTC
Thanks for the clarifications, the "new" status with a patch made me fear that there was a risk being forgotten during many months.

But it turns out it's in good hands :)
Comment 8 Claire Gravely 2019-04-10 13:21:21 UTC
Created attachment 87712 [details] [review]
Bug 22274: Self-checkout/checkin pages not covered by OPAC CSS changes

This patch updates the Self-checkout pages to match the new OPAC style.
Comment 9 Oliver Behnke 2019-04-11 13:03:46 UTC
Thanks Claire! I'll check it out and get back to you ASAP
Comment 10 Owen Leonard 2019-04-11 16:16:25 UTC
Created attachment 87779 [details] [review]
Bug 22274: Self-checkout/checkin pages not covered by OPAC CSS changes

This patch updates the Self-checkout pages to match the new OPAC style.

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Comment 11 Owen Leonard 2019-04-11 16:16:29 UTC
Created attachment 87780 [details] [review]
Bug 22274: (follow-up) Use one CSS file for SCO and SCI

This patch makes the self-checkin CSS created in Bug 22638 the CSS for
self-checkout as well. The interfaces have the same requirements.

This patch also replaces some old image-based icons with Font Awesome
icons.

To test, apply the patch and rebuild the OPAC CSS. Clear your browser
cache if necessary.

 - Enable both self checkout (WebBasedSelfCheck) and self checkin
   (SelfCheckInModule).
 - Test both interfaces, confirming that the style is consistent for
   each and looks correct.
Comment 12 Owen Leonard 2019-04-12 11:37:48 UTC
*** Bug 14000 has been marked as a duplicate of this bug. ***
Comment 13 Oliver Behnke 2019-04-16 09:12:51 UTC
Hi Owen, I tried to test the patches on our local test system and a number of hunks didn't apply. What's the baseline version for the patches? I'm on 18.11.04.

Cheers
Comment 14 Oliver Behnke 2019-04-16 12:17:06 UTC
I don't think I can test this properly. The patches are partially rejected on my 18.11.04 test system and I didn't have much luck with various sandboxes either. Either they didn't even get back out of maintenance mode, or I couldn't deploy 22638 and 22274 simulateneously (docker-based SBs / required as they depend on each other) or the patches didn't seem to effective, despite testing 22638 by itself elsewhere did more or less work.
Comment 15 Liz Rea 2019-04-16 16:28:21 UTC
Created attachment 88089 [details] [review]
Bug 22274: Self-checkout/checkin pages not covered by OPAC CSS changes

This patch updates the Self-checkout pages to match the new OPAC style.

Signed-off-by: Owen Leonard <oleonard@myacpl.org>

Signed-off-by: Liz Rea <wizzyrea@gmail.com>
Comment 16 Liz Rea 2019-04-16 16:29:40 UTC
Created attachment 88090 [details] [review]
Bug 22274: Self-checkout/checkin pages not covered by OPAC CSS changes

This patch updates the Self-checkout pages to match the new OPAC style.

Signed-off-by: Owen Leonard <oleonard@myacpl.org>

Signed-off-by: Liz Rea <wizzyrea@gmail.com>
Comment 17 Liz Rea 2019-04-16 16:29:43 UTC
Created attachment 88091 [details] [review]
Bug 22274: (follow-up) Use one CSS file for SCO and SCI

This patch makes the self-checkin CSS created in Bug 22638 the CSS for
self-checkout as well. The interfaces have the same requirements.

This patch also replaces some old image-based icons with Font Awesome
icons.

To test, apply the patch and rebuild the OPAC CSS. Clear your browser
cache if necessary.

 - Enable both self checkout (WebBasedSelfCheck) and self checkin
   (SelfCheckInModule).
 - Test both interfaces, confirming that the style is consistent for
   each and looks correct.

Signed-off-by: Liz Rea <wizzyrea@gmail.com>
Comment 18 Josef Moravec 2019-04-16 19:43:06 UTC
Created attachment 88112 [details] [review]
Bug 22274: Self-checkout/checkin pages not covered by OPAC CSS changes

This patch updates the Self-checkout pages to match the new OPAC style.

Signed-off-by: Owen Leonard <oleonard@myacpl.org>

Signed-off-by: Liz Rea <wizzyrea@gmail.com>

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>
Comment 19 Josef Moravec 2019-04-16 19:43:11 UTC
Created attachment 88113 [details] [review]
Bug 22274: (follow-up) Use one CSS file for SCO and SCI

This patch makes the self-checkin CSS created in Bug 22638 the CSS for
self-checkout as well. The interfaces have the same requirements.

This patch also replaces some old image-based icons with Font Awesome
icons.

To test, apply the patch and rebuild the OPAC CSS. Clear your browser
cache if necessary.

 - Enable both self checkout (WebBasedSelfCheck) and self checkin
   (SelfCheckInModule).
 - Test both interfaces, confirming that the style is consistent for
   each and looks correct.

Signed-off-by: Liz Rea <wizzyrea@gmail.com>

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>
Comment 20 Oliver Behnke 2019-04-17 08:28:45 UTC
Thanks everyone for getting this done. Hopefully future OPAC CSS changes will include tests of the SCI/SCO modules as well :-)

Cheers!
Comment 21 Nick Clemens 2019-04-17 12:28:07 UTC
Awesome work all!

Pushed to master for 19.05
Comment 22 Martin Renvoize 2019-04-26 11:58:58 UTC
Bug with enhancement not in 18.11.x series.