Bug 22286 - When OpacHiddenItems are checked out, link in list of checkouts leads to 404
Summary: When OpacHiddenItems are checked out, link in list of checkouts leads to 404
Status: RESOLVED DUPLICATE of bug 27734
Alias: None
Product: Koha
Classification: Unclassified
Component: ILL (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Bugs List
QA Contact:
URL:
Keywords:
Depends on:
Blocks: 24403
  Show dependency treegraph
 
Reported: 2019-02-07 12:31 UTC by Magnus Enger
Modified: 2021-06-29 11:21 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Magnus Enger 2019-02-07 12:31:04 UTC
For some kinds of ILL you need to create records and items for materials the library receives through ILL, so they ca be lent to patrons in the regular way. Normally, you do not want these records to display or be searchable in the OPAC, because they are not part of the collection of the library. My guess is most libraries will solve this by creating an itemtype called something like ILL, and use OpacHiddenItems to hide these records from browsing and searching in the OPAC. 

When such an item is on loan to the patron it does show up in "my summary" in the OPAC, but the link from the title leads to a 404, which is not ideal. 

A couple of different solutions come to mind:

1. Detect that the item on loan is hidden and don't display the link

2. Detect that the item on loan is hidden and display the record in some other way than through a link to the regular OPAC detail view, for example in a pop-up. 

Thoughts?
Comment 1 Magnus Enger 2021-06-29 11:18:13 UTC
*** Bug 27734 has been marked as a duplicate of this bug. ***
Comment 2 Magnus Enger 2021-06-29 11:21:40 UTC

*** This bug has been marked as a duplicate of bug 27734 ***