Bug 22316 - Double quotes in some patron's attributes breaks patrons search
Summary: Double quotes in some patron's attributes breaks patrons search
Status: RESOLVED DUPLICATE of bug 30055
Alias: None
Product: Koha
Classification: Unclassified
Component: Patrons (show other bugs)
Version: master
Hardware: All All
: P5 - low minor (vote)
Assignee: Bugs List
QA Contact: Testopia
URL:
Keywords:
: 22369 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-02-12 07:28 UTC by Magnus Enger
Modified: 2022-02-09 09:40 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Magnus Enger 2019-02-12 07:28:39 UTC
To reproduce:

- Add a comment with double quotes to the borrowernotes of a patron. 
- Do a patron search that returns a good number of hits, including the patron with the double quote comment
- Sort the table on "Circ cote". This should bring patrons without comments to the top, so it should work. 
- Sort the table on "Circ note" again. This should bring patrons with comments to the top. If the patron with the double quote comment is not in the first page of patrons you might have to click to the "Previous" page one or more times. Eventually you should see the small "Processing" popup never go away. 

The developer tools shows the data benig returned OK from the server, so there is probably some problem when the data is getting shoehorned into the table. 

Tested with 18.11.02. Probably somewhat related to bug 21986.
Comment 1 Jonathan Druart 2019-02-17 15:48:45 UTC
(In reply to Magnus Enger from comment #0)
> Tested with 18.11.02. Probably somewhat related to bug 21986.

I think it's more related to bug 20891.
Comment 2 Jonathan Druart 2019-02-19 13:26:25 UTC
*** Bug 22369 has been marked as a duplicate of this bug. ***
Comment 3 David Roberts 2019-04-14 22:20:46 UTC
I've reproduced this too, but it doesn't affect the patron search on the checkout screen, only the patron search screen.
Comment 4 Jonathan Druart 2022-02-09 09:40:50 UTC
Will be fixed by bug 30055.

*** This bug has been marked as a duplicate of bug 30055 ***