Bug 22374 - Circulation.t noisy since Bug 21753 was pushed
Summary: Circulation.t noisy since Bug 21753 was pushed
Status: RESOLVED DUPLICATE of bug 21747
Alias: None
Product: Koha
Classification: Unclassified
Component: Test Suite (show other bugs)
Version: master
Hardware: All All
: P5 - low minor (vote)
Assignee: Martin Renvoize
QA Contact: Testopia
URL:
Keywords:
: 22356 (view as bug list)
Depends on: 21753
Blocks:
  Show dependency treegraph
 
Reported: 2019-02-20 09:20 UTC by Martin Renvoize
Modified: 2019-03-11 11:42 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 22374: Silence warning in UpdateFine logaction (999 bytes, patch)
2019-02-20 09:28 UTC, Martin Renvoize
Details | Diff | Splinter Review
Bug 22374: Silence warning in UpdateFine logaction (1.05 KB, patch)
2019-02-21 15:22 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 22374: Silence warning in UpdateFine logaction (1.10 KB, patch)
2019-02-25 18:36 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Renvoize 2019-02-20 09:20:01 UTC
I missed a case in the tests!
Comment 1 Martin Renvoize 2019-02-20 09:28:54 UTC
Created attachment 85318 [details] [review]
Bug 22374: Silence warning in UpdateFine logaction

In bug 21753 we replaced the always empty variable $type with undef and
this caused noise in the Circulation.t tests. This patch replaces the
undef with the string 'UPDATE' to reflact that fine updates are taking
place.

Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>
Comment 2 Jonathan Druart 2019-02-21 15:22:49 UTC
Created attachment 85451 [details] [review]
Bug 22374: Silence warning in UpdateFine logaction

In bug 21753 we replaced the always empty variable $type with undef and
this caused noise in the Circulation.t tests. This patch replaces the
undef with the string 'UPDATE' to reflact that fine updates are taking
place.

Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 3 Martin Renvoize 2019-02-25 18:08:15 UTC
*** Bug 22356 has been marked as a duplicate of this bug. ***
Comment 4 Katrin Fischer 2019-02-25 18:36:27 UTC
Created attachment 85651 [details] [review]
Bug 22374: Silence warning in UpdateFine logaction

In bug 21753 we replaced the always empty variable $type with undef and
this caused noise in the Circulation.t tests. This patch replaces the
undef with the string 'UPDATE' to reflact that fine updates are taking
place.

Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 5 Nick Clemens 2019-03-11 10:50:15 UTC
Bug 21747 removed this code, is this still needed?
Comment 6 Martin Renvoize 2019-03-11 11:42:03 UTC
The call to logaction moves to Koha::Account::Line->adjust and it is already set to 'UPDATE' there..

This patch is no longer needed :)

*** This bug has been marked as a duplicate of bug 21747 ***