Bug 22655 - Add setup of a hold rule to the onboarding tool
Summary: Add setup of a hold rule to the onboarding tool
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Installation and upgrade (web-based installer) (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Aleisha Amohia
QA Contact: Testopia
URL:
Keywords:
: 19378 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-04-07 22:45 UTC by Hayley Mapley
Modified: 2020-05-16 15:51 UTC (History)
5 users (show)

See Also:
Change sponsored?: Sponsored
Patch complexity: Small patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:
20.05.00


Attachments
Bug 22655: Adding holds rules to Onboarding tool (4.54 KB, patch)
2020-02-13 02:50 UTC, Aleisha Amohia
Details | Diff | Splinter Review
Bug 22655: Adding holds rules to Onboarding tool (4.61 KB, patch)
2020-02-14 17:06 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 22655: Adding holds rules to Onboarding tool (4.66 KB, patch)
2020-02-21 08:38 UTC, Martin Renvoize
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Hayley Mapley 2019-04-07 22:45:49 UTC
Currently, when doing a fresh install of Koha, no Holds rules are set during the Onboarding process. This means that users testing Holds or new users to Koha have to set up Hold rules in the Tools before placing any Holds. We should allow users to set up default Hold rule while setting up the Circulation rules.
Comment 1 Aleisha Amohia 2020-02-13 02:50:18 UTC
Created attachment 98785 [details] [review]
Bug 22655: Adding holds rules to Onboarding tool

This patch adds the following fields to the circ rule step in the
onboarding tool:
- holds allowed (total)
- holds allowed (daily)
- holds per record (count)

To test:
1) Apply patch, drop and recreate database, restart memcached and refresh page
2) Go through the installer and get to the final step of the onboarding
tool
3) Confirm the above fields are now available to set in your circulation
rule
4) Save and log in to Koha
5) Go to Admin -> Circ and fines rules
6) Confirm the fields saved correctly

Sponsored-by: Catalyst IT
Comment 2 Owen Leonard 2020-02-14 17:06:00 UTC
Created attachment 98981 [details] [review]
Bug 22655: Adding holds rules to Onboarding tool

This patch adds the following fields to the circ rule step in the
onboarding tool:
- holds allowed (total)
- holds allowed (daily)
- holds per record (count)

To test:
1) Apply patch, drop and recreate database, restart memcached and refresh page
2) Go through the installer and get to the final step of the onboarding
tool
3) Confirm the above fields are now available to set in your circulation
rule
4) Save and log in to Koha
5) Go to Admin -> Circ and fines rules
6) Confirm the fields saved correctly

Sponsored-by: Catalyst IT

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Comment 3 Martin Renvoize 2020-02-21 08:38:35 UTC
Created attachment 99358 [details] [review]
Bug 22655: Adding holds rules to Onboarding tool

This patch adds the following fields to the circ rule step in the
onboarding tool:
- holds allowed (total)
- holds allowed (daily)
- holds per record (count)

To test:
1) Apply patch, drop and recreate database, restart memcached and refresh page
2) Go through the installer and get to the final step of the onboarding
tool
3) Confirm the above fields are now available to set in your circulation
rule
4) Save and log in to Koha
5) Go to Admin -> Circ and fines rules
6) Confirm the fields saved correctly

Sponsored-by: Catalyst IT
Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>
Comment 4 Martin Renvoize 2020-02-21 08:38:57 UTC
Works well, passes QA tests..

Passing QA
Comment 5 Martin Renvoize 2020-02-21 16:08:25 UTC
Nice work everyone!

Pushed to master for 20.05
Comment 6 Alex Buckley 2020-02-26 00:18:46 UTC
*** Bug 19378 has been marked as a duplicate of this bug. ***
Comment 7 Joy Nelson 2020-03-13 00:54:09 UTC
enhancement not backported to 19.11.x