Bug 23149 - Unsuspend button in staff interface is confusing
Summary: Unsuspend button in staff interface is confusing
Status: RESOLVED DUPLICATE of bug 29060
Alias: None
Product: Koha
Classification: Unclassified
Component: Hold requests (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Owen Leonard
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-18 17:54 UTC by Nick Clemens
Modified: 2022-01-10 14:05 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nick Clemens 2019-06-18 17:54:19 UTC
When viewing the holds page for  biblio in the staff client it initially says:

'Suspend' until [date] - where suspend is a button and date is a datepicker

if you choose a date and hit 'suspend' it then says

'Unsuspend' on [date] - where unsuspend is a button and the date is the date set above, but offers a date picker


I read 'Unsuspend on date' as an option to set the date the hold will be unsuspended - not as 'Unsuspend now' with an irrelevant date displayed afterwards, which is how it seemingly functions.

Does this make sense to others in its current state?

I would propose:

'Suspend' until [date] - and if you set a date and click suspend it becomes

Suspended until [date] then a new column with 'Unsuspend' as a button
Comment 1 Fridolin Somers 2021-12-16 22:06:12 UTC
Indeed.

Display in catalogue should be like in patrons module :
- Use "Resume" instead of "Unsuspend"
- Use a modal for date entry
Comment 2 Owen Leonard 2022-01-10 14:05:17 UTC

*** This bug has been marked as a duplicate of bug 29060 ***