Bug 23430 - News not inserted with SQL strict modes
Summary: News not inserted with SQL strict modes
Status: RESOLVED DUPLICATE of bug 21066
Alias: None
Product: Koha
Classification: Unclassified
Component: Architecture, internals, and plumbing (show other bugs)
Version: unspecified
Hardware: All All
: P5 - low normal (vote)
Assignee: Bugs List
QA Contact: Testopia
URL:
Keywords:
: 24742 (view as bug list)
Depends on:
Blocks: 17258
  Show dependency treegraph
 
Reported: 2019-08-05 14:36 UTC by Jonathan Druart
Modified: 2020-09-10 18:42 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Druart 2019-08-05 14:36:59 UTC
DBD::mysql::st execute failed: Incorrect integer value: '' for column 'number' at row 1 [for Statement "INSERT INTO opac_news ( title,timestamp,lang,branchcode,content,borrowernumber,number,expirationdate ) VALU
ES ( ?,?,?,?,?,?,?,? )" with ParamValues: 0="OpacNavRight", 1='2019-08-05', 2="OpacNavRight_en", 3=undef, 4="<p>this is the opac nav right</p>", 5="51", 6="", 7=undef] at /home/vagrant/kohaclone/C4/NewsChannels.
pm line 68.
Comment 1 Jonathan Druart 2019-08-05 14:37:35 UTC
Will be fixed by bug 22544.
Comment 2 Owen Leonard 2020-08-10 13:34:04 UTC
*** Bug 24742 has been marked as a duplicate of this bug. ***
Comment 3 Marcel de Rooy 2020-08-10 19:43:24 UTC
Also resolved by bug 21066
Comment 4 Owen Leonard 2020-09-10 18:42:22 UTC

*** This bug has been marked as a duplicate of bug 21066 ***