Bug 24742 - Can't save news item in strict mode without value in number field
Summary: Can't save news item in strict mode without value in number field
Status: RESOLVED DUPLICATE of bug 23430
Alias: None
Product: Koha
Classification: Unclassified
Component: Tools (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Bugs List
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks: 17258
  Show dependency treegraph
 
Reported: 2020-02-27 13:58 UTC by Owen Leonard
Modified: 2020-08-10 13:34 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Leonard 2020-02-27 13:58:32 UTC
If strict mode is enabled, you can't save a news item without putting a number in the "Appears in position" field. The operation fails silently and this error appears in the log:

DBD::mysql::st execute failed: Incorrect integer value: '' for column 'number' at row 1 [for Statement "UPDATE opac_news SET number = ?,expirationdate = ?,lang = ?,timestamp = ?,title = ?,branchcode = ?,content = ? WHERE idnew = ?;" with ParamValues: 0="", ... ] at /kohadevbox/koha/C4/NewsChannels.pm line 106.
Comment 1 Jonathan Druart 2020-03-16 11:36:16 UTC
Will certainly be fixed by bug 22544
Comment 2 Owen Leonard 2020-08-10 13:34:04 UTC

*** This bug has been marked as a duplicate of bug 23430 ***