Bug 23772 - Itemtype icons not showing in table
Summary: Itemtype icons not showing in table
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: System Administration (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Martin Renvoize
QA Contact: Testopia
URL:
Keywords:
Depends on: 20216 23602
Blocks:
  Show dependency treegraph
 
Reported: 2019-10-07 21:22 UTC by Katrin Fischer
Modified: 2019-11-08 14:52 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:
19.11.00


Attachments
Bug 23772: Revert to passing itemtype objects to the template (3.74 KB, patch)
2019-10-11 12:40 UTC, Martin Renvoize
Details | Diff | Splinter Review
Bug 23772: Revert to passing itemtype objects to the template (3.81 KB, patch)
2019-10-11 13:23 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 23772: Revert to passing itemtype objects to the template (3.87 KB, patch)
2019-10-12 10:31 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Katrin Fischer 2019-10-07 21:22:19 UTC
When looking at the new datatable for itemtypes, the itemtype icons are no longer displayed. The same happens, when editing an itemtype - the icon is no longer 'checked'. When you take a look at the db, the file names are there.
Comment 1 Owen Leonard 2019-10-08 13:07:37 UTC
Git bisect says the display problem (icons not showing up in the table) is caused by Bug 23602.

Git bisect says the problem with the correct icon's radio button not being selected arose way back in Bug 20216.
Comment 2 Katrin Fischer 2019-10-08 20:06:54 UTC
Quite some detective work there! Should we split this into 2 separate bugs then?
Comment 3 Martin Renvoize 2019-10-11 12:40:31 UTC
Created attachment 94011 [details] [review]
Bug 23772: Revert to passing itemtype objects to the template

This patch restores the methodology prior to bug 23602 of passing the
full Koha::ItemType objects to the template and thus giving us the
ability to use all the methods present within them.

Test plan:
1) Ensure you have at least one itemtype with an assigned icon and the
   images enabled.
2) View the itemtypes admin page and note the icons display again
3) Ensure you have at least one itemtype with library limitations
   defined.
4) View the itemtypes admin page and note the library limitations still
   display.
5) Signoff
Comment 4 Owen Leonard 2019-10-11 13:23:35 UTC
Created attachment 94016 [details] [review]
Bug 23772: Revert to passing itemtype objects to the template

This patch restores the methodology prior to bug 23602 of passing the
full Koha::ItemType objects to the template and thus giving us the
ability to use all the methods present within them.

Test plan:
1) Ensure you have at least one itemtype with an assigned icon and the
   images enabled.
2) View the itemtypes admin page and note the icons display again
3) Ensure you have at least one itemtype with library limitations
   defined.
4) View the itemtypes admin page and note the library limitations still
   display.
5) Signoff

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Comment 5 Katrin Fischer 2019-10-12 10:31:17 UTC
Created attachment 94035 [details] [review]
Bug 23772: Revert to passing itemtype objects to the template

This patch restores the methodology prior to bug 23602 of passing the
full Koha::ItemType objects to the template and thus giving us the
ability to use all the methods present within them.

Test plan:
1) Ensure you have at least one itemtype with an assigned icon and the
   images enabled.
2) View the itemtypes admin page and note the icons display again
3) Ensure you have at least one itemtype with library limitations
   defined.
4) View the itemtypes admin page and note the library limitations still
   display.
5) Signoff

Signed-off-by: Owen Leonard <oleonard@myacpl.org>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 6 Katrin Fischer 2019-10-12 10:31:33 UTC
Thx for the fix!
Comment 7 Martin Renvoize 2019-10-15 13:16:43 UTC
Nice work!

Pushed to master for 19.11.00
Comment 8 Fridolin SOMERS 2019-11-08 14:52:34 UTC
Depends on Bug 23602 not in 19.05.x