Bug 27101 - Remove fr-CA installer data
Summary: Remove fr-CA installer data
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Installation and upgrade (web-based installer) (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Jonathan Druart
QA Contact: Tomás Cohen Arazi
URL:
Keywords:
: 27620 (view as bug list)
Depends on:
Blocks: 27829
  Show dependency treegraph
 
Reported: 2020-11-26 14:32 UTC by Caroline Cyr La Rose
Modified: 2021-11-04 23:49 UTC (History)
8 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
This enhancement removes fr-CA installer data. Installer data is now in YAML format and there is no need for localized installer files (these are now translated using Koha's translation system using .po files maintained on https://translate.koha-community.org).
Version(s) released in:
21.11.00


Attachments
Bug 27101: Remove fr-CA installer data (685.48 KB, patch)
2021-07-16 08:41 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 27101: Fix sample_notices.t (726 bytes, patch)
2021-07-16 08:41 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 27101: Remove fr-CA installer data (684.22 KB, patch)
2021-10-06 11:44 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review
Bug 27101: Fix sample_notices.t (779 bytes, patch)
2021-10-06 11:44 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review
Bug 27101: Remove fr-CA installer data (684.32 KB, patch)
2021-10-07 06:19 UTC, Marcel de Rooy
Details | Diff | Splinter Review
Bug 27101: Fix sample_notices.t (877 bytes, patch)
2021-10-07 06:19 UTC, Marcel de Rooy
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Caroline Cyr La Rose 2020-11-26 14:32:00 UTC
+++ This bug was initially created as a clone of Bug #24972 +++

Now we can translate all installer data, then the fr-CA directory is no longer needed.
Comment 1 Jonathan Druart 2021-04-09 08:25:31 UTC
*** Bug 27620 has been marked as a duplicate of this bug. ***
Comment 2 Caroline Cyr La Rose 2021-07-13 15:29:36 UTC
Do i simply remove the directories?
Comment 3 Jonathan Druart 2021-07-16 08:41:24 UTC
Created attachment 122876 [details] [review]
Bug 27101: Remove fr-CA installer data

With installer data in YAML format and it's translations,
there are no need for localized installer files.

This patch removes fr-CA installer files.

1) Apply the patch
2) Translate to fr-CA
   cd misc/translator
   ./translate update fr-CA
   ./translate install fr-CA
3) Do a clean install using fr-CA,
   check no problems during install
Comment 4 Jonathan Druart 2021-07-16 08:41:28 UTC
Created attachment 122877 [details] [review]
Bug 27101: Fix sample_notices.t
Comment 5 Jonathan Druart 2021-07-16 08:42:57 UTC
(In reply to Caroline Cyr La Rose from comment #2)
> Do i simply remove the directories?

Yes! I've attached a patch.

The idea is mainly to catch Canadian specific changes that could existed in fr-CA installer files, but I didn't find any!
Comment 6 Tomás Cohen Arazi 2021-10-06 11:44:38 UTC
Created attachment 125776 [details] [review]
Bug 27101: Remove fr-CA installer data

With installer data in YAML format and it's translations,
there are no need for localized installer files.

This patch removes fr-CA installer files.

1) Apply the patch
2) Translate to fr-CA
   cd misc/translator
   ./translate update fr-CA
   ./translate install fr-CA
3) Do a clean install using fr-CA,
   check no problems during install

Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>
Comment 7 Tomás Cohen Arazi 2021-10-06 11:44:43 UTC
Created attachment 125777 [details] [review]
Bug 27101: Fix sample_notices.t

Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>
Comment 8 Marcel de Rooy 2021-10-07 06:19:10 UTC
Created attachment 125853 [details] [review]
Bug 27101: Remove fr-CA installer data

With installer data in YAML format and it's translations,
there are no need for localized installer files.

This patch removes fr-CA installer files.

1) Apply the patch
2) Translate to fr-CA
   cd misc/translator
   ./translate update fr-CA
   ./translate install fr-CA
3) Do a clean install using fr-CA,
   check no problems during install

Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>

Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl>
Comment 9 Marcel de Rooy 2021-10-07 06:19:14 UTC
Created attachment 125854 [details] [review]
Bug 27101: Fix sample_notices.t

Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>

Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl>
Comment 10 Jonathan Druart 2021-10-07 13:48:14 UTC
Pushed to master for 21.11, thanks to everybody involved!