Bug 27287 - Make note fields from orders searchable
Summary: Make note fields from orders searchable
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Acquisitions (show other bugs)
Version: unspecified
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Hayley Pelham
QA Contact: Testopia
URL:
Keywords:
: 12588 (view as bug list)
Depends on: 29298
Blocks:
  Show dependency treegraph
 
Reported: 2020-12-21 09:13 UTC by Katrin Fischer
Modified: 2021-11-29 18:22 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Adds search options for the internal and vendor note fields from the basket to the advanced search form in acquisitions.
Version(s) released in:
21.11.00


Attachments
Bug 27287: Make note fields from orders history searchable (5.13 KB, patch)
2021-08-16 23:37 UTC, Hayley Pelham
Details | Diff | Splinter Review
Bug 27287: Make note fields from orders history searchable (5.14 KB, patch)
2021-08-17 13:09 UTC, David Nind
Details | Diff | Splinter Review
Bug 27287: Make note fields from orders history searchable (5.20 KB, patch)
2021-10-18 11:44 UTC, Nick Clemens
Details | Diff | Splinter Review
Bug 27287: (QA follow-up) Unit tests (3.98 KB, patch)
2021-10-18 11:44 UTC, Nick Clemens
Details | Diff | Splinter Review
Bug 27287: Add new columns to the table settings yml file (764 bytes, patch)
2021-10-21 09:48 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Katrin Fischer 2020-12-21 09:13:19 UTC
It would be nice if the acquisition search allowed to search for the internal and vendor notes from the order lines.
Comment 1 Hayley Pelham 2021-08-16 23:37:13 UTC
Created attachment 123864 [details] [review]
Bug 27287: Make note fields from orders history searchable

This patch adds aqorders.order_internalnote and
aqorders.order_vendornote to the Acquisitions history search.

To test:
1) Apply patch and restart services
2) Create an order in Acquisitions and set an internal note and a vendor note
3) Go to /cgi-bin/acqui/histsearch.pl and search by internal or vendor
note using the terms you set in step 2
4) Note your order is returned and internal note and vendor note are
included in the search results at the end of the table

Sponsored-by: Bibliotheksservice-Zentrum Baden-Wuerttemberg

https://bugs.koha-community.org/show_bug.cgi?id=27827
Comment 2 David Nind 2021-08-17 13:09:43 UTC
Created attachment 123874 [details] [review]
Bug 27287: Make note fields from orders history searchable

This patch adds aqorders.order_internalnote and
aqorders.order_vendornote to the Acquisitions history search.

To test:
1) Apply patch and restart services
2) Create an order in Acquisitions and set an internal note and a vendor note
3) Go to /cgi-bin/acqui/histsearch.pl and search by internal or vendor
note using the terms you set in step 2
4) Note your order is returned and internal note and vendor note are
included in the search results at the end of the table

Sponsored-by: Bibliotheksservice-Zentrum Baden-Wuerttemberg

https://bugs.koha-community.org/show_bug.cgi?id=27827

Signed-off-by: David Nind <david@davidnind.com>
Comment 3 Nick Clemens 2021-10-18 11:44:01 UTC
Created attachment 126428 [details] [review]
Bug 27287: Make note fields from orders history searchable

This patch adds aqorders.order_internalnote and
aqorders.order_vendornote to the Acquisitions history search.

To test:
1) Apply patch and restart services
2) Create an order in Acquisitions and set an internal note and a vendor note
3) Go to /cgi-bin/acqui/histsearch.pl and search by internal or vendor
note using the terms you set in step 2
4) Note your order is returned and internal note and vendor note are
included in the search results at the end of the table

Sponsored-by: Bibliotheksservice-Zentrum Baden-Wuerttemberg

https://bugs.koha-community.org/show_bug.cgi?id=27827

Signed-off-by: David Nind <david@davidnind.com>

Signed-off-by: Nick Clemens <nick@bywatersolutions.com>
Comment 4 Nick Clemens 2021-10-18 11:44:04 UTC
Created attachment 126429 [details] [review]
Bug 27287: (QA follow-up) Unit tests

Signed-off-by: Nick Clemens <nick@bywatersolutions.com>
Comment 5 Jonathan Druart 2021-10-21 09:48:43 UTC
Created attachment 126654 [details] [review]
Bug 27287: Add new columns to the table settings yml file
Comment 6 Jonathan Druart 2021-10-21 10:24:42 UTC
Pushed to master for 21.11, thanks to everybody involved!
Comment 7 Katrin Fischer 2021-11-29 16:59:12 UTC
*** Bug 12588 has been marked as a duplicate of this bug. ***
Comment 8 Noémie Labine 2021-11-29 18:17:54 UTC
Hi everyone ! 

Could this patch also be backported to 21.05 ?

Thank you !
Comment 9 Katrin Fischer 2021-11-29 18:22:36 UTC
Hi Noemie, usually new features like this won't get backported and are only in new major versions, but it's always up to the release maintainer to make the final decision.