Bug 27619 - Remove fr-FR installer data
Summary: Remove fr-FR installer data
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Installation and upgrade (web-based installer) (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL: https://gitlab.com/joubu/Koha/-/commi...
Keywords:
: 30413 (view as bug list)
Depends on: 24871 24973 30373
Blocks: 27829
  Show dependency treegraph
 
Reported: 2021-02-04 08:48 UTC by Martin Renvoize
Modified: 2022-06-24 14:40 UTC (History)
13 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:
22.05.00


Attachments
Bug 27619: FA for UNIMARC and custom for fr-FR (7.83 KB, patch)
2021-06-04 09:56 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 27619: Add custom for fr-FR (3.45 KB, patch)
2022-04-28 10:04 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 27619: Add custom for fr-FR (3.51 KB, patch)
2022-05-03 16:21 UTC, Biblibre Sandboxes
Details | Diff | Splinter Review
Bug 27619: Add custom for fr-FR (3.56 KB, patch)
2022-05-03 16:22 UTC, Biblibre Sandboxes
Details | Diff | Splinter Review
Bug 27619: (QA follow-up) Remove xt/sample_notices.t (4.61 KB, patch)
2022-05-11 10:29 UTC, Martin Renvoize
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Renvoize 2021-02-04 08:48:56 UTC
+++ This bug was initially created as a clone of Bug #24897 +++

Now we can translate all installer data, then the fr-FR directory is no longer needed.
Comment 1 Jonathan Druart 2021-06-04 09:56:46 UTC
Created attachment 121625 [details] [review]
Bug 27619: FA for UNIMARC and custom for fr-FR
Comment 2 Marcel de Rooy 2022-04-01 09:26:05 UTC
This did not move recently.
On bug 2222 I want to remove auth_subfield_structure.frameworkcode.
That gives a lot of changes in especially the fr-FR SQL files.
Would you support doing that first ?
Comment 3 Katrin Fischer 2022-04-01 21:30:16 UTC
(In reply to Marcel de Rooy from comment #2)
> This did not move recently.
> On bug 2222 I want to remove auth_subfield_structure.frameworkcode.
> That gives a lot of changes in especially the fr-FR SQL files.
> Would you support doing that first ?

Hi Marcel, easy to miss, but there is actually some very recent movement here:

This was waiting for the new UNIMARC frameworks (dependency bug 30373). The patches were provided just in time before the hackfest and tests have begun. Once this is solved, it should be relatively easy to resolve this bug.
Comment 4 Marcel de Rooy 2022-04-04 11:45:17 UTC
(In reply to Marcel de Rooy from comment #2)
> This did not move recently.
> On bug 2222 I want to remove auth_subfield_structure.frameworkcode.
> That gives a lot of changes in especially the fr-FR SQL files.
> Would you support doing that first ?

I cant remove that field. Scratch this remark.
Comment 5 Jonathan Druart 2022-04-28 10:04:43 UTC
Created attachment 134213 [details] [review]
Bug 27619: Add custom for fr-FR
Comment 6 Jonathan Druart 2022-04-28 10:05:57 UTC
Patches pushed to https://gitlab.com/joubu/Koha/-/commits/bug_27619
Comment 7 Bernardo Gonzalez Kriegel 2022-04-28 13:09:39 UTC
(In reply to Jonathan Druart from comment #5)
> Created attachment 134213 [details] [review] [review]
> Bug 27619: Add custom for fr-FR

Hi Jonathan, may be a "DELETE FROM `z3950servers`;" is needed before inserting the BNF server, just in case the sample z3950 servers were selected at install time; or just an "INSERT IGNORE", the BNF server is now present in that archive.
Comment 8 Jonathan Druart 2022-04-28 13:22:11 UTC
(In reply to Bernardo Gonzalez Kriegel from comment #7)
> (In reply to Jonathan Druart from comment #5)
> > Created attachment 134213 [details] [review] [review] [review]
> > Bug 27619: Add custom for fr-FR
> 
> Hi Jonathan, may be a "DELETE FROM `z3950servers`;" is needed before
> inserting the BNF server, just in case the sample z3950 servers were
> selected at install time; or just an "INSERT IGNORE", the BNF server is now
> present in that archive.

Indeed, thanks!
I adjusted the remote branch.
Comment 9 Arthur Suzuki 2022-05-03 15:10:25 UTC
Hello,
I've just test that one, I can say it works up to some point.
After installing translation files and refresh (Clear database) the framework is indeed translated to French.
However, it stays in french whatever language I choose for the staff interface.
Is this the expected behaviour? (fine for me).
If it is then I'm happy to signoff :)
Arthur
Comment 10 Arthur Suzuki 2022-05-03 15:12:10 UTC
Can be tested here : 
https://staff-bz27619.sandboxes.biblibre.eu/cgi-bin/koha/mainpage.pl
credentials : koha / XW73vWQpBTN2jVh
Comment 11 Katrin Fischer 2022-05-03 15:52:56 UTC
(In reply to Arthur Suzuki from comment #9)
> Hello,
> I've just test that one, I can say it works up to some point.
> After installing translation files and refresh (Clear database) the
> framework is indeed translated to French.
> However, it stays in french whatever language I choose for the staff
> interface.
> Is this the expected behaviour? (fine for me).
> If it is then I'm happy to signoff :)
> Arthur

Yes, it's totally expected. The installer files are picked according to the language you choose, so if you run the installer in French, the database will be filled with French data. :)
Comment 12 Biblibre Sandboxes 2022-05-03 16:21:58 UTC
Created attachment 134553 [details] [review]
Bug 27619: Add custom for fr-FR

Signed-off-by: liliputech <arthur.suzuki@biblibre.com>
Comment 13 Biblibre Sandboxes 2022-05-03 16:22:15 UTC
Created attachment 134554 [details] [review]
Bug 27619: Add custom for fr-FR

Signed-off-by: liliputech <arthur.suzuki@biblibre.com>

Signed-off-by: liliputech <arthur.suzuki@biblibre.com>
Comment 14 Arthur Suzuki 2022-05-03 16:41:49 UTC
This one has been tested OK!
Changing status to SO.
Comment 15 Jonathan Druart 2022-05-09 07:07:58 UTC
Added Arthur's signed-off-by lines to the remote branch.
Comment 16 Martin Renvoize 2022-05-11 06:34:37 UTC
This all works as expected to me, but I'm not the target audience in terms of the actual translation workflows.. I'm more the target in terms of streamlining work for devs ;P

Feel free to add my SO line on top of Arthurs.. and lets be brave and go for it on this one.

Passing QA
Comment 17 Martin Renvoize 2022-05-11 09:08:41 UTC
Jonathan and I were keen to see this in and watch the test suit/start responding to any issues that present...

So, whilst I grabbed the branch to add my QA stamp and went bold and pushed this as an RM Assistant.

Thanks to everyone involved, Pushed to Master for 22.05.00!
Comment 18 Martin Renvoize 2022-05-11 10:29:20 UTC
Created attachment 134861 [details] [review]
Bug 27619: (QA follow-up) Remove xt/sample_notices.t

Now that we've remove the last of the translated .sql files, we can just
drop this test entirely.. translation is now handled on pootle for all
languages.   Woopie! :)

Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>
Comment 19 Jonathan Druart 2022-06-08 09:29:04 UTC
*** Bug 30413 has been marked as a duplicate of this bug. ***