Bug 27856 - Update mappings.yaml after bug 27316
Summary: Update mappings.yaml after bug 27316
Status: RESOLVED DUPLICATE of bug 28279
Alias: None
Product: Koha
Classification: Unclassified
Component: Searching - Elasticsearch (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Fridolin Somers
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-03-04 09:49 UTC by Fridolin Somers
Modified: 2021-05-03 13:06 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 27856: Update mappings.yaml after bug 27316 (102.19 KB, patch)
2021-03-04 10:10 UTC, Fridolin Somers
Details | Diff | Splinter Review
Bug 27856: Update mappings.yaml after bug 27316 (102.25 KB, patch)
2021-03-31 10:22 UTC, Julian Maurice
Details | Diff | Splinter Review
Bug 27856: Update mappings.yaml after bug 27316 (102.31 KB, patch)
2021-04-27 13:50 UTC, Martin Renvoize
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Fridolin Somers 2021-03-04 09:49:07 UTC
Bug 27316 has changed sort to 0/1 in Elasticsearch mappings.
This should be updated in mappings.yaml
Comment 1 Fridolin Somers 2021-03-04 10:10:14 UTC
Created attachment 117667 [details] [review]
Bug 27856: Update mappings.yaml after bug 27316

Bug 27316 has changed sort to 0/1 in Elasticsearch mappings.
This should be updated in mappings.yaml

Test plan:
1) Reset mappings
2) Check sort values 0 and 1 are ok in searchengine config
Comment 2 Fridolin Somers 2021-03-04 10:11:02 UTC
Done with :

sed -i 's/sort: ~/sort: 1/g' admin/searchengine/elasticsearch/mappings.yaml
Comment 3 Julian Maurice 2021-03-31 10:22:04 UTC
Created attachment 119035 [details] [review]
Bug 27856: Update mappings.yaml after bug 27316

Bug 27316 has changed sort to 0/1 in Elasticsearch mappings.
This should be updated in mappings.yaml

Test plan:
1) Reset mappings
2) Check sort values 0 and 1 are ok in searchengine config

Signed-off-by: Julian Maurice <julian.maurice@biblibre.com>
Comment 4 Julian Maurice 2021-03-31 10:23:27 UTC
Trivial patch that should have been part of bug 27316. Signed off
Comment 5 Martin Renvoize 2021-04-27 13:50:55 UTC
Created attachment 120231 [details] [review]
Bug 27856: Update mappings.yaml after bug 27316

Bug 27316 has changed sort to 0/1 in Elasticsearch mappings.
This should be updated in mappings.yaml

Test plan:
1) Reset mappings
2) Check sort values 0 and 1 are ok in searchengine config

Signed-off-by: Julian Maurice <julian.maurice@biblibre.com>
Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>
Comment 6 Martin Renvoize 2021-04-27 13:51:18 UTC
Doh, thanks for the fix Fridolin.

Passing QA
Comment 7 Jonathan Druart 2021-04-28 08:59:51 UTC
I'd like an answer on bug 25325 comment 18 before pushing this one.
Comment 8 Jonathan Druart 2021-05-03 13:06:08 UTC

*** This bug has been marked as a duplicate of bug 28279 ***