Bug 28156 - Koha::Account::Line->renewable must be named is_renewable
Summary: Koha::Account::Line->renewable must be named is_renewable
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Architecture, internals, and plumbing (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Keywords:
Depends on: 23051 25508
Blocks: 27995
  Show dependency treegraph
 
Reported: 2021-04-16 10:09 UTC by Jonathan Druart
Modified: 2021-04-25 20:50 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Text to go in the release notes:
Version(s) released in:
21.05.00,20.11.05,20.05.11


Attachments
Bug 28156: Rename Koha::Account::Line->renewal with is_renewal (3.91 KB, patch)
2021-04-16 10:13 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 28156: Rename Koha::Account::Line->renewal with is_renewal (3.96 KB, patch)
2021-04-16 13:51 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 28156: Rename Koha::Account::Line->renewal with is_renewal (4.11 KB, patch)
2021-04-16 14:15 UTC, Joonas Kylmälä
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Druart 2021-04-16 10:09:32 UTC
It's returning a boolean.
Comment 1 Jonathan Druart 2021-04-16 10:13:49 UTC
Created attachment 119703 [details] [review]
Bug 28156: Rename Koha::Account::Line->renewal with is_renewal

It's a boolean, it must be named is_*

Test plan:
Confirm that
  prove t/db_dependent/Koha/Account/Line.t
is still returning green
Comment 2 Owen Leonard 2021-04-16 13:51:04 UTC
Created attachment 119742 [details] [review]
Bug 28156: Rename Koha::Account::Line->renewal with is_renewal

It's a boolean, it must be named is_*

Test plan:
Confirm that
  prove t/db_dependent/Koha/Account/Line.t
is still returning green

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Comment 3 Joonas Kylmälä 2021-04-16 14:15:00 UTC
Created attachment 119751 [details] [review]
Bug 28156: Rename Koha::Account::Line->renewal with is_renewal

It's a boolean, it must be named is_*

Test plan:
Confirm that
  prove t/db_dependent/Koha/Account/Line.t
is still returning green

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Signed-off-by: Joonas Kylmälä <joonas.kylmala@helsinki.fi>
Comment 4 Jonathan Druart 2021-04-16 14:31:43 UTC
Pushed to master for 21.05, thanks to everybody involved!
Comment 5 Fridolin Somers 2021-04-22 14:39:30 UTC
Pushed to 20.11.x for 20.11.05
Comment 6 Andrew Fuerste-Henry 2021-04-25 16:59:44 UTC
Pushed to 20.05.x for 20.05.11
Comment 7 Victor Grousset/tuxayo 2021-04-25 20:50:44 UTC
Not backported to oldoldstable (19.11.x). Feel free to ask if it's needed.