Bug 28312 - We should not assume hold pickup branch = ReservesControlBranch when checking it holds are allowed
Summary: We should not assume hold pickup branch = ReservesControlBranch when checking...
Status: RESOLVED DUPLICATE of bug 28338
Alias: None
Product: Koha
Classification: Unclassified
Component: Hold requests (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Tomás Cohen Arazi
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-05-10 18:35 UTC by Andrew Fuerste-Henry
Modified: 2021-05-13 14:13 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Fuerste-Henry 2021-05-10 18:35:42 UTC
To replicate:
- Have branches A & B
- In the Libraries setup, set A to be a pickup location, B to not be a pickup location
- Set ReservesControl to Item's Home Library
- Have a bib with two items, one owned by each branch
- Confirm circ rules say all items on your bib are holdable by all patrons
- On your bib, try to place a hold via the intranet
- Confirm Koha allows a hold on the bib or on the Branch A item, but the Branch B item gives the message "libraryNotPickupLocation"

As Koha checks whether each hold is allowed, it assumes a pickup branch of whatever's indicated by ReservesControl. So it assumes the Branch A item would be a hold for pickup at Branch A (allowed location) and the hold for the Branch B item would be for pickup at Branch B (un-allowed location). But that assumption is wrong.
Comment 1 Andrew Fuerste-Henry 2021-05-11 12:08:23 UTC
Oh, one more thing: This only impacts holds placed via the intranet. If you follow those same steps but place the hold via the OPAC you will not get an error.
Comment 2 Tomás Cohen Arazi 2021-05-12 20:19:29 UTC
Please, ponder the global solution proposed on bug 28338.
Comment 3 Andrew Fuerste-Henry 2021-05-13 14:13:07 UTC

*** This bug has been marked as a duplicate of bug 28338 ***
Comment 4 Andrew Fuerste-Henry 2021-05-13 14:13:38 UTC
Tomas's work on 28338 solves this problem along with some other things.